cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1800
Views
0
Helpful
4
Replies
Highlighted
Beginner

Problem configuring Port Channel for VSS

Hi,

Im trying to configure VSS on Cisco 6840 Switch. 

here are the commands i entered these commands 

SW1(config)#switch virtual domain 10
SW1(config-vs-domain)#switch 1
SW1(config-vs-domain)#exit
SW1(config)#
SW1(config)#int port-channel 5
SW1(config-if)#switchport
SW1(config-if)#switch virtual link 1
SW1(config-if)#no shut
SW1(config-if)#exit
SW1(config)#int range te 1/0/35 - 36
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#channel-group 5 mode on

But im not able to configure port-channel on those two ports.

this is the error im getting

Command rejected (Port-channel5, Te1/35): Either port is L2 and port-channel is L3, or vice-versa

% Range command terminated because it failed on TenGigabitEthernet1/35

i tried using Active instead of on but i got the same output

this is my version

c6848x-ipservicesk9_npe-mz.SPA.152-2.SY2.bin
(c6848x-IPSERVICESK9_NPE-M), Version 15.2(2)SY2

c6848x-ipservicesk9_npe-mz.SPA.152-2.SY2.bin
c6848x-IPSERVICESK9_NPE-M), Version 15.2(2)SY2

any idea what might be wrong?

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Collaborator

I don't see, nor do I think,

I don't see, nor do I think, that you should be configuring the virtual link interfaces as trunks. That might be your problem:

http://www.cisco.com/c/en/us/td/docs/solutions/Enterprise/Campus/VSS30dg/campusVSS_DG/VSS-dg_appa-configs.pdf

4 REPLIES 4
VIP Collaborator

I don't see, nor do I think,

I don't see, nor do I think, that you should be configuring the virtual link interfaces as trunks. That might be your problem:

http://www.cisco.com/c/en/us/td/docs/solutions/Enterprise/Campus/VSS30dg/campusVSS_DG/VSS-dg_appa-configs.pdf

Beginner

your are right there's no

your are right there's no need to configure VSL Ports as Trunks.

here's my new config 

#switch virtual domain 10
#mac-address use-virtual
#switch 1
#switch 1 priority 110
#switch 2 priority 100
#interface port-channel 1
#no shut
#switch virtual link 1
#ex

#int ra te 1/35 - 36
#channel-group 1 mode on
#no sh


#switch virtual domain 10
#mac-address use-virtual
#switch 2
#switch 1 priority 110
#switch 2 priority 100
#interface port-channel 2
#no shut
#switch virtual link 2
#ex

#int ra te 1/35 - 36
#channel-group 2 mode on
#no sh

#switch convert mode virtual
#switch convert mode virtual

#show switch virtual
Switch mode : Virtual Sw
Virtual switch domain number : 10
Local switch number : 1
Local switch operational role: Virtual Sw
Peer switch number : 2
Peer switch operational role : Virtual Sw

#show switch virtual link
VSL Status : UP
VSL Uptime : 2 hours, 49 minutes
VSL SCP Ping : Pass
VSL ICC Ping : Pass
VSL Control Link : Te1/1/36

#show switch virtual role
RRP information for Instance 1

-----------------------------------------
Valid Flags Peer Preferred Reser
Count Peer Peer

-----------------------------------------
TRUE V 1 1 1

Switch Switch Status Priority
Number Oper(Conf)
-----------------------------------------
LOCAL 1 UP 110(110)
REMOTE 2 UP 100(100)

Peer 0 represents the local switch

Flags : V - Valid


In dual-active recovery mode: No

Thanks for the help..

VIP Mentor

Hello,

Hello,

I don't think the error is related to VSS, but rather to the order of operations when configuring the channel. I would do the following (on both switches):

1. remove interface port-channel 5

2. default all interfaces that are in the port-channel (default interface)

3. shut all interfaces

4. create port-channel interface

5. bind the channel (5) to the member ports (mode on)

5. configure trunking on the port-channel interface

6. unshut all interfaces

So the whole procedure would look like this:

SW1#conf t
SW1(config)#no interface port-channel 5
SW1(config)#default interface TenGigabitEthernet1/0/35
SW1(config)#default interface TenGigabitEthernet1/0/36
SW1(config)#int TenGigabitEthernet1/0/35
SW1(config-if)#shut
SW1(config-if)#exit
SW1(config)#int TenGigabitEthernet1/0/36
SW1(config-if)#shut
SW1(config-if)#exit
SW1(config)#interface port-channel 5
SW1(config-if)#exit
SW1(config)#int TenGigabitEthernet1/0/35
SW1(config-if)#channel-group 5 mode on
SW1(config-if)#exit
SW1(config)#int TenGigabitEthernet1/0/36
SW1(config-if)#channel-group 5 mode on
SW1(config-if)#exit
SW1(config)#interface port-channel 5
SW1(config-if)#switchport mode trunk
SW1(config-if)#exit
SW1(config)#int TenGigabitEthernet1/0/35
SW1(config-if)#no shut
SW1(config-if)#exit
SW1(config)#int TenGigabitEthernet1/0/36
SW1(config-if)#no shut
SW1(config-if)#exit
SW1(config)#end

VIP Expert

Hi,

Hi,

The VSL links do not need to be configured as trunk.

See example:

interface Port-channel5
 no switchport
 no ip address
 switch virtual link 1

HTH

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards