07-05-2017 01:54 AM - edited 03-08-2019 11:12 AM
Hi,
I want to configure a little network where I have 1 Router Linksys and 2 Catalyst C3650-24TS.
I have the next picture.
ip routing
!!
!
!
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
negotiation auto
!
interface GigabitEthernet1/0/1
description "Telefonica router ISP fiber"
no switchport
ip address 10.0.0.1 255.255.0.0
no shutdown
exitinterface GigabitEthernet1/0/2
switchport mode access
duplex full
!
interface GigabitEthernet1/0/17
duplex full
switchport mode trunkswitchport trunk allowed vlan 1-3,10,20,30,40,50,1002-1005
no shutdown
!
interface Vlan1
description vlan1
ip address 192.168.1.1 255.255.0.0
ip nat inside
no shutdown
interface Vlan10
description vlan10
ip address 172.16.0.254 255.255.0.0
ip nat inside
no shutdown
interface Vlan20
description vlan20
ip address 172.17.0.254 255.255.0.0
ip nat inside
no shutdown
ip route 0.0.0.0 0.0.0.0 10.0.0.254 200access-list 1 permit 192.168.0.0 0.0.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 1 permit 172.17.0.0 0.0.255.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.11.0 0.0.0.255
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 23 permit 192.168.11.0 0.0.0.255
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 23 permit 172.16.0.0 0.0.255.255
access-list 23 permit 172.17.0.0 0.0.255.255
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 permit ip 192.168.8.0 0.0.0.255 any
access-list 101 permit ip 192.168.10.0 0.0.0.255 any
access-list 101 permit ip 192.168.11.0 0.0.0.255 any
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
access-list 101 permit ip 172.16.0.0 0.0.255.255 any
access-list 101 permit ip 172.17.0.0 0.0.255.255 any!
!
When I do one ping to the router, I haven´t any respond to me. I don´t know if The interVlan is not working or anything else.
Could anybody help me, please?
Regards.
Solved! Go to Solution.
07-05-2017 02:12 AM
Hi the nat should be done on the router not the switch , catalyst don't support nat
also you Linksys router needs a static route back to the switch so it can return traffic back
remove this too the 200 at the end , its the only route so does not need to be weighted
ip route 0.0.0.0 0.0.0.0 10.0.0.254
07-05-2017 02:12 AM
Hi the nat should be done on the router not the switch , catalyst don't support nat
also you Linksys router needs a static route back to the switch so it can return traffic back
remove this too the 200 at the end , its the only route so does not need to be weighted
ip route 0.0.0.0 0.0.0.0 10.0.0.254
07-07-2017 12:27 AM
Hi Mark,
the problem was the static route in the router. It is working fine now.
Thanks!
Regards.
07-07-2017 12:39 AM
great , glad you got it sorted
07-05-2017 05:25 AM
Hi
Is the subnet mask correct on the point to point with the router? You have a /16 - 255.255.0.0
As Mark mentioned, usually the switches dont support NAT (there are some exceptions like 6500 and some 5000 switches)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide