cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
549
Views
0
Helpful
5
Replies

Problem with EIGRG doesn´t work

blisteink4m
Level 1
Level 1

Hello I am trying to use EIGRP on Packet Tracert but i don´t get, this is my topology

Topology.JPG

These are the config files

R1

 

!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R1
!
!
!
enable password 7 0822455D0A16
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524JHHA
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.1.1.2 255.255.255.252
 clock rate 128000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 192.168.20.0
 network 10.1.1.0 0.0.0.3
 network 192.168.10.0
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd 
acceso restringido
!
!
!
!
line con 0
 logging synchronous
!
line aux 0
!
line vty 0 4
 password 7 0822455D0A16
 login
 transport input telnet
line vty 5 15
 password 7 0822455D0A16
 login
 transport input telnet
!
!
!
end

ISP

!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname ISP
!
!
!
enable password 7 0822455D0A16
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15248ZCZ
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.1.1.2 255.255.255.252
!
interface Serial0/0/1
 ip address 10.2.2.2 255.255.255.252
 clock rate 128000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 10.1.1.0 0.0.0.3
 network 10.2.2.0 0.0.0.3
 network 209.165.200.0 0.0.0.31
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
banner motd 
banner motd 
!
!
!
!
line con 0
 logging synchronous
!
line aux 0
!
line vty 0 4
 password 7 0822455D0A16
 login
 transport input telnet
line vty 5 15
 password 7 0822455D0A16
 login
 transport input telnet
!
!
!
end

R3

!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname R3
!
!
!
enable password 7 0822455D0A16
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX152474D8
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.40.1 255.255.255.0
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.30.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/0/1
 ip address 10.2.2.1 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 192.168.30.0
 network 192.168.40.0
 10.2.2.1 0.0.0.3
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd 
acceso restringido 
!
!
!
!
line con 0
 logging synchronous
!
line aux 0
!
line vty 0 4
 password 7 0822455D0A16
 login
 transport input telnet
line vty 5 15
 password 7 0822455D0A16
 login
 transport input telnet
!
!
!
end

I check the file but i dont´t find any error, when I execute show ip route eigrp I haven´t any route to remote router with EIGRP protocols

 

 

5 Replies 5

burleyman
Level 8
Level 8

Double check all you interface IP configurations and you will see the issue. I can give you the answer but if you are studying it will help for you to track it down.

 

There are also some errors in the EIGRP config as well but start with the interfaces.

 

Mike

ISP router looks to be missing 10 range back to R1 in eigrp process , also the public ip address is being advertised in R3 would have thought that would be the ISP router itself

add to ISP router
network 10.1.1.0 0.0.0.3

is this correct in R3
network 209.165.200.0 0.0.0.31

also you have loopbacks advertised in ISP eigrp that are not actually there but would belong in r1 and r3 to be advertised

As Mike has said there in his post check the interfaces that are in the devices and also whats actually being advertised on the eigrp process locally for that device , each interface should have a corresponding advertisement

Predrag Jovic
Level 3
Level 3

R1

interface Serial0/0/0
 ip address 10.1.1.2 255.255.255.252

ISP

interface Serial0/0/0
 ip address 10.1.1.2 255.255.255.252

Overlapping IP addresses

 

 

This should work.

ISP

int s0/0/0
description Link to R1
ip address 10.1.1.2 255.255.255.252
no shut

int s0/0/1
description Link to R3
ip address 10.2.2.2 255.255.255.252

router eigrp 10
network 10.1.1.0 0.0.0.3
network 10.2.2.0 0.0.0.3

***************************************
R1

int s0/0/0
description Link to ISP
ip address 10.1.1.1 255.255.255.252
no shut

int gi0/1
description Link to Switch 1
ip address 192.168.10.1 255.255.255.0
no shut

int loopback 0
ip address 192.168.20.1 255.255.255.0

router eigrp 10
network 10.1.1.0 0.0.0.3
network 192.168.10.0 0.0.0.255
network 192.168.20.0 0.0.0.255

***************************************
R3
192.168.20.
int ser0/0/1
description Link to ISP
ip address 10.2.2.1 255.255.255.252
no shut

int gi0/1
description Link to Switch 3
ip address 192.168.30.1 255.255.255.0
no shut

int loopback 0
ip address 192.168.40.1 255.255.255.0

router eigrp 10
network 10.2.2.0 0.0.0.3
network 192.168.30.0 0.0.0.255
network 192.168.40.0 0.0.0.255

This was in your config on the ISP router but it is not on the drawing.

network 209.165.200.0 0.0.0.31

Mike

Review Cisco Networking for a $25 gift card