cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1317
Views
0
Helpful
4
Replies

QnQ Looping

lmanavalan
Level 1
Level 1

Hi,

I have configured 2 QnQ in parallel as shown in the attachment diagram. But some reason its causing a loop in spite i have the spanning-tree configured with high cost.

can i configure 2 interface connected to the same switch with same vlan 3505 or do i have to use different vlans say vlan 3505 and 3506

Below is the logs

Apr 24 00:01:06.284 UTC: %PM-SP-4-ERR_DISABLE: l2ptguard error detected on Gi1/1, putting Gi1/1 in err-disable state
Apr 24 00:01:06.456 UTC: %PM-SPSTBY-4-ERR_DISABLE: l2ptguard error detected on Gi1/1, putting Gi1/1 in err-disable state
Apr 24 00:01:07.456 UTC: %SYS-SPSTBY-3-LOGGER_FLUSHED: System was paused for 3y30w to ensure console debugging output.
Apr 24 00:02:11.529 UTC: %QNQ-6-NATIVE_VLAN_TAGGING: Please enable the native VLAN tagging feature for proper functioning of the Q-in-Q service.

regards

Logesh

4 Replies 4

Philip D'Ath
VIP Alumni
VIP Alumni

Which device generated the %QNQ-6-NATIVE_VLAN_TAGGING error?

Why not form a LACP Etherchannel instead and make it loop free?

Hi

the ISP Switch A is spitting the error. I can configure the port at the ISP Switch A but, on the other end 2 different switch is connected to Customer switch 2.

Thanks

Logesh

Adding more info

aftet bring up the second link the customer service got affected and also lost access to the ISP Switch 2 and 3 

thanks

logesh

Hi

To resolve the issue instead of using the same vlan 3505 on Switch A i used vlan 3505 on interface gi1/1 and vlan gi 2/1 on interface 2/1. Everything was working fine for a while.

But the issue came back again. This time i found that the dot1q tunnel is automatically adding the command "spanning-tree BPDU filter enable" on the interface.

i expecenced the same errors in the log

%PM-SP-4-ERR_DISABLE: l2ptguard error detected on Gi1/1, putting Gi1/1 in err-disable state
%PM-SP-4-ERR_DISABLE: l2ptguard error detected on Gi2/1, putting Gi2/1 in err-disable state
%PM-SPSTBY-4-ERR_DISABLE: l2ptguard error detected on Gi1/1, putting Gi1/1 in err-disable state
%PM-SPSTBY-4-ERR_DISABLE: l2ptguard error detected on Gi2/1, putting Gi2/1 in err-disable state

its been mentioned to add the vlan tag native vlan. How this could help resolve the issue.

Regards

Logesh

Review Cisco Networking for a $25 gift card