cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
534
Views
0
Helpful
2
Replies

QoS vs trunk port

digit
Level 1
Level 1

Need to policing / shapping Internet connection to priorize some traffic from specific host.

 

Cisco 1941 as core router

Multiple offices connected to a MPLS network through telco router

Each office have Internet connection (30Mb/30Mb)

VLAN on trunk port LAN side.

MPLS to VLANs must be full speed

VLAN to VLAN must be full speed

INTERNET to VLANs must be shaped.

 

As I understand it, shaping need to be egress, here g0/0/0 port.  The idea is to throttle Internet at 30Mbits and later on do some sub-shaping of that 30Mbits.

 

Did an lab test to see if I can throttle internet connection down to 1Mbs, but it fail.  I’m still downloading at 30Mbits, no throttling as expected.  Something wrong because port is trunk ?  Any workaround ?  Is it broken by design ?

 

# Tag Traffic from Internet (MPLS need to be full speed)
class-map match-any cmap-internet
 match input-interface GigabitEthernet0/1

# Throttle to 1Mbits
policy-map pmap-internet
 class cmap-internet
  shape average 1024000

# Hopefully throttle VLANs total bandwidth to INTERNET at 1Mbits and allow full speed VLAN-to-VLAN and VLANs-to-MPLS
interface g0/0/0
 service-policy out pmap-internet

 

cisco.png

2 Replies 2

Paul Smith
Level 1
Level 1

If you are testing download speed you will need to change to service-policy in pmap-internet on the external interface ( gig 0/0/0). Alternatively you can do service-policy out pmap-internet on gig 0/1.

Paul,

 

Terminology: I use word "download" for workstation using speedtest.net on LAN point of view where external interface is g0/1 and internal is g0/0/0.

Data from Internet that goest IN g0/1 to Lan workstation OUT g0/0/0 trunk (Vlan1).  Policing need to be egress, so "service-policy out pmap-internet" on g0/0/0

unfortunatly I still get 30Mbits

 

# Tag Traffic from Internet (MPLS need to be full speed)
class-map match-any cmap-internet
 match input-interface GigabitEthernet0/1
!
# Throttle to 1Mbits
policy-map pmap-internet
 class cmap-internet
  shape average 1024000
!
interface GigabitEthernet0/1
 description INTERNET
 ip address 1.1.1.1 255.255.255.248
 ...
!
interface GigabitEthernet0/0/0
 description Trunk LAN
 switchport mode trunk
 no ip address
 service-policy out pmap-internet
 ...
!
interface Vlan1
 description LAN
 ip address 10.101.1.1 255.255.255.0
 ...

 

Review Cisco Networking for a $25 gift card