03-08-2009 03:04 PM - edited 03-06-2019 04:27 AM
I need to set the DSCP value of packets arriving at a switch port to EF. This is for a 3750 running IOS version 12.2(25)SEB4.
I have the following configuration..
access-list 105 permit udp host 10.16.3.5 any
class-map match-all voip
match access-group 105
!
!
policy-map setdscp
class voip
set dscp ef
interface FastEthernet1/0/22
description VOIP GW 10.6.1.35
switchport access vlan 250
switchport mode access
switchport voice vlan 250
ip access-group 105 in
service-policy input setdscp
spanning-tree portfast
UDP packets are not being marked with DSCP = EF
Any suggestions / corrections would be very helpful.
Thanks
03-08-2009 03:25 PM
If I am reading your configuration right, then it looks like your VOIP network is hanging off Fastethernet1/0/22.
This would mean that the host 10.16.3.5 hangs on a different interface?.
If this is the case, then you should really move the service-policy inbound to the interface/SVI that the host hangs off.
If you just want to get this working (and I have read your config right), then change the service policy and access-group command to output on interface FastEthernet1/0/22, ie
interface FastEthernet1/0/22
description VOIP GW 10.6.1.35
switchport access vlan 250
switchport mode access
switchport voice vlan 250
ip access-group 105 out
service-policy output setdscp
spanning-tree portfast
Add a log statement to the end of your ACL to see if you are getting any hits also but take this off once you have finished as if forces a CEF punt.
As a side note, it is always better to mark inbound and shape/police/queue outbound.
03-08-2009 03:36 PM
The VOIP gateway 10.6.1.35 is on port Fa1/0/22.
The gateway has a PRI circuit on it - so when a call arrives on thet PRI line it goes through the gateway and arrives on the 3750 port. I'm trying to mark the packets that entering the 3750 with dscp = ef so that as those packets traverse our intersite MPLS network they ride over the high priority queue.
03-08-2009 04:24 PM
Is this a typo , you have a description under the interface -
description VOIP GW 10.6.1.35
and yet your acl references 10.16.1.35 ie.
10.6.1.35 does not equal 10.16.1.35
are you seeing any hits on acl 105 ?
Jon
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide