cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
572
Views
10
Helpful
5
Replies

Simple NAT Translation

jfraasch
Level 3
Level 3

I am trying to NAT a webserver to a routable IP address.  I just have the server directly plugged into my router and need to NAT its IP (172.30.194.131) to the other side of the router (172.30.180.28).

Here is the config:

interface FastEthernet0/0
ip address 172.30.180.25 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.30.194.135 255.255.255.192
ip nat outside
duplex auto
speed auto

!
ip route 0.0.0.0 0.0.0.0 172.30.180.1
!
no ip http server
ip nat inside source static 172.30.194.131 172.30.180.28
ip nat outside source static 172.30.194.131 172.30.180.28

That's it.

Now, my pings work fine and when I show IP NAT Translations I can see the translation table.  But I cannot HTTP to the same IP address.  I don't think there is anything special to do with HTTP.  Any thoughts?


James

1 Accepted Solution

Accepted Solutions

mrdogantr
Level 1
Level 1

Hi,

access-list 20 permit WEB_SERVER_LOCAL_IP

ip nat pool websrv WEB_SERVER_PUBLIC_IP  WEB_SERVER_LOCAL_IP netmask 255.255.255.252

ip nat inside source list 20 pool websrv overload

ip nat inside source static tcp WEB_SERVER_LOCAL_IP 80 WEB_SERVER_PUBLIC_IP 80

hth

Muammer

View solution in original post

5 Replies 5

mrdogantr
Level 1
Level 1

Hi,

access-list 20 permit WEB_SERVER_LOCAL_IP

ip nat pool websrv WEB_SERVER_PUBLIC_IP  WEB_SERVER_LOCAL_IP netmask 255.255.255.252

ip nat inside source list 20 pool websrv overload

ip nat inside source static tcp WEB_SERVER_LOCAL_IP 80 WEB_SERVER_PUBLIC_IP 80

hth

Muammer

So you are saying I need a specific NAT for HTTP?

I will give it a shot.


James

Hi James,

don't need a specific NAT, you can try,

ip nat inside source static tcp WEB_SERVER_LOCAL_IP 80 WEB_SERVER_PUBLIC_IP 80

or

ip nat inside source static WEB_SERVER_LOCAL_IP  WEB_SERVER_PUBLIC_IP

hth

Muammer

Hi James,

you can define simple nat like below to be able to connect that nated server through http (80)

ip nat inside source static tcp 10.50.50.52 80 196.27.24.79 80 extendable

Please rate if this helped you...

Regards,

Naidu.

It was much easier than this.

I had it right. The server team had the wrong default gateway.  My NAT Translations were looking all good and everything so I couldn't figure it out until I started at the bottom and worked my way up.

Since this is a test box only on the inside corporate network I didnt need the port 80 only open.

Thanks for the help!


James

Review Cisco Networking for a $25 gift card