cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
93
Views
0
Helpful
0
Replies

Some helpful packet tracer commands I have to share

ghet_69
Beginner
Beginner

LAYER 3 SWITCH

  1. For L3 switch:

Switch(config)#ip routing

2. We enable operation and communication between different VLANs, i.e. between VLAN2 (management), VLAN3 (sales) and VLAN10 (guests) :

Names of VLAN- s:

SW(config)#vlan 2
SW(config-vlan)#name vodstvo
SW(config-vlan)#exit
same for VALN3 and VLAN10

Configuration on interfaces to belong to certain VLANs:

Switch(config)#interface fastethernet 0/2
Switch(config−if)#switchport mode access
Switch(config−if)#switchport access vlan2
Switch(config−if)#no shutdown

Same for vlan2, vlan3 and vlan10.

3. IP configuration on VLAN-s:.

Switch#conf t
Switch(config)#interface Vlan2
Switch(config−if)#ip address 10.1.2.1 255.255.255.0
Switch(config−if)#no shutdown

Same for vlan2, vlan3 in vlan10

4. Configuration of IP addresses on the interfaces to the two routers (these two interfaces are like third-level interfaces):

Switch(config)#
interface FastEthernet 0/1
Switch(config−if)#no switchport
Switch(config−if)#ip address 200.1.1.1 255.255.255.0
Switch(config−if)#no shutdown

We configure the same on the interface to the other router,

5. Configuration of routing protocols

Set static or dynamic routing.

Static routing:

Default route to R0:

Switch(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2

Dinamic on R1:

Switch(config)#router rip
Switch(config-router)#network 200.2.2.0
Switch(config-router)#network 10.1.2.0
Switch(config-router)#network 10.1.3.0
Switch(config-router)#network 10.1.10.0

6. Let's also set the corresponding already known settings that are needed on router R0 and R1.

DHCP

b. Settings for router 0:
Router>enable
Router#conf t
Router(config)#hostname Router0
Router0(config)#interface fastEthernet 0/0
Router0(config-if)#ip address 192.168.1.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit
Router0(config)#interface fastEthernet 0/1
Router0(config-if)#ip address 192.168.2.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit
Router0(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/1

Settings for Router1:
Router>enable
Router#conf t
Router(config)#hostname Router1
Router1(config)#interface fastEthernet 0/0
Router1(config-if)#ip address 192.168.2.2 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0
Router1(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10
Router1(config)#ip dhcp excluded-address 192.168.2.1 192.168.2.10
Router1(config)#ip dhcp pool LAN1
Router1(dhcp-config)# network 192.168.1.0 255.255.255.0
Router1(dhcp-config)# default-router 192.168.1.1
Router1(dhcp-config)#exit
Router1(config)#ip dhcp pool LAN2
Router1(dhcp-config)# network 192.168.2.0 255.255.255.0
Router1(dhcp-config)# default-router 192.168.2.1

FOR IP HELPER

Router0(config)#interface fastEthernet 0/0
Router0(config-if)#ip helper-address 192.168.2.2

VLANS

1.3 Nastavitev VLAN na Cisco Ethernet stikalih
Nastavitev VLAN na Cisco stikalih poteka v dveh korakih in sicer:
• kreiranje VLAN omrežij in
• določanje fizičnih vmesnikov na stikalu posameznim VLAN omrežjem.

Za kreiranje VLAN se uporabljajo naslednji ukazi:
Switch> Switch> enable
Switch#
Switch # configure terminal
Switch(config)#
Switch(config)# vlan <št. VLAN> (<= ukaz za nastavitev VLAN-ov; npr. VLAN 10)
Switch(config-vlan)# (<= preidemo v VLAN ukazni način)
Switch(config-vlan)# name (<= poimenujemo VLAN, npr. name administracija)
Switch(config-vlan)# exit (<= zapustimo konfiguracijo VLAN-ov)

Za določanje posameznih vmesnikov določenim VLAN omrežjem se uporabljajo naslednji ukazi:
Switch> Switch> enable
Switch#
Switch # configure terminal
Switch(config)#
Switch(config)# interface <št. vmesnika> (<= ukaz za izbiro Ethernet vmesnika na stikalu; npr. fastEthernet 0/1)
Switch(config-if)# (<= preidemo v INTERFACE ukazni način)
Switch(config-if)# switchport mode access (<= določimo tip vmesnika kot dostopovni vmesnik, namenjen priključitvi končnih naprav, npr. računalnikov)
Switch(config-if)# switchport access vlan (<= določimo pripadnost tega vmesnika VLAN-u s številko , npr. switchport access vlan 10)

Za določanje povezovalnega »trunk« vmesnika med dvema stikaloma se uporabljajo naslednji ukazi:
Switch> Switch> enable
Switch#
Switch # configure terminal
Switch(config)#
Switch(config)# interface <št. vmesnika> (<= ukaz za izbiro Ethernet vmesnika na stikalu; npr. fastEthernet 0/1)
Switch(config-if)# (<= preidemo v INTERFACE ukazni način)
Switch(config-if)# switchport mode trunk (<= določimo tip vmesnika kot povezovalni »trunk« vmesnik, namenjen povezavi več stikal med seboj in izmenjavi prometa vseh VLAN-ov)

VLAN konfiguracijo preverimo z ukazi:
Switch> Switch> enable
Switch#
Switch # show vlan (<= izpišemo informacije o vseh nastavljenih VLAN omrežjih na stikalu, ter pripadnosti posameznih vmesnikov)

Po privzetem vsi vmesniki na stikalu brez konfiguracije pripadajo VLAN št. 1.

Ime stikala spremenimo z naslednjimi ukazi:
Switch> Switch> enable
Switch#
Switch # configure terminal
Switch(config)#
Switch(config)# hostname (<= ukaz za nastavite imena stikala; npr. hostname SW1)
SW1(config)#

Sprememba imena je smiselna, da lažje ločimo med različnimi stikali v večjih omrežjih.

Povezava VLAN omrežij v druga omrežja preko usmerjevalnika:

V primeru, da želimo omogočiti promet VLA omrežij preko usmerjevalnika moramo ustvariti pod-vmesnike (ang. subinterface) na samem usmerjevalniku. Ker so VLAN omrežja standardizirana z 802.1Q moramo na teh pod-vmesnikih omogočiti encapsulation dot1q (št.vlan).

Pod-vmesnike na usmerjevalniku nastavimo:

Router> Router > enable
Router #
Router # configure terminal
Router (config)#
Router (config)# interface <št. vmesnika> (<= ukaz za izbiro Ethernet vmesnika na usmerjevlaniku; npr. fastEthernet 0/1; tukaj zdaj ne nastavimo ip naslova; omogočimo pa da je aktiven)
Router (config)# no shutdown
Router (config)#interface fastEthernet 0/1. <št.Vlan> Router (config-subif)#encapsulation dot1q <št.Vlan> Router (config-subif)#ip address

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers