cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1532
Views
0
Helpful
8
Replies

SPAN not able to add in Gi interface

mashokece1989
Beginner
Beginner

Hi team,

Anyone please suggest the solution 

    Im using Cisco Catalyst 6509, While i try to add the SPAN in the Giga ethernet. getting error message, Cant able to add that interface!!!!!! but i can able to add the vlan in SPAN

FYI

Switch net #monitor session 1 source interface gi4/10
% Cannot add interfaces as sources for SPAN session 1

8 Replies 8

Giuseppe Larosa
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hello Mashokece1989,

check with

show monitor

the current configuration of SPAN session 1, it may be already monitoring another L2 Vlan this could explain what you see

Hope to help

Giuseppe

In that interface i configured as 

#rmon collection stats 6067 owner monitor

So what is the issue that i couldn't able to do 

monitor session 1 source interface gi4/10

Hello Mashokece1989,

it is likely that monitor session 1 might be already configured with a L2 Vlan source.

see

You cannot mix individual source ports and source VLANs within a single session.

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/12-2SX/configuration/guide/book/span.html#wp1153551

RMON is not reported as not compatible with SPAN.

This is the reason for which I had asked the output of show monitor to see the current status.

Hope to help

Giuseppe

Hi Sir,

Thanks for your reply, but the thing is when i removed the L2 vlan for that interface even that time also i couldn't able to configure that command (#monitor session 1 source interface gi4/10)

FYI As you asked below the result of show Monitor command

#Switch#sh monitor

Session 1
---------
Type : Local Session
Source VLANs :
Both : 10,203
Destination Ports : analysis-module 8 data-port 1

Egress SPAN Replication State:
Operational mode : Centralized
Configured mode : Centralized (default)

Hello Mashokece1989,

you see the line:

Source VLANs :
Both : 10,203

Your monitor session 1 is already using as source of SPAN two L2 Vlans 10 and 203!

This is the reason why the device refuses to accept port gi4/10 as a source port, because as reported in the link in my second post in this thread, you cannot mix source types: all your sources are physical ports EXOR all your sources are Vlans in a span session.

So or you remove the commands that make vlan10 and vlan203 sources for span session 1 OR you add the vlan to which port gi4/10 belongs instead of the physical port.

Hope to help

Giuseppe

Thanks for your reply Sir,

But the thing is i tried as i removed the VLAN 10 in Span configuration and try to enable that (#monitor session 1 source interface gi4/10) command but i couldn't do that. Even that time i can see the result like only one (203) vlan there in the result.....

 So what is the issue? why wouldn't i able to do that particular command even i removed that 10 vlan?

Hello Mashokece1989,

two L2 Vlans 10 and 203 are currently listed as SPAN source you need to remove BOTH if you want to use as SPAN source interface gi4/10.

You cannot mix different types of source in the same SPAN session or all of them are L2 Vlans or all of them are physical ports (that can belong to different Vlans).

What is not clear in the above sentence?

Hope to help

Giuseppe

Thank You sir,

Now only i get a clear clarification from your precious explanation, Thanks for your valuable time for reply to me.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers