cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
513
Views
0
Helpful
1
Replies

Spanning tree - cannot re-enable.

Hi 

I have a strange issue with spanning-tree on a VSS pair of C4507E+R switches.The ios version is 15.1 

the core was configured to be the STP root for any BPDU forwarding. 

I noticed that spanning tree was not running for a number of VLANs, in my attempt to "re-enable" spanning tree i issued a no spanning-tree vlan 1-4094 then spanning -enable vlan 1-4094. Now it appears that STP is completely disabled for all VLAN despite the attempt to re-enable. 

for example, when I perform a show spanning-tree for VLAN10 I receive the following - 

Spanning tree instance(s) for VLAN10 does not exist. 

I will add that I am running etherchannel links between the core and the edge switches using mode on. 

I have tried deleting the VLAN + SVI on the core and disconnecting all edge switches but no luck.

Can anyone offer any advice/ideas to get spanning-tree working again?

1 REPLY 1
paul driver
VIP Mentor

Hello

spanning-tree  vlan 1-4094
spanning-tree  vlan 1-4094 priority xxxx
spanning-tree  mode xxx

Note: STP would not be active on a vlan that isn't allowed across the mec or the vlan doesn't have an active port assigned to it

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future