08-04-2022 06:56 AM
I have created a post a over a week ago having issues seeing access points from the main switches on a traffic network ring. That issue has been fixed, seeing that it was a a routing issue, but now, a spanning-tree issue has cropped up instead. Currently, the state of the interfaces need to be forwarding, but generally, at least 1 port on each site is being blocked, and though some sites get all the ports the access points connecting to are all in the forwarding state, this changes every few hours at each site.
The network is on Spanning-tree mode rapid pvst.
I have added the network topology as well as the the port configurations, spanning-tree configuration and output for the show spanning-tree command for the management VLAN.
My main issue as stated previously is that I need the ports to all be forwarding, but these ports are all trunk ports.
Node A# show spanning-tree vlan 5
VLAN0005
Spanning tree enabled protocol rstp
Root ID Priority 8197
Address 3473.2d3d.6180
Cost 3
Port 96 (Port-channel5)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 8197 (priority 8192 sys-id-ext 5)
Address 3473.2d3d.6200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/1 Desg FWD 4 128.1 P2p
Gi1/2 Desg BLK 19 128.2 P2p Dispute
Gi1/3 Desg FWD 19 128.3 P2p
Gi1/4 Desg FWD 4 128.4 P2p
Po1 Desg FWD 3 128.64 P2p
Po5 Root FWD 3 128.96 P2p
Node A Port Configurations
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-4093 priority 8192
!
interface Port-channel1
switchport trunk native vlan 1110
switchport mode trunk
!
interface Port-channel5
switchport trunk native vlan 1120
switchport mode trunk
!
interface GigabitEthernet1/1
description AP 1
switchport mode trunk
!
interface GigabitEthernet1/2
description AP 2
switchport mode trunk
!
interface GigabitEthernet1/3
description AP 3
switchport mode trunk
!
interface GigabitEthernet1/4
description AP 4
switchport mode trunk
!
interface GigabitEthernet1/5
switchport trunk native vlan 1110
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/6
switchport trunk native vlan 1120
switchport mode trunk
channel-group 5 mode active
!
interface GigabitEthernet1/7
switchport trunk native vlan 1110
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/8
switchport trunk native vlan 1120
switchport mode trunk
channel-group 5 mode active
!
interface GigabitEthernet1/9
description UPLINk2AP
switchport mode trunk
!
interface GigabitEthernet1/10
description UPLINk2AP
port-type eni
switchport mode trunk
!
interface GigabitEthernet1/11
description UPlink2LAN
port-type eni
switchport mode trunk
!
interface GigabitEthernet1/12
description T-ShootPort
port-type eni
switchport access vlan 5
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
description MGMT
ip address x.x.x.x 255.255.255.0
Node B# show spanning-tree vlan 5
VLAN0005
Spanning tree enabled protocol rstp
Root ID Priority 8197
Address 3473.2d3d.6180
Cost 7
Port 64 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 8197 (priority 8192 sys-id-ext 5)
Address 806a.0003.5300
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/13 Desg FWD 4 128.13 P2p
Gi1/14 Desg FWD 4 128.14 P2p
Po1 Root FWD 3 128.64 P2p
Po2 Altn BLK 3 128.72 P2p
Node B Port Configurations
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-4093 priority 8192
!
interface Port-channel1
description PTP_OSPF_Link_Node A
switchport trunk native vlan 1110
switchport mode trunk
!
interface Port-channel2
description PTP_OSPF_Link_Node E
switchport trunk native vlan 1150
switchport mode trunk
!
interface GigabitEthernet1/1
description UNUSED
shutdown
!
interface GigabitEthernet1/2
description UNUSED
shutdown
!
interface GigabitEthernet1/3
description UNUSED
shutdown
!
interface GigabitEthernet1/4
description UNUSED
shutdown
!
interface GigabitEthernet1/5
switchport trunk native vlan 1110
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/6
switchport trunk native vlan 1150
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/7
switchport trunk native vlan 1110
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/8
switchport trunk native vlan 1150
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/9
description PTP_OSPF_Link_Midway_Pump_Station
no switchport
ip address x.x.x.x 255.255.255.248
!
interface GigabitEthernet1/10
description Firewall
no switchport
x.x.x.x 255.255.255.0
!
interface GigabitEthernet1/11
description UPlink2LAN
switchport mode trunk
!
interface GigabitEthernet1/12
description Uplink to Traffic Server
port-type eni
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet1/13
description AP 1
switchport mode trunk
!
interface GigabitEthernet1/14
description AP 2
switchport mode trunk
!
interface GigabitEthernet1/15
!
interface GigabitEthernet1/16
description T-ShootPort
port-type uni
switchport access vlan 5
switchport mode access
!
interface GigabitEthernet1/17
!
interface GigabitEthernet1/18
!
interface GigabitEthernet1/19
!
interface GigabitEthernet1/20
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
--More--
description MGMT
ip address x.x.x.x 255.255.255.0
!
Node C#show spanning-tree vlan 5
VLAN0005
Spanning tree enabled protocol rstp
Root ID Priority 8197
Address 3473.2d3d.6180
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 8197 (priority 8192 sys-id-ext 5)
Address 3473.2d3d.6180
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/1 Desg BLK 4 128.1 P2p Dispute
Gi1/2 Desg FWD 4 128.2 P2p
Gi1/3 Desg FWD 4 128.3 P2p
Gi1/4 Desg FWD 19 128.4 P2p
Po4 Desg FWD 3 128.88 P2p
Po5 Desg FWD 3 128.96 P2p
Node C Port Configurations
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-4093 priority 8192
!
interface Port-channel4
switchport trunk native vlan 1130
switchport mode trunk
!
interface Port-channel5
switchport trunk native vlan 1120
switchport mode trunk
!
interface GigabitEthernet1/1
description AP 1
switchport mode trunk
!
interface GigabitEthernet1/2
description AP 2
switchport mode trunk
!
interface GigabitEthernet1/3
description AP 3
switchport mode trunk
!
interface GigabitEthernet1/4
description AP 4
switchport mode trunk
!
interface GigabitEthernet1/5
switchport trunk native vlan 1120
switchport mode trunk
channel-group 5 mode active
!
interface GigabitEthernet1/6
switchport trunk native vlan 1130
switchport mode trunk
channel-group 4 mode active
!
interface GigabitEthernet1/7
switchport trunk native vlan 1120
switchport mode trunk
channel-group 5 mode active
!
interface GigabitEthernet1/8
switchport trunk native vlan 1130
switchport mode trunk
channel-group 4 mode active
!
interface GigabitEthernet1/9
description UPLINk2AP
switchport mode trunk
!
interface GigabitEthernet1/10
description UPLINk2AP
switchport mode trunk
!
interface GigabitEthernet1/11
description UPlink2LAN
switchport mode trunk
!
interface GigabitEthernet1/12
description T-ShootPort
port-type eni
switchport access vlan 5
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
description MGMT
ip address x.x.x.x 255.255.255.0
!
Node D# show spanning-tree vlan 5
VLAN0005
Spanning tree enabled protocol rstp
Root ID Priority 8197
Address 3473.2d3d.6180
Cost 3
Port 80 (Port-channel3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32773 (priority 32768 sys-id-ext 5)
Address 3473.2d74.f600
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/1 Desg BLK 4 128.1 P2p Dispute
Gi1/2 Desg FWD 19 128.2 P2p
Po3 Root FWD 3 128.80 P2p
Po4 Desg FWD 3 128.88 P2p
Node D Port Configurations
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-4093 priority 8192
!
interface Port-channel3
switchport trunk native vlan 1130
switchport mode trunk
!
interface Port-channel4
switchport trunk native vlan 1140
switchport mode trunk
!
interface GigabitEthernet1/1
description AP 1
switchport mode trunk
!
interface GigabitEthernet1/2
description AP 2
switchport mode trunk
!
interface GigabitEthernet1/3
description AP 3
shutdown
!
interface GigabitEthernet1/4
description AP 4
shutdown
!
interface GigabitEthernet1/5
switchport trunk native vlan 1130
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet1/6
switchport trunk native vlan 1140
switchport m
Mode trunk
channel-group 4 mode active
!
interface GigabitEthernet1/7
switchport trunk native vlan 1130
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet1/8
switchport trunk native vlan 1140
switchport mode trunk
channel-group 4 mode active
!
interface GigabitEthernet1/9
description UPLINk2AP
switchport mode trunk
!
interface GigabitEthernet1/10
description UPLINk2AP
port-type uni
switchport mode trunk
!
interface GigabitEthernet1/11
description UPlink2LAN
switchport mode trunk
!
interface GigabitEthernet1/12
description T-ShootPort
port-type uni
switchport access vlan 5
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
description MGMT
ip address x.x.x.x 255.255.255.0
!
Node E#show spanning-tree vlan 5
VLAN0005
Spanning tree enabled protocol rstp
Root ID Priority 8197
Address 3473.2d3d.6180
Cost 6
Port 80 (Port-channel3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 8197 (priority 8192 sys-id-ext 5)
Address 4c5d.3cb6.2a00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/1 Desg FWD 4 128.1 P2p
Gi1/2 Desg BLK 4 128.2 P2p Dispute
Gi1/3 Desg FWD 19 128.3 P2p
Gi1/4 Desg FWD 4 128.4 P2p
Po2 Desg FWD 3 128.72 P2p
Po3 Root FWD 3 128.80 P2p
Node E Port Configurations
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-4093 priority 8192
!
interface Port-channel2
description PTP_OSPF_Link_Node B
switchport trunk native vlan 1150
switchport mode trunk
!
interface Port-channel3
switchport trunk native vlan 1140
switchport mode trunk
!
interface GigabitEthernet1/1
description AP 1
switchport mode trunk
!
interface GigabitEthernet1/2
description AP 2
switchport mode trunk
!
interface GigabitEthernet1/3
description AP 3
switchport mode trunk
!
interface GigabitEthernet1/4
description AP 4
switchport mode trunk
!
interface GigabitEthernet1/5
switchport trunk native vlan 1150
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/6
switchport trunk native vlan 1140
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet1/7
switchport trunk native vlan 1150
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/8
switchport trunk native vlan 1140
switchport mode trunk
channel-group 3 mode active
!
interface GigabitEthernet1/9
description UPLINk2AP
switchport mode trunk
!
interface GigabitEthernet1/10
description UPLINk2AP
port-type uni
switchport mode trunk
!
interface GigabitEthernet1/11
description UPlink2LAN
port-type uni
switchport mode trunk
!
interface GigabitEthernet1/12
description T-ShootPort
port-type uni
switchport access vlan 5
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan5
description MGMT
ip address x.x.x.x 255.255.255.0
!
08-04-2022 11:53 AM
All port FWD that impossible for your design,
ONE trunk must be BLK to broke the L2 LOOP
but
since you run Rapid-PVST then you can do Spanning tree load balance when the VLANX in trunk Z is FWD but VLANY is BLK.
this need to make two switch as Spanning tree Root, one root for each VLAN.
08-04-2022 11:41 PM
Please check below document..
https://www.cisco.com/c/en/us/support/docs/lan-switching/spanning-tree-protocol/10556-16.html
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide