Showing results for 
Search instead for 
Did you mean: 

Stack upgrade failure,


7x stack WS-C3750E-48TD-E

orignal code 12.2.35...i wanted to get it to 15.0.1 ..

so as a test i disconnected top switch (not the master ) and installed via

archive download-sw /allowupgrade 15.0.1.tar.... and it worked away fine...

so i moved onto the stack, issued the same command, image loaded

rebooted and stack hung..

Consoled in and switch was unable to boot..looping on trying to load flash..

Error.. "flash:c3750e-universalk9npe-mz.150-2.SE/c3750e-universalk9npe-mz.150-2.SE.bin"

** where is this folder, i though it would be made after the code load???

i pointed the boot flash:/to the update folder which had update/3750XXX/3750XX.bin..

Error loading "flash:/update/c3750e-universalk9npe-mz.150-2.SE/c3750e-universalk9npe-mz.150-2.SE.bin

so i xmodem an older c3750-advipservicesk9-mz.122-35.SE5.bin (slowly)..

point the boot flash:/ commmand to this .bin file and this still fails...

ideally id liketo get 15 on there, all the files seem to be in  place, just not installed??


switch: dir flash:/

Directory of flash://

    2  -rwx  3660      <date>               vlan.dat

    3  -rwx  40659     <date>               config.text

    4  -rwx  1938      <date>               private-config.text

    5  drwx  512       <date>               update

  528  -rwx  3096      <date>               multiple-fs

  529  -rwx  40374     <date>               config.text.backup

  530  -rwx  1938      <date>               private-config.text.backup

  531  -rwx  17111658  <date>               c3750-ipservicesk9-mz.150-1.SE.bin

  532  -rwx  8765440   <date>               c3750-advipservicesk9-mz.122-35.SE5.


9259520 bytes available (48412160 bytes used)

switch: help

Reza Sharifi
Hall of Fame Expert


If you are trying to upgrade a stack of switches, you need to use the .tar file not .bin

bin is for single switch upgrade.

Try downloading a .tar file and do it again.



i used the .tar file as a test on first switch and it worked..

then tried it on the stack and thats when it failed..




So within flash:/update/ folder is teh folder i was looking for and and the .bin file is located in there..

starting loading via the boot command.

switch: boot flash:/update/c3750e-universalk9npe-mz.150-2.SE/c3750e-universalk9npe-mz.150-2.SE.bin

Loading "flash:/update/c3750e-universalk9npe-mz.150-2.SE/

@@@@@@@@@@@@@@@@@@@@@@@@.. plenty more of this but finally...

Error loading "flash:/update/c3750e-universalk9npe-mz.150-2.SE/c3750e-universalk9npe-mz.150-2.SE.bin"

I wonder what went wrong with your installation.  I upgraded a stack of 3750x switches last week using this document and it went well with no issues:

I used this exact command:

archive download-sw /leave-old-sw tftp://xx.xx.xx.xx/
It just took a long time, but no issues at all


Leo L
VIP Community Legend

orignal code 12.2.35...i wanted to get it to 15.0.1 .

Exercise caution when going to 15.0(1)SE and 15.0(2)SE.  Read the Release Notes first before deciding if you really, really want this version.

cheers for the replys..

so it looks like the bootloader didnt upgrade (is it suppose to??)

after a show version... bootloader= the orignal 12.44 code..

i decided to  xmodem @115200 c3750sxxx12.44 se6 code to the device..

issued the boot flash:/c3750XXX12.44.bin file and it arrived back at the desired promt..

now i have 2 of seven at 12.44 (fully operational)

1@ 15.02 ( working fine)

another 4 left in limbo..i think i will load 12.44 onto them to get the stack back up...

so 6 of 7 will be ok..

why didnt the bootloader upgrade to the 15 code??

should i just go back to 12.44 ?


Leo L
VIP Community Legend

so it looks like the bootloader didnt upgrade (is it suppose to??)

Suppose to.

Error loading "flash:/update/c3750e-universalk9npe-mz.150-2.SE/c3750e-universalk9npe-mz.150-2.SE.bin"

The IOS you've uploaded to the switch could be corrupt.

i decided to  xmodem @115200 c3750sxxx12.44 se6 code to the device..

Don't you have a 3750E/X?  If you do, stick the IOS into a USB flash drive and boot from there.  It's far faster than xmodem.


bootloader files doesnt necessarily get updated with every IOS upgrade, which is fine..

The IOS uploaded, had already been tested on another switch, and workied fine..

so i'm still back at 12.X code, i wil have another look at this before the new year..

thanks for the replies.