cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
912
Views
0
Helpful
7
Replies
Highlighted
Beginner

Telnet issue

I connected 1941 router with 2960 switch via trunk link and I want to access the switch with telnet from the router. what shall I do for this and how can I assign ip address for both router and switch to do the telnet or if any other solution is there????

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Telnet issue

Hi,

  Okay, your configuration looks good to me. What we are going to do is as follows:

Assuming that we want to use VLAN-99 for switch management.

Cisco 2960 Switch. Hope you already correctly configured the trunk port(At least allow vlan 4 ,5 and 99)connected Fast0/0 on C1941.

For example

!

Switch(conf)#vlan 99

Switch(conf)#interface vlan 99

Switch(conf-if)#ip add 172.31.99.2 255.255.255.0   ,  You can change it to what you want.

Switch(conf-If)#no shut

Switch(conf)#ip default-gateway 172.31.99.1           , C1941's IP address

Swicth(conf)#line vty 0 15

Switch(conf-line)#password 0 cisco123

Switch(conf-line)#login

Switch(conf)#enable password 0 cisco1234

Assuming that you're going to use Fast0/24 on Switch to connect C1941

Switch(conf)#vlan 4

Switch(conf)#vlan 5

Switch(conf)#interface Fa0/24

Switch(conf-if)#switchport mode trunk

Switch(conf-if)#no shut

!

Cisco 1941 Router


For example

!

interface FastEthernet0/0.99

encapsulation dot1Q 99

ip address 172.31.99.1 255.255.255.0

!

     Please get back and let us know how things work out.

HTH,

Toshi

View solution in original post

7 REPLIES 7
Highlighted

Telnet issue

Hi,

   Yes you can do. Please post current configuration on both devices.

HTH,

Toshi

Highlighted
Beginner

Re: Telnet issue

version 12.2

service timestamps debug uptime

service timestamps log datetime localtime

service password-encryption

!

logging buffered 20480 debugging

logging monitor informational

enable secret 5 $1$9Xi/$a8C4dDrDrBO2y65dO3Zuz1

!

ip subnet-zero

no ip source-route

no ip domain-lookup

!

no ip bootp server

ip cef

isdn switch-type basic-net3

!

!

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

isdn switch-type basic-net3

!

interface FastEthernet0/0

no ip address

ip accounting output-packets

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 4

ip address 172.31.73.1 255.255.255.240

!

interface FastEthernet0/0.2

encapsulation dot1Q 5

ip address 172.31.73.17 255.255.255.240

!

interface Serial0

bandwidth 64

ip address 172.31.126.30 255.255.255.252

encapsulation ppp

!

router eigrp 100

network 172.31.0.0

auto-summary

!

ip classless

ip tacacs source-interface FastEthernet0

no ip http server

!

access-list 5 permit 172.16.4.56

access-list 5 permit 172.16.4.57

tacacs-server host 172.16.4.58

tacacs-server host 172.16.4.59

tacacs-server directed-request

snmp-server community kanbetac1dnys RO 5

snmp-server community tideciffoetaroproc RW 5

snmp-server enable traps tty

snmp-server host 172.16.4.56 kanbetac1dnys

snmp-server host 172.16.4.57 kanbetac1dnys

!

line con 0

password 7 131742561B030A6E6A322D

line aux 0

line vty 0 4

password 7 13061E010803

login

!

no scheduler allocate

end

These are all the router configuration and there is no configuration for switch, have to configure

Highlighted

Re: Telnet issue

Hi

I didn't see any lan configuration. We need to get enough information to help you.

Toshi

Sent from Cisco Technical Support iPhone App

Highlighted
Beginner

Re: Telnet issue

just now updated it. kindly review once again

Highlighted

Re: Telnet issue

Hi,

  Okay, your configuration looks good to me. What we are going to do is as follows:

Assuming that we want to use VLAN-99 for switch management.

Cisco 2960 Switch. Hope you already correctly configured the trunk port(At least allow vlan 4 ,5 and 99)connected Fast0/0 on C1941.

For example

!

Switch(conf)#vlan 99

Switch(conf)#interface vlan 99

Switch(conf-if)#ip add 172.31.99.2 255.255.255.0   ,  You can change it to what you want.

Switch(conf-If)#no shut

Switch(conf)#ip default-gateway 172.31.99.1           , C1941's IP address

Swicth(conf)#line vty 0 15

Switch(conf-line)#password 0 cisco123

Switch(conf-line)#login

Switch(conf)#enable password 0 cisco1234

Assuming that you're going to use Fast0/24 on Switch to connect C1941

Switch(conf)#vlan 4

Switch(conf)#vlan 5

Switch(conf)#interface Fa0/24

Switch(conf-if)#switchport mode trunk

Switch(conf-if)#no shut

!

Cisco 1941 Router


For example

!

interface FastEthernet0/0.99

encapsulation dot1Q 99

ip address 172.31.99.1 255.255.255.0

!

     Please get back and let us know how things work out.

HTH,

Toshi

View solution in original post

Beginner

Re: Telnet issue

ya its working nice dude thanks a lot

Highlighted

Telnet issue

Hi,

    My pleasure

Thanks

Toshi

CreatePlease to create content
Content for Community-Ad