02-16-2015 06:46 AM - edited 03-07-2019 10:40 PM
We have a metro-Ethernet service connecting several sites, and we are going to the same topography with a different provider. I am trying to program the hub router (a 3834) to talk across the link to a 2821, both routers running 12.4. The issue I am facing is that if I just use a LAN IP address for the 3834 G0/1 interface (10.0.10.1/24) connected by crossover cable to the 2821 G0/0 interface (10.0.10.254/24) everything works, routing tables understand to route 10.0.10.0/24 traffic across those interfaces, routing protocols work, etc. If I then change the 3834 G0/1 to "no ip address", then create a G0/1.1 VLAN, nothing works. Neither of the routers understand that 10.0.10.0/24 traffic should route to the interfaces. Here is the pertinent part of the 3834 config:
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.0.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no snmp trap link-status
!
And now the pertinent part of the 2821 config:
interface GigabitEthernet0/0
ip address 10.0.10.254 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
no mop enabled
!
Here is the routing table for the 3484:
FielderNew#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.10.0 is directly connected, GigabitEthernet0/1.10
C 192.168.100.0/24 is directly connected, GigabitEthernet0/0
FielderNew#ping 10.0.10.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.10.254, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
FielderNew#
And for the 2821:
FirewheelNew#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.10.0/24 is directly connected, GigabitEthernet0/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.10.0 is directly connected, GigabitEthernet0/0
FirewheelNew#
FirewheelNew#ping 10.0.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
FirewheelNew#
I've been hacking at this for a quite a while, obviously not a network engineer, can anyone tell me what I am doing wrong? Many thanks, Brad
Solved! Go to Solution.
02-16-2015 07:34 AM
By configuring subinterfaces on the G0/1 of the 3834? like that you are tagging the packets leaving the router with VLAN ID 10. Router 2821 doesn't understand the dot1q tag because its interface is configured as a layer 3 interface.
The solution is to do the same on both ends of the link: either you configure both routers with subinterfaces and vlan 10, or you configure both as layer 3 interfaces.
So if you want to keep the config on the 3834, you should replicate the comands on the other router:
interface GigabitEthernet0/1
no ip address 192.168.10.254 255.255.255.0
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.0.10.254 255.255.255.0
02-16-2015 06:56 AM
Brad
Not sure what a 3834 is but if you use a subinterface then it is expecting a tagged packet.
But if you simply connect the other end to the 2821 and just use a physical interface on the 2800 then there will be no tags.
If there is a switch in between you could make the connection to the 3834 a trunk link allowing vlan 10 and then make the connection to the 2821 an access port in vlan 10 and that would work.
Basically your 3834 is expecting traffic with a vlan tag so either -
1) use the switch method above
or
2) create a corresponding subinterface on your 2821
Jon
02-16-2015 07:03 AM
02-16-2015 07:20 AM
don't worry :)
02-16-2015 07:34 AM
By configuring subinterfaces on the G0/1 of the 3834? like that you are tagging the packets leaving the router with VLAN ID 10. Router 2821 doesn't understand the dot1q tag because its interface is configured as a layer 3 interface.
The solution is to do the same on both ends of the link: either you configure both routers with subinterfaces and vlan 10, or you configure both as layer 3 interfaces.
So if you want to keep the config on the 3834, you should replicate the comands on the other router:
interface GigabitEthernet0/1
no ip address 192.168.10.254 255.255.255.0
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.0.10.254 255.255.255.0
02-16-2015 07:46 AM
Thanks to everyone, adding the equivalent commands to the 2nd router did the trick. Next time I run into this kind of road block I'll make sure to post a question rather than spend weeks beating my head against the wall (but at least I read up a LOT on the subject!).
Thanks again, Brad
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide