cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
812
Views
0
Helpful
21
Replies
ibrunello
Beginner

VLAN not trunking between cat2900xl and 2950

Strange behaviour.

I have a cat2900xl and a 2950.

Just set VTP on both.

Interface are trunked in 802.1q on both (explicitly set on 2900xl, since by default it uses ISL).

Native VLAN is 1 on both.

Create VLANs on 2950 (which happens to be the VTP server), and they're connectly seen on the 2900xl.

Set VTP version 2, and both run in v2-mode.

Set pruning, and both set pruning.

create vlan4, and it's showed on both.

set an access port on vlan 4 on both, and traffic is not forwarded.

("show vlan" on 2900xl correctly shows the interface associated to vlan4).

notably, vlan4 is pruned on 2950 uplink interface (show interface trunk).

any hint?

TIA

Ivan

21 REPLIES 21

cat2950:

cat2950#sh int f0/1 status

Port Name Status Vlan Duplex Speed Type

Fa0/1 cat2900xl f0/22 connected trunk a-full a-100 10/100BaseTX

cat2950#sh int f0/1 trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/1 1-4094

Port Vlans allowed and active in management domain

Fa0/1 1-4

Port Vlans in spanning tree forwarding state and not pruned

Fa0/1 1

cat2950#sh int f0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

cat2900xl (capability is not supported):

cat2900xl#sh int f0/22 status

Port Name Status Vlan Duplex Speed Type

------- ------------------ ------------ -------- ------ ------- ----

Fa0/22 cat2950 f0/1 connected trunk A-Full A-100 100BaseTX/FX

cat2950:

cat2950#sh int f0/1 status

Port Name Status Vlan Duplex Speed Type

Fa0/1 cat2900xl f0/22 connected trunk a-full a-100 10/100BaseTX

cat2950#sh int f0/1 trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/1 1-4094

Port Vlans allowed and active in management domain

Fa0/1 1-4

Port Vlans in spanning tree forwarding state and not pruned

Fa0/1 1

cat2950#sh int f0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

cat2900xl (capability is not supported):

cat2900xl#sh int f0/22 status

Port Name Status Vlan Duplex Speed Type

------- ------------------ ------------ -------- ------ ------- ----

Fa0/22 cat2950 f0/1 connected trunk A-Full A-100 100BaseTX/FX

I'm not trying to ping an IP on the switch itself.

Instead, i'm trying to ping a device with a static ip address which resides on Vlan4.

I'm not trying to ping an IP on the switch itself.

Instead, i'm trying to ping a device with a static ip address which resides on Vlan4.

I asked you before to capture "show int trunk" and "show spanning-tree vlan 4" when you have access port in vlan 4 on both switch is up/up.

I am not sure when you captured the following output. But I did not see vlan 4 is listed under "Port Vlans in spanning tree forwarding state and not pruned"

cat2950#sh int f0/1 trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/1 1-4094

Port Vlans allowed and active in management domain

Fa0/1 1-4

Port Vlans in spanning tree forwarding state and not pruned

Fa0/1 1 <<<<<<

That's exactly one of the sympthoms I outlined in the first place.

SOLVED.

It turned out to be a problem with a misconfiguration.

I created and deleted by accident an "interface vlan4".

As long as this ghost configuration remained (status "deleted"), vlan did not work.

I was able to reboot the switch right now (maintenance window on application servers).

Since the interface vlan4 is gone, everything at L2 works as expected.

thanks everybody for the hints.