cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
542
Views
0
Helpful
2
Replies
Highlighted
Beginner

VRF configuration

Hello, I have a  WS-C3750G-24T-S layer 3 switch and I need to configure independent routes for a specific network, I'm trying to use VRF but it is not working for me. I tried using route-map but it seems the switch doesn't support that, so I'm stuck with VRF, but I think I'm not doing it right. The topology is as follows:

I have a network directly connected to a vlan and I need to forward all the traffic I get on this VLAN using a tunnel to a router. I think the problem is that in order to use the tunnel I need to utilize another VLAN which isn't part of that VRF. I attach the configuration I'm using to better understand what I'm trying to do:

layer-3 switch:

ip vrf TEST

rd 1:1

interface Tunnel1

ip vrf forwarding TEST

ip address 172.17.0.1 255.255.255.252

tunnel source 10.245.0.9

tunnel destination 10.250.4.31

interface Vlan404

ip vrf select source

ip vrf receive TEST

ip address 10.250.4.1 255.255.255.0

ip ospf cost 32000

ip ospf hello-interval 2

ip ospf dead-interval 6

end

interface Vlan827

description access-patprimoquicentro

ip vrf forwarding TEST

ip address 10.245.0.9 255.255.255.248

ip route vrf TEST 0.0.0.0 0.0.0.0 Tunnel1

This is how my routing table looks for my VRF:

     172.17.0.0/30 is subnetted, 1 subnets

C       172.17.0.0 is directly connected, Tunnel1

     10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks

S       10.250.4.31/32 [1/0] via 10.250.4.1

C       10.250.4.0/24 is directly connected, Vlan404

C       10.245.0.8/29 is directly connected, Vlan827

S*   0.0.0.0/0 [1/0]  is directly connected, Tunnel1

this is my final end router:

interface Tunnel4

ip address 172.17.0.2 255.255.255.252

traffic-shape rate 512000 12800 12800 1000

tunnel source 10.250.4.31

tunnel destination 10.250.4.1

and this is how my routing table looks on this router:

     172.17.0.0/30 is subnetted, 1 subnets

C       172.17.0.0 is directly connected, Tunnel4

C       10.250.4.0/24 is directly connected, Vlan404

S       10.245.0.8/29 [1/0] via 10.250.4.1

S*   0.0.0.0/0 [1/0] via 10.1.60.15

I hope you can help me out.

Thanks in advance

2 REPLIES 2
Highlighted
Cisco Employee

VRF configuration

Why do you have tunnel destination on your router as 10.250.4.1? Shoulnt it be 10.245.0.9????

Highlighted
Beginner

Re: VRF configuration

Hi
You need an additinal route for the tunnel endpoint.
And the source/destination of the tunnels must fit - of course vise versa.

CreatePlease to create content
Content for Community-Ad