Showing results for 
Search instead for 
Did you mean: 

Restore TMS from backup

Cisco Employee
Cisco Employee



I am following cisco install and upgrade guide for TMS  . The problem i am having is that when i click restore i get the following error. which i have no idea where its coming from . Basically i have moved TMS 14.6 on a new server different ip address, i have built sql and tms , i have copied the encryption key fro mold server. when i click on the new tmsng database and say restore it fails and gives me the below error


10 Replies 10

Magnus Ohm
Cisco Employee
Cisco Employee


On the new server I assume you have an empty tmsng database (or a default installation database)? Try to delete the one on the new server that is empty, or you don´t have to delete it, but just detach it from the server. You can then locate the database file on the server and move it somewhere else. Then you can try the restore procedure. You don´t have to have an existing tmsng database to restore it. And since this is causing the conflict I would try to do it to a new database. Just type tmsng in the "to database" field like in the screenshot and it will be created.

Or alternatively: just detach the TMSNG database and the ldf file from the old server, copy the files to the new server and attach them. Make sure to attach the databases to the old server again though (must be done in maintenance window as this method causes a short downtime).


Thanks Magnus.


Another quick one please, i am unable to login to TMS from the local host.


But when i try yo login from a different machine but a same netwrok(in my case windows 7) it works.


so on my local host do i need to add some othe rpermissions for it to work.



Also when i fo a back up of tmsng and tmspe, i got 2 more data based there tms_userportal and tmspe_vmr do i also need to copy that files to the new server



You cannot login as not getting prompted with a username and password when trying to login from the localhost?

Do you type in http(s)://localhost/tms ?

I need to know what you see in both instances. Do you see a "access denied" message on the localhost or any other error messages or does it just re-prompt you with username and password? Is the server in a domain? you need to narrow it down for me :)

If you are installing TMSPE on the new server and want to merge that application as well, then yes. Those databases are related to TMSPE. TMS uses tmsng. userportal and virtual meeting rooms (vmr) is something that comes with TMSPE as far as I know.


  • tmspe
  • tmspe_vmr
  • tmspe_userportal

They are all TMSPE related databases, as their database names suggest, it's documented in the TMSPE deployment guides.

Hi Magnus,


Thanks for the reply.


I do type http(s)://localhost/tms. or even x.x.x.x/tms. i even tried to open web page of TMS from installed software. Under start-->program files


it keeps on asking me username and password, and after few attempts i get IIS error.


Sorry i am not an expert with Microsoft so struggling a bit.


Thanks in advance

What browser are you using? IE, Firefox, Chrome?  On the TMS Server I've only seen it asking for the username and password when using something other than IE, or when, for some reason, a proxy server was being used for the local connection.

In any case, you should be able to enter the username and password of the admin account you're logged in to the server with.  You may need to enter it in the "DOMAIN\username" format.

Another cause for it asking for the username and password could be a broken installation/IIS configuration error.  If you run the TMS installer again and re-install the software, that should repair those issues.

Please remember to rate responses and to mark your question as answered if appropriate.


Please remember to mark helpful responses and to set your question as answered if appropriate.

I have tried with IE, Firefox, chrome. The funny thing is it works when i try to login from a windows 7 machine which is part of the same domain. I am pretty sure i tried using DOMAIN\username, but it was unsuccesfull

Do you perhaps have the web browser on the TMS server set to use a proxy server for all requests, if so, when you hit the http://localhosts/tms it could be trying to look at the proxy server's address for the tms page, which will of course not work.  This could help explain why you are able to get to it from the Win7 PC but not from the server itself.

Make sure that you set your browser to bypass any proxy settings for the localhost address (and/or the DNS Name/IP address of of your TMS). 

Please remember to rate responses and to mark your question as answered if appropriate.


Please remember to mark helpful responses and to set your question as answered if appropriate.

Just as a matter of interest, what version of SQL were you on and what version are you moving to? Are they the same?

uSING sqL sERVER 2008 r2. Yup they are the same on servers