キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
1379
閲覧回数
5
いいね!
0
コメント
Kenji Takahagi
Cisco Employee
Cisco Employee
 

 

はじめに

このドキュメントでは、Cisco Nexus シリーズで Link Aggregation Control Protocol (LACP) のトラブルシューティングを実施する際のポイントを記載しています。

 

  

show tech-support lacp

 

LACP のトラブルシューティングには、show tech-support lacp に含まれる出力が解析に有用です。
以下は show tech-support lacp に含まれる代表的なコマンド例です。
(show tech-support の取得ができない場合、それぞれを個別に実行しても同じ出力が得られます)

 

`show system internal sysmgr service name lacp`
`show lacp internal info all`
`show lacp internal event-history errors`
`show lacp internal event-history msgs`
`show lacp internal event-history lock`
`show lacp internal event-history global`
`show lacp internal mem-stats detail`
`show lacp counters`

 

上記に加え、以下のようなコマンド出力も必要です。

 

`show version`
`show module`
`show running-config`
`show logging log`
`show logging nvram`
`show accounting log`

 

 

出力内容の解析例

 

まず show logging log などで、解析したい事象が発生した時刻やポートを明確にします。

 

yyyy Mmm dd hh:mm:ss switch %ETH_PORT_CHANNEL-5-PORT_HOT_STANDBY: port-channel1: Ethernet1/9 goes to hot-standby
yyyy Mmm dd hh:mm:ss switch %ETH_PORT_CHANNEL-5-PORT_HOT_STANDBY: port-channel1: Ethernet1/10 goes to hot-standby

 

その後、show lacp internal info all に含まれる該当ポートのイベントログの、該当時間のイベントを確認します。
下記の例の場合、該当時間に対向機器からの LACP PDU が timeout し、ポートが hot-standby になったとわかります。

 

 

28) FSM:<Ethernet1/9> Transition at xxxxxx usecs after Day Mmm dd hh:mm:ss yyyy
    Previous state: [LACP_ST_ATTACHED_TO_AGGREGATOR]
    Triggered event: [LACP_EV_PARTNER_SYNC_TIMED_OUT]
    Next state: [LACP_ST_SUSPENDED_FOR_MISCONFIGURATION]

29) FSM:<Ethernet1/9> Transition at xxxxxx usecs after Day Mmm dd hh:mm:ss yyyy
    Previous state: [LACP_ST_SUSPENDED_FOR_MISCONFIGURATION]
    Triggered event: [LACP_EV_PORT_SELECTED_AS_MCEC_HOT_STANDBY_FOR_AGGREGATION]
    Next state: [LACP_ST_HOT_STANDBY_FOR_PORT_CHANNEL]


30) FSM:<Ethernet1/10> Transition at xxxxxx usecs after Day Mmm dd hh:mm:ss yyyy
    Previous state: [LACP_ST_ATTACHED_TO_AGGREGATOR]
    Triggered event: [LACP_EV_PARTNER_SYNC_TIMED_OUT]
    Next state: [LACP_ST_SUSPENDED_FOR_MISCONFIGURATION]

31) FSM:<Ethernet1/10> Transition at xxxxxx usecs after Day Mmm dd hh:mm:ss yyyy
    Previous state: [LACP_ST_SUSPENDED_FOR_MISCONFIGURATION]
    Triggered event: [LACP_EV_PORT_SELECTED_AS_MCEC_HOT_STANDBY_FOR_AGGREGATION]
    Next state: [LACP_ST_HOT_STANDBY_FOR_PORT_CHANNEL]
 
LACP が timeout した場合、通常は suspend/individual になりますが、ポートは vPC に属しているため、hot-standby となります。

  

interface port-channel1
  switchport
  switchport mode trunk
  vpc 1

interface Ethernet1/9
  switchport
  switchport mode trunk
  channel-group 1 mode active
  no shutdown

interface Ethernet1/10
  switchport
  switchport mode trunk
  channel-group 1 mode active
  no shutdown

 

 

コマンド出力以外に必要なポイント

 

  • 接続ポート番号がわかるような構成図は事前に用意しておくことをおすすめいたします。迅速にトラブルシューティングを開始することができます。
  • 事象発生時間に、ネットワーク上で操作や作業などが発生していたかどうかを確認する必要があります。
  • show accouting log などで、コマンドの実行履歴を参照するのことも有用です。
  • 事象発生前後で、該当ポートの show interface などで、インターフェース上でエラーカウンターの上昇があるかどうかを確認することも有用です。
  • monitor session などを利用して、LACP PDU をキャプチャーした情報は、トラブルシューティングに非常に有用な情報です。

  

参考情報

 

Nexus シリーズ : Link Aggregation Control Protocol (LACP) の設定例

Nexus シリーズ : Nexus シリーズ : LACP Data Unit

Nexus シリーズ : Nexus シリーズ : LACP max-bundle と min-links

Nexus シリーズ : LACP suspend-individual

Nexus スイッチ (NX-OS) : 設定例

Cisco Nexus 9000 シリーズ : SPAN と Ethanalyzer を併用したパケットキャプチャー

 

Getting Started

検索バーにキーワード、フレーズ、または質問を入力し、お探しのものを見つけましょう

シスコ コミュニティをいち早く使いこなしていただけるよう役立つリンクをまとめました。みなさんのジャーニーがより良いものとなるようお手伝いします