キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
1294
閲覧回数
0
いいね!
0
コメント
Kenji Takahagi
Cisco Employee
Cisco Employee

 

 

 

はじめに

この記事では、Cisco Nexus シリーズで初期設定の際に、NX-OS Setup Utility を利用して設定を実施する例を示します。この機能については以下の URL に記載があります。本ドキュメントはその補足内容です。

以下の URL に記載のある内容と、本ドキュメントの内容に相違がある場合、URL 記載の内容が優先されます。

本ドキュメントの例は、特に記載がない限り、cisco Nexus9000 C93180YC-FX (N9K-C93180YC-FX) で NX-OS 9.3(5) を利用した場合のものです。ハードウェアやソフトウェアによって、内容に相違がある場合がございます。

 

Using the Cisco NX-OS Setup Utility

 

Cisco Nexus NX-OS Setup Utility の起動

 

何も設定がない状態(工場出荷時) や write erase で設定消去後に再起動や電源のオフ/オンを実施した場合、起動時に以下のようなログが表示されます。

 

Waiting for system online status before starting POAP ...
2020 Aug 27 22:50:29  %$ VDC-1 %$ %VDC_MGR-2-VDC_ONLINE: vdc 1 has come online
Waiting for system online status before starting POAP ...
Starting Auto Provisioning ...
2020 Aug 27 22:51:18 switch %$ VDC-1 %$ %ASCII-CFG-2-CONF_CONTROL: System ready
Done
Abort Power On Auto Provisioning [yes - continue with normal setup, skip - bypass password and basic configuration, no - continue with Power On Auto Provisioning] (yes/skip/no)[no]:

 

Power On Auto Provisioning(POAP) とは機器起動時に、必要な設定をサーバーからネットワークを経由して自動的に適用する仕組みのことです。詳しくは以下の URL をご参照ください。

 

Using PowerOn Auto Provisioning

 

初期設定時に POAP をご利用にならない場合、もしくは POAP に心当たりがない場合には、
"yes" を入力し、通常のセットアップに進んでください。
skip も選択できますが、その場合 setup utility は起動せず、通常の Command Line Interface (CLI) による設定となります。

 

yes
Disabling POAP.......Disabling POAP
2020 Aug 27 22:51:27 switch %$ VDC-1 %$ poap: Rolling back, please wait... (This may take 5-15 minutes)


         ---- System Admin Account Setup ----


Do you want to enforce secure password standard (yes/no) [y]: y

  Enter the password for "admin":
  Confirm the password for "admin":

         ---- Basic System Configuration Dialog VDC: 1 ----

This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.

Please register Cisco Nexus9000 Family devices promptly with your
supplier. Failure to register may affect response times for initial
service calls. Nexus9000 devices must be registered to receive
entitled support services.

Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.

 Would you like to enter the basic configuration dialog (yes/no): yes
yes を入力後、user admin のパスワードを設定します。
Do you want to enforce secure password standard (yes/no) [y] は、パスワードの規則性に関する
チェックを行うかどうかを選択します。詳しくは以下の URL をご参照ください。

Setting Up Your Cisco NX-OS Device

この例では yes を選択し、user admin のパスワードを設定しています。

 

         ---- Basic System Configuration Dialog VDC: 1 ----

This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.

Please register Cisco Nexus9000 Family devices promptly with your
supplier. Failure to register may affect response times for initial
service calls. Nexus9000 devices must be registered to receive
entitled support services.

Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.

 Would you like to enter the basic configuration dialog (yes/no): yes

 

その後、Would you like to enter the basic configuration dialog (yes/no) と表示されますので、
ここで yes を選択することで Cisco Nexus NX-OS Setup Utility の利用を開始することができます。

 

 

Cisco Nexus NX-OS Setup Utility の設定例

ここでは Cisco Nexus NX-OS Setup Utility を起動した後の設定項目に関する補足と例を示します。

  

  Create another login account (yes/no) [n]: yes

    Enter the User login Id : test_1

    Enter the password for "test_1":
    Wrong Password, Reason:
       [Length should be at least 8 characters]
      Invalid user password.

    Enter the password for "test_1":
    Wrong Password, Reason:
       [Password should contain characters from at least three of the following classes: lower case letters, upper case letters, digits and special characters.]
      Invalid user password.

    Enter the password for "test_1":
    Wrong Password, Reason:
       [it is too simplistic/systematic]
      Invalid user password.

    Enter the password for "test_1":
    Confirm the password for "test_1":

    Enter the user role (network-operator|network-admin|vdc-operator|vdc-admin) [network-operator]:

 

ここでは、user admin 以外のユーザーの追加、と役割の付与を設定します。
詳しくは以下の URL をご参照ください。

 

Configuring User Accounts and RBAC

 

  Configure read-only SNMP community string (yes/no) [n]: yes

    SNMP community string : public

  Configure read-write SNMP community string (yes/no) [n]: yes

    SNMP community string : private

ここでは SNMP community string を設定します。
詳しくは以下の URL をご参照ください。


Configuring SNMP

 

 

  Enter the switch name : N9K

 

ここでは、スイッチの名前を設定します。
詳しくは以下の URL をご参照ください。

Changing the Device Hostname

 

 

Continue with Out-of-band (mgmt0) management configuration? (yes/no) [y]: yes

    Mgmt0 IPv4 address : 10.201.168.18

    Mgmt0 IPv4 netmask : 255.255.255.248

 

ここではマネージメントインターフェース(mgmt 0) の IP address を設定します。
各製品の mgmt 0 の位置を確認する場合は、各製品のハードウェアインストレーションガイドをご参照ください。

Cisco Nexus 93180YC-FX NX-OS Mode Switch Hardware Installation Guide : Overview

 

mgmt 0 はこのポート専用の management という Virtual Routing and Forwarding(VRF) に属し、
他のポートからの通信から独立して動作します。主に管理用途でご利用頂けます。

 

  Configure the default gateway? (yes/no) [y]: yes

    IPv4 address of the default gateway : 10.201.168.17

 

vrf management の default gateway を設定します。
ここで設定している default gateway は mgmt 0 で通信するためのものであり、
他のポートを利用した通信とは異なる点にご注意ください。

 

  Configure advanced IP options? (yes/no) [n]: yes

 

他の IP 機能を、続けて設定したい場合は yes を選択します。
yes を選択した場合の設定事項を以下に例示します。

 

  Configure static route? (yes/no) [n]: yes

    Destination prefix : 10.0.0.0

    Destination prefix mask : 255.255.255.0

    Next hop IPv4 address : 20.0.0.1

 

特定のネットワーク向けの static route を設定します。
こちらは mgmt 0 ではなく、他のポートをご利用の際に、default の vrf (vrf default) で
通信する際に利用する経路となります。

詳しくは以下の URL をご参照ください。

Configuring Static Routing

 

  Configure the DNS IPv4 address? (yes/no) [n]: yes

    DNS IPv4 address : 8.8.8.8

 

DNS server の IP address を入力します。
詳しくは以下の URL をご参照ください。

Configuring DNS

 

  Configure the default domain name? (yes/no) [n]: no

 

デフォルトの domain name を設定します。

 

  Enable the telnet service? (yes/no) [n]: yes

 

この機器へログインする方法として、telnet を許可する場合、yes を選択します。
デフォルトでは SSH のみとなっています。

 

  Enable the ssh service? (yes/no) [y]: yes

    Type of ssh key you would like to generate (dsa/rsa) [rsa]:

    Number of rsa key bits <1024-2048> [1024]:

 

SSH で利用する key の種類と長さを設定します。

 

SSH/Telnet 設定の詳細は、以下の URL をご確認ください。

 

Configuring SSH and Telnet

 

 

  Configure the ntp server? (yes/no) [n]: yes

    NTP server IPv4 address : 1.1.1.1

 

NTP を利用する場合、NTP server の IP address を設定します。
NTP 設定の詳細は以下の URL をご確認ください。

 

Configuring NTP

 

  Configure default interface layer (L3/L2) [L2]:

 

フロントポートのデフォルトの layer を設定します。デフォルトでは L2 となっています(switchport)。

 

  Configure default switchport interface state (shut/noshut) [noshut]:

 

デフォルトの interface の port の状態を設定します。
デフォルトでは no shutdown となっております。

 

  Enter basic FC configurations (yes/no) [n]: n

 

Fiber Channel の基本設定を実施するかどうかを決定します。

Fiber Channel の詳細などについてはここでは割愛いたします。

 

  Configure CoPP system profile (strict/moderate/lenient/dense) [strict]:

 

スイッチに適用される Control Plane Policing (CoPP) のプロファイルを選択します。
CoPP の詳細については以下の URL をご確認ください。

Configuring Control Plane Policing

 

The following configuration will be applied:
  password strength-check
  username test_1 password <user-password> role network-operator
  snmp-server community public ro
  snmp-server community private rw
  switchname N9K
ip route 10.0.0.0 255.255.255.0 20.0.0.1
vrf context management
ip route 0.0.0.0/0 10.201.168.17
exit
ip name-server 8.8.8.8
  feature telnet
  ssh key rsa 1024 force
  feature ssh
  ntp server 1.1.1.1
  system default switchport
  no system default switchport shutdown
  copp profile strict
interface mgmt0
ip address 10.201.168.18 255.255.255.248
no shutdown

 

ここまでの設定で、適用される設定内容を一覧で表示します。

 

Would you like to edit the configuration? (yes/no) [n]: no

 

再度、設定をやり直す項目があれば、yes を選択します。
この内容でよければ、no を選択します。

上記の設定内容は、設定変更可能なユーザーでログインし、コマンドで変更することが可能です。

 

Use this configuration and save it? (yes/no) [y]: yes
2020 Aug 27 22:55:48 N9K %$ VDC-1 %$ %COPP-2-COPP_POLICY: Control-Plane is protected with policy copp-system-p-policy-strict.

[########################################] 100%
Copy complete, now saving to disk (please wait)...
Copy complete.

 

ここまでの設定内容を保存します。

Cisco Nexus NX-OS Setup Utility を利用した初期設定例 はここで終了となります。

以下は、その後 user admin でログインし、設定内容を確認する方法です。

 

User Access Verification
N9K login: admin
Password:

 

show running-config で設定内容を確認します。

 

N9K# show run

!Command: show running-config
!Running configuration last done at: Thu Aug 27 22:55:48 2020
!Time: Thu Aug 27 22:56:19 2020

version 9.3(5) Bios:version 05.42
switchname N9K
vdc N9K id 1
  limit-resource vlan minimum 16 maximum 4094
  limit-resource vrf minimum 2 maximum 4096
  limit-resource port-channel minimum 0 maximum 511
  limit-resource u4route-mem minimum 248 maximum 248
  limit-resource u6route-mem minimum 96 maximum 96
  limit-resource m4route-mem minimum 58 maximum 58
  limit-resource m6route-mem minimum 8 maximum 8
  limit-resource vni_bd minimum 4096 maximum 4096

feature telnet

username admin password 5 $5$DBPHNA$EnoR2/SDKAtUs3HRzPmFnrElis1sIR6BzAAlm1DUL42
 role network-admin
username test_1 password 5 $5$NNABPA$draEZZRxQ0aJxupLhJ1ehPnxC.LfenqqiOQi7e9TgJ2
  role network-operator
username test_1 passphrase  lifetime 99999 warntime 14 gracetime 3
ip domain-lookup
ip name-server 8.8.8.8
system default switchport


system vlan 200 reserve

copp profile strict
snmp-server user admin network-admin auth md5 0x1a6f4dce18c1ba7e5e909c2fc4ded8b9
 priv 0x1a6f4dce18c1ba7e5e909c2fc4ded8b9 localizedkey
snmp-server user test_1 network-operator auth md5 0x2abe5ff5b7cd3bf3a56f5db14a27
0948 priv 0x2abe5ff5b7cd3bf3a56f5db14a270948 localizedkey
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO
snmp-server community private group network-admin
snmp-server community public group network-operator
ntp server 1.1.1.1 use-vrf default

ip route 10.0.0.0/24 20.0.0.1
vlan 1

vrf context management
  ip route 0.0.0.0/0 10.201.168.17

interface Ethernet1/1

interface Ethernet1/2

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface Ethernet1/11

interface Ethernet1/12

interface Ethernet1/13

interface Ethernet1/14

interface Ethernet1/15

interface Ethernet1/16

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

interface Ethernet1/20

interface Ethernet1/21

interface Ethernet1/22

interface Ethernet1/23

interface Ethernet1/24

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27

interface Ethernet1/28

interface Ethernet1/29

interface Ethernet1/30

interface Ethernet1/31

interface Ethernet1/32

interface Ethernet1/33

interface Ethernet1/34

interface Ethernet1/35

interface Ethernet1/36

interface Ethernet1/37

interface Ethernet1/38

interface Ethernet1/39

interface Ethernet1/40

interface Ethernet1/41

interface Ethernet1/42

interface Ethernet1/43

interface Ethernet1/44

interface Ethernet1/45

interface Ethernet1/46

interface Ethernet1/47

interface Ethernet1/48

interface Ethernet1/49

interface Ethernet1/50

interface Ethernet1/51

interface Ethernet1/52

interface Ethernet1/53

interface Ethernet1/54

interface mgmt0
  vrf member management
  ip address 10.201.168.18/29
icam monitor scale

line console
line vty
boot nxos bootflash:/nxos.9.3.5.bin
no system default switchport shutdown

 

注意事項

 

Cisco Nexus NX-OS Setup Utility を用いて設定した内容は、起動後、Command Line Interface (CLI) で変更することが可能です。  

write erase で設定を消去しても、interface management 0 や boot ファイルに関する情報は消去されません。これらの情報を消去したい場合には write erase boot を利用します。

  

参考情報

 

Cisco Nexus 9000 Series NX-OS Fundamentals Configuration Guide, Release 9.3(x) Chapter: Using the Cisco NX-OS Setup Utility

Cisco Nexus スイッチ (NX-OS) : 設定例

Getting Started

検索バーにキーワード、フレーズ、または質問を入力し、お探しのものを見つけましょう

シスコ コミュニティをいち早く使いこなしていただけるよう役立つリンクをまとめました。みなさんのジャーニーがより良いものとなるようお手伝いします