custom.ribbon_feed
キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
8134
閲覧回数
0
いいね!
0
コメント
Kenji Takahagi
Cisco Employee
Cisco Employee

 

 

はじめに

LACP で提供される機能の max-bundle と min-links の機能について記述します。

設定の矛盾を回避するため、max-bundle や min-links で指定するポート数や、bundle されるポートの lacp port-priority は接続されるポートの間(例: switch A の eth 1/1 と switch B の eth 1/1) で同じ値を設定する必要があります。

  

 

LACP max-bundle

port-channel として含まれる最大の物理ポート数を指定します。

 

Switch(config)# int po 1
Switch(config-if)# lacp max-bundle 1
Switch(config-if)# end
Switch#
Switch# show run int po 1

interface port-channel1
  switchport
  switchport mode trunk
  lacp max-bundle 1

 

この例では、ethernet 1/1 と 1/2 が port-channel 1 として接続し、max-bundle を 1 と設定しています。
接続されているポートが 2 つであるのに対し、max-bundle が 1 と設定されているため、1 つのポートは
Hot-Standby となります。

 

Switch# show port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        b - BFD Session Wait
        S - Switched    R - Routed
        U - Up (port-channel)
        p - Up in delay-lacp mode (member)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)    Eth1/2(H)

 

どのポートが hot-standby になるかは、lacp port-priority に応じて決定されます。

 

矛盾を避けるため、lacp port-priority の値は接続されるポート双方で同じ値に設定します。

以下の例では、eth1/1 に lacp priority 2 を、eth1/2 に lacp port-priority 1 を設定し、数値の低い eth1/2 が優先的に接続されるよう調整しています。

 

Switch# show run int e 1/1-2

interface Ethernet1/1
  lacp port-priority 2
  switchport
  switchport mode trunk
  channel-group 1 mode active
  no shutdown

interface Ethernet1/2
  lacp port-priority 1
  switchport
  switchport mode trunk
  channel-group 1 mode active
  no shutdown

Switch# show port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        b - BFD Session Wait
        S - Switched    R - Routed
        U - Up (port-channel)
        p - Up in delay-lacp mode (member)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(H)    Eth1/2(P)

 

このとき、Hot-standbyとなっているポートの LACP state は 0x5 となっています。 LACP state の詳細は、Nexus シリーズ : LACP Data Unit に記載しています。

 

Switch# show lacp interface e 1/1
Interface Ethernet1/1 is hot-standby
  Channel group is 1 port channel is Po1
  PDUs sent: 74
  PDUs rcvd: 71
  Markers sent: 0
  Markers rcvd: 0
  Marker response sent: 0
  Marker response rcvd: 0
  Unknown packets rcvd: 0
  Illegal packets rcvd: 0
Lag Id: [ [(8000, 0-be-75-18-f3-f7, 8000, 2, 101), (8000, 0-be-75-19-36-d7, 8000, 2, 101)] ]
Operational as aggregated link since Thu Dec 12 07:07:36 2019

Local Port: Eth1/1   MAC Address= 0-be-75-19-36-d7
  System Identifier=0x8000,  Port Identifier=0x2,0x101
  Operational key=32768
  LACP_Activity=active
  LACP_Timeout=Long Timeout (30s)
  Synchronization=NOT_IN_SYNC
  Collecting=false
  Distributing=false
  Partner information refresh timeout=Long Timeout (90s)
Actor Admin State=5
Actor Oper State=5
Neighbor: 0x101
  MAC Address= 0-be-75-18-f3-f7
  System Identifier=0x8000,  Port Identifier=0x2,0x101
  Operational key=32768
  LACP_Activity=active
  LACP_Timeout=Long Timeout (30s)
  Synchronization=NOT_IN_SYNC
  Collecting=false
  Distributing=false
Partner Admin State=5
Partner Oper State=5
Aggregate or Individual(True=1)= 1
Switch# show lacp neighbor int po 1
Flags:  S - Device is sending Slow LACPDUs F - Device is sending Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode
port-channel1 neighbors
Partner's information
            Partner                Partner                     Partner
Port        System ID              Port Number     Age         Flags
Eth1/1      32768,0-be-75-18-f3-f7 0x101           534         SA

            LACP Partner           Partner                     Partner
            Port Priority          Oper Key                    Port State
            2                      0x8000                      0x5

Partner's information
            Partner                Partner                     Partner
Port        System ID              Port Number     Age         Flags
Eth1/2      32768,0-be-75-18-f3-f7 0x105           524         SA

            LACP Partner           Partner                     Partner
            Port Priority          Oper Key                    Port State
            1                      0x8000                      0x3d

この状態で、ポートチャネルとしてアップしている Eth1/2 がダウンすると、Hot-standby であった Eth1/1 がポートチャネルとして動作を開始します。

2019 Dec 12 07:20:52 Switch %ETH_PORT_CHANNEL-5-PORT_HOT_STANDBY_DOWN: port-channel1: hot-standby port Ethernet1/1 is down
2019 Dec 12 07:20:53 Switch %ETH_PORT_CHANNEL-5-PORT_UP: port-channel1: Ethernet1/1 is up
2019 Dec 12 07:20:53 Switch %ETH_PORT_CHANNEL-5-PORT_DOWN: port-channel1: Ethernet1/2 is down
2019 Dec 12 07:20:53 Switch %ETH_PORT_CHANNEL-5-FOP_CHANGED: port-channel1: first operational port changed from Ethernet1/2 to Ethernet1/1
2019 Dec 12 07:20:53 Switch %ETHPORT-5-IF_DOWN_INITIALIZING: Interface Ethernet1/2 is down (Initializing)
2019 Dec 12 07:20:53 Switch %ETHPORT-5-IF_UP: Interface Ethernet1/1 is up in mode trunk

Switch#
Switch# show port-channel sum
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        b - BFD Session Wait
        S - Switched    R - Routed
        U - Up (port-channel)
        p - Up in delay-lacp mode (member)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)    Eth1/2(D)

再度、eth1/2 が UP した場合、Hot-standby になるポートの選考が lacp port-priority に応じて行われ、eth 1/1 が再び Hot-standby となります。

2019 Dec 12 07:23:04 Switch %ETHPORT-5-SPEED: Interface Ethernet1/2, operational speed changed to 10 Gbps
2019 Dec 12 07:23:04 Switch %ETHPORT-5-IF_DUPLEX: Interface Ethernet1/2, operational duplex mode changed to Full
2019 Dec 12 07:23:04 Switch %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet1/2, operational Receive Flow Control state changed to off
2019 Dec 12 07:23:04 Switch %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet1/2, operational Transmit Flow Control state changed to off
2019 Dec 12 07:23:07 Switch %ETHPORT-5-IF_DOWN_PORT_CHANNEL_MEMBERS_DOWN: Interface port-channel1 is down (No operational members)
2019 Dec 12 07:23:07 Switch %ETH_PORT_CHANNEL-5-PORT_DOWN: port-channel1: Ethernet1/1 is down
2019 Dec 12 07:23:07 Switch %ETH_PORT_CHANNEL-5-FOP_CHANGED: port-channel1: first operational port changed from Ethernet1/1 to none
2019 Dec 12 07:23:07 Switch %ETHPORT-5-IF_DOWN_INITIALIZING: Interface Ethernet1/1 is down (Initializing)
2019 Dec 12 07:23:07 Switch %ETHPORT-5-IF_DOWN_PORT_CHANNEL_MEMBERS_DOWN: Interface port-channel1 is down (No operational members)
2019 Dec 12 07:23:10 Switch last message repeated 1 time
2019 Dec 12 07:23:10 Switch %ETH_PORT_CHANNEL-5-PORT_HOT_STANDBY: port-channel1: Ethernet1/1 goes to hot-standby
2019 Dec 12 07:23:10 Switch %ETH_PORT_CHANNEL-5-PORT_UP: port-channel1: Ethernet1/2 is up
2019 Dec 12 07:23:10 Switch %ETH_PORT_CHANNEL-5-FOP_CHANGED: port-channel1: first operational port changed from none to Ethernet1/2
2019 Dec 12 07:23:10 Switch %ETHPORT-5-IF_UP: Interface Ethernet1/2 is up in mode trunk
2019 Dec 12 07:23:10 Switch %ETHPORT-5-IF_UP: Interface port-channel1 is up in mode trunk

Switch#
Switch# show port-ch su
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        b - BFD Session Wait
        S - Switched    R - Routed
        U - Up (port-channel)
        p - Up in delay-lacp mode (member)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(H)    Eth1/2(P)

 

 

LACP min-links

port-channel として動作するために必要最低限の物理ポート数を指定します。

 

Switch# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# int po 1
Switch(config-if)# lacp min-links 2
Switch(config-if)#
Switch(config-if)# show run int po 1

interface port-channel1
  switchport
  switchport mode trunk
  lacp min-links 2

上記は、LACP の port-channel として動作するために、最低限 2 つのポートが接続されている必要があることを設定しています。

もし 1 ポートのみの接続であった場合、port-channel は suspend となり、通信を行うことはできません。

 

2019 Dec 12 07:30:06 Switch %ETH_PORT_CHANNEL-5-PORT_DOWN: port-channel1: Ethernet1/1 is down
2019 Dec 12 07:30:06 Switch %ETHPORT-5-IF_DOWN_INITIALIZING: Interface Ethernet1/1 is down (Initializing)
2019 Dec 12 07:30:08 Switch %ETHPORT-5-IF_DOWN_PORT_CHANNEL_MEMBERS_DOWN: Interface port-channel1 is down (No operational members)
2019 Dec 12 07:30:08 Switch %ETH_PORT_CHANNEL-5-PORT_DOWN: port-channel1: Ethernet1/2 is down
2019 Dec 12 07:30:08 Switch %ETH_PORT_CHANNEL-5-FOP_CHANGED: port-channel1: first operational port changed from Ethernet1/2 to none
2019 Dec 12 07:30:08 Switch %ETHPORT-5-IF_DOWN_INITIALIZING: Interface Ethernet1/2 is down (Initializing)
2019 Dec 12 07:30:08 Switch %ETHPORT-5-IF_DOWN_PORT_CHANNEL_MEMBERS_DOWN: Interface port-channel1 is down (No operational members)
2019 Dec 12 07:30:08 Switch last message repeated 1 time
2019 Dec 12 07:30:08 Switch %ETHPORT-5-SPEED: Interface port-channel1, operational speed changed to 10 Gbps
2019 Dec 12 07:30:08 Switch %ETHPORT-5-IF_DUPLEX: Interface port-channel1, operational duplex mode changed to Full
2019 Dec 12 07:30:08 Switch %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface port-channel1, operational Receive Flow Control state changed to off
2019 Dec 12 07:30:08 Switch %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface port-channel1, operational Transmit Flow Control state changed to off
2019 Dec 12 07:30:11 Switch %ETH_PORT_CHANNEL-5-PORT_SUSPENDED: Ethernet1/2: Ethernet1/2 is suspended

Switch#
Switch# show port-channel sum
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        b - BFD Session Wait
        S - Switched    R - Routed
        U - Up (port-channel)
        p - Up in delay-lacp mode (member)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SM)     Eth      LACP      Eth1/1(D)    Eth1/2(s)
Switch#
Switch# show int po 1
port-channel1 is down (suspended(min-links))
admin state is up,
  Hardware: Port-Channel, address: 00be.7519.36d9 (bia 00be.7519.36d9)
  MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, medium is broadcast
  Port mode is trunk
  auto-duplex, auto-speed
  Input flow-control is off, output flow-control is off
  Auto-mdix is turned off
  Switchport monitor is off
  EtherType is 0x8100
  Members in this channel: Eth1/1, Eth1/2
  Last clearing of "show interface" counters never
  9 interface resets
  Load-Interval #1: 30 seconds
    30 seconds input rate 824 bits/sec, 0 packets/sec
    30 seconds output rate 296 bits/sec, 0 packets/sec
    input rate 824 bps, 0 pps; output rate 296 bps, 0 pps
  Load-Interval #2: 5 minute (300 seconds)
    300 seconds input rate 536 bits/sec, 0 packets/sec
    300 seconds output rate 88 bits/sec, 0 packets/sec
    input rate 536 bps, 0 pps; output rate 88 bps, 0 pps
  RX
    0 unicast packets  2093 multicast packets  0 broadcast packets
    2093 input packets  171820 bytes
    0 jumbo packets  0 storm suppression bytes
    0 runts  0 giants  0 CRC  0 no buffer
    0 input error  0 short frame  0 overrun   0 underrun  0 ignored
    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
    0 input with dribble  0 input discard
    0 Rx pause
  TX
    0 unicast packets  409 multicast packets  0 broadcast packets
    409 output packets  59256 bytes
    0 jumbo packets
    0 output error  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble  0 output discard
    0 Tx pause

このとき、suspend の状態で接続されている eth 1/2 の lacp status は 0x5 となっています。LACP state の詳細は、Nexus シリーズ : LACP Data Unit に記載しています。

Switch# show lacp interface e 1/2
Interface Ethernet1/2 is suspended
  Channel group is 1 port channel is Po1
  PDUs sent: 164
  PDUs rcvd: 163
  Markers sent: 0
  Markers rcvd: 0
  Marker response sent: 0
  Marker response rcvd: 0
  Unknown packets rcvd: 0
  Illegal packets rcvd: 0
Lag Id: [ [(8000, 0-be-75-18-f3-f7, 8000, 1, 105), (8000, 0-be-75-19-36-d7, 8000, 1, 105)] ]
Operational as aggregated link since Thu Dec 12 07:23:10 2019

Local Port: Eth1/2   MAC Address= 0-be-75-19-36-d7
  System Identifier=0x8000,  Port Identifier=0x1,0x105
  Operational key=32768
  LACP_Activity=active
  LACP_Timeout=Long Timeout (30s)
  Synchronization=NOT_IN_SYNC
  Collecting=false
  Distributing=false
  Partner information refresh timeout=Long Timeout (90s)
Actor Admin State=5
Actor Oper State=5
Neighbor: 0x105
  MAC Address= 0-be-75-18-f3-f7
  System Identifier=0x8000,  Port Identifier=0x1,0x105
  Operational key=32768
  LACP_Activity=unknown
  LACP_Timeout=Long Timeout (30s)
  Synchronization=NOT_IN_SYNC
  Collecting=false
  Distributing=false
Partner Admin State=5
Partner Oper State=5
Aggregate or Individual(True=1)= 2
Switch#
Switch# show lacp neighbor int po 1
Flags:  S - Device is sending Slow LACPDUs F - Device is sending Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode
port-channel1 neighbors
Partner's information
            Partner                Partner                     Partner
Port        System ID              Port Number     Age         Flags
Eth1/2      32768,0-be-75-18-f3-f7 0x105           477         SA

            LACP Partner           Partner                     Partner
            Port Priority          Oper Key                    Port State
            1                      0x8000                      0x5

eth1/1 の接続が再度確立されると、port-channel 1 は UP となります。

2019 Dec 12 07:34:59 Switch %ETHPORT-5-SPEED: Interface Ethernet1/1, operational speed changed to 10 Gbps
2019 Dec 12 07:34:59 Switch %ETHPORT-5-IF_DUPLEX: Interface Ethernet1/1, operational duplex mode changed to Full
2019 Dec 12 07:34:59 Switch %ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet1/1, operational Receive Flow Control state changed to off
2019 Dec 12 07:34:59 Switch %ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet1/1, operational Transmit Flow Control state changed to off
2019 Dec 12 07:35:02 Switch %ETH_PORT_CHANNEL-5-PORT_UP: port-channel1: Ethernet1/1 is up
2019 Dec 12 07:35:02 Switch %ETH_PORT_CHANNEL-5-FOP_CHANGED: port-channel1: first operational port changed from none to Ethernet1/1
2019 Dec 12 07:35:02 Switch %ETHPORT-5-IF_UP: Interface Ethernet1/1 is up in mode trunk
2019 Dec 12 07:35:02 Switch %ETHPORT-5-IF_UP: Interface port-channel1 is up in mode trunk
2019 Dec 12 07:35:05 Switch %ETH_PORT_CHANNEL-5-PORT_UP: port-channel1: Ethernet1/2 is up
2019 Dec 12 07:35:05 Switch %ETHPORT-5-IF_UP: Interface Ethernet1/2 is up in mode trunk

Switch# show int po 1
port-channel1 is up
admin state is up,
  Hardware: Port-Channel, address: 00be.7519.36d8 (bia 00be.7519.36d8)
  MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, medium is broadcast
  Port mode is trunk
  full-duplex, 10 Gb/s
  Input flow-control is off, output flow-control is off
  Auto-mdix is turned off
  Switchport monitor is off
  EtherType is 0x8100
  Members in this channel: Eth1/1, Eth1/2
  Last clearing of "show interface" counters never
  10 interface resets
  Load-Interval #1: 30 seconds
    30 seconds input rate 1176 bits/sec, 0 packets/sec
    30 seconds output rate 1304 bits/sec, 0 packets/sec
    input rate 1.18 Kbps, 0 pps; output rate 1.30 Kbps, 0 pps
  Load-Interval #2: 5 minute (300 seconds)
    300 seconds input rate 96 bits/sec, 0 packets/sec
    300 seconds output rate 128 bits/sec, 0 packets/sec
    input rate 96 bps, 0 pps; output rate 128 bps, 0 pps
  RX
    0 unicast packets  2143 multicast packets  0 broadcast packets
    2143 input packets  178196 bytes
    0 jumbo packets  0 storm suppression bytes
    0 runts  0 giants  0 CRC  0 no buffer
    0 input error  0 short frame  0 overrun   0 underrun  0 ignored
    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
    0 input with dribble  0 input discard
    0 Rx pause
  TX
    0 unicast packets  445 multicast packets  0 broadcast packets
    445 output packets  64516 bytes
    0 jumbo packets
    0 output error  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble  0 output discard
    0 Tx pause

Switch# show port-channel sum
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        b - BFD Session Wait
        S - Switched    R - Routed
        U - Up (port-channel)
        p - Up in delay-lacp mode (member)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
1     Po1(SU)     Eth      LACP      Eth1/1(P)    Eth1/2(P)

 

 

関連コンテンツ

Nexus シリーズ : Nexus シリーズ : Link Aggregation Control Protocol (LACP) の設定例

Nexus シリーズ : LACP Data Unit

Nexus シリーズ : LACP suspend-individual

Nexus スイッチ (NX-OS) : 設定例

 

 

参考情報

Cisco Nexus 9000 Series NX-OS Interfaces Configuration Guide, Release 9.3(x)

Getting Started

検索バーにキーワード、フレーズ、または質問を入力し、お探しのものを見つけましょう

シスコ コミュニティをいち早く使いこなしていただけるよう役立つリンクをまとめました。みなさんのジャーニーがより良いものとなるようお手伝いします