cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2233
Views
0
Helpful
3
Replies

TReX isssues with Intel NIC ixgbe

riasudeen
Beginner
Beginner

Hi,

I am new to TReX, TReX running in RHEL 7.2 and defined 2 No's of 10Gig Interface ports in trex_cfg.yaml

Interface Details:

Intel 82599ES 10-Gigabit SFI/SFP+

driver: ixgbe and version 5.3.5 (Ensured its latest NIC drivers)

Normally, I am able to see above interfaces when run "ifconfig" or "nmcli conn show"

This interfaces disappears from ifconfig  after i do trex test, Also ethtool not able to find the NIC

# sudo ./t-rex-64 --cfg /etc/trex_enp129s0f_cfg.yaml -f cap2/dns.yaml -c 4 -m 1 -d 10 -l 1000


Starting TRex v2.34 please wait ...

set driver name net_ixgbe

driver capability : TCP_UDP_OFFLOAD TSO


set driver name net_ixgbe driver capability : TCP_UDP_OFFLOAD TSO


<Omitted test output> ...............................................


# ethtool enp129s0f0


Settings for enp129s0f0:

Cannot get device settings: No such device

Cannot get wake-on-lan settings: No such device

Cannot get message level: No such device

Cannot get link status: No such device

No data available

Any help would be highly appriciated

Thanks,

Gani

1 Accepted Solution

Accepted Solutions

ybrustin
Cisco Employee
Cisco Employee

Hi,

Upon TRex start, it removes the interfaces from Linux native driver and binds to it's own driver (for increased speed).

To return the interfaces to Linux:

  1. Ensure TRex is not running
  2. Run following command: (little L as argument)
    sudo ./dpdk_setup_ports.py -l

Thanks,

Yaroslav.

View solution in original post

3 Replies 3

riasudeen
Beginner
Beginner

Please Note. Interface appears in ifconfig after reboot

Thanks @Yaroslav Brustinov

I see ports Returning to Linux after entering the command you mentioned above.

Thanks,

Rias

ybrustin
Cisco Employee
Cisco Employee

Hi,

Upon TRex start, it removes the interfaces from Linux native driver and binds to it's own driver (for increased speed).

To return the interfaces to Linux:

  1. Ensure TRex is not running
  2. Run following command: (little L as argument)
    sudo ./dpdk_setup_ports.py -l

Thanks,

Yaroslav.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers