cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

UCSD - Workflow Rules Example

495
Views
0
Helpful
3
Comments

 

Task Name

Workflow Rules

Description

Workflow input rules example

Prerequisites

Validated on UCSD 6.6

Category

Workflow Task

Components

 

User Inputs

  1. Number of disks

Output

Result of operation

 

 

Installation

  1. Download the attached .ZIP file below to your computer. *Remember the location of the saved file on your computer.
  2. Unzip the file on your computer. Should end up with a .WFDX file.
  3. Log in to UCS Director as a user that has "system-admin" privileges.
  4. Navigate to "Policies-->Orchestration" and click on "Import".
  5. Click "Browse" and navigate to the location on your computer where the .WFD file resides. Choose the .WFD file and click "Open".
  6. Click "Upload" and then "OK" once the file upload is completed. Then click "Next".
  7. Click the "Select" button next to "Import Workflows". Click the "Check All" button to check all checkboxes and then the "Select" button.
  8. Click "Submit".
  9. A new folder should appear in "Policies-->Orchestration" that contains the imported workflow. You will now need to update the included tasks with information about the specific environment.

The workflow: 

 

Screen Shot 2018-07-25 at 11.35.57 AM.png

 

Workflow input: 

Screen Shot 2018-07-25 at 10.56.42 AM.pngScreen Shot 2018-07-25 at 10.56.35 AM.pngScreen Shot 2018-07-25 at 10.56.27 AM.png

 

 

Workflow run with one disk: 

 

Screen Shot 2018-07-25 at 11.01.11 AM.pngScreen Shot 2018-07-25 at 11.01.44 AM.pngWorkflow run with 2 disks: 

 

Screen Shot 2018-07-25 at 11.03.51 AM.pngScreen Shot 2018-07-25 at 11.04.35 AM.pngWorkflow run with 3 disks: 

 

Screen Shot 2018-07-25 at 11.06.42 AM.pngScreen Shot 2018-07-25 at 11.06.55 AM.png

Comments
Beginner
Has anyone also experienced problems when using Custom Workflow Inputs for me (regex validated gen_text_input) and User Input Rules together ? Today I've used a such a Custom Workflow Input as an Input Type for one of my User Inputs in a Workflow. In that same Workflow i was also using User Input Rules. When testing the workflow, I noticed that my validated input was not working. So I tried it in a different workflow, where i had nothing configured, but this one validated Input and there the validation worked correct. After doing that, i tried the validated user input again in the original workflow but this time with User Input Rules turned off and that way the validation worked. But after enabling the User Input Rules again, the validation didn't work anymore. Am I missing a setting, that i have to do when using these settings together ?
Cisco Employee

May we know the UCSD version 6.6 or 6.7?

Beginner
Yes of course my bad for not mentioning that in my first post.. Im using UCSD version 6.6
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.