cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
783
Views
0
Helpful
2
Replies

Help with CME and incoming sip calls.

alexten1983
Level 1
Level 1

I have CME setup on SIP and out bound works good. The thing is I have it setup behind a home router on privet IP address. When the calls come is it hits the CME but it hits it with a public ip address. 

SIP/2.0 400 Bad Request - 'Invalid Host'

To: <sip:3475416554@100.2.251.57:55158;transport=tcp>;tag=1890CC7C-1758

but the ip of CME is 192.168.1.6

I did come across this but didn't try it as my ip is dynamic. 

  • NAT Traversal

If your CUBE is behind a NAT and does not have a public IP, you need to modify the IPs in the SIP messages to your public IP using SIP Profiles as shown below:

In global configuration mode

voice class sip-profiles 1
response ANY sip-header Contact modify "172.x.y.z" "1.2.3.4" !1.2.3.4 Public IP; 172.x.y.z Private IP of the CME
request ANY sip-header Contact modify "172.x.y.z" "1.2.3.4" 
response ANY sdp-header Audio-Connection-Info modify "172.x.y.z" "1.2.3.4"
response ANY sdp-header Connection-Info modify "172.x.y.z" "1.2.3.4"
response ANY sdp-header Session-Owner modify "172.x.y.z" "1.2.3.4"
request ANY sdp-header Audio-Connection-Info modify "172.x.y.z" "1.2.3.4"
request ANY sdp-header Connection-Info modify "172.x.y.z" "1.2.3.4"
request ANY sdp-header Session-Owner modify "172.x.y.z" "1.2.3.4"

This can then be applied either globally to the general sip config or under the dial-peer config using:

voice-class sip profiles 1

Additionally, it is advisable to define a loopback interface and configure it with your public IP address. Do not advertise this into your network though, as it may cause other problems.

In global configuration mode

interface loopback 0
ip address 50.249.214.241 255.255.255.0

  • Inbound calling:

Use translation rules and translation profiles to translate your DIDs to extensions. 

  • Create a voice translation rule. For example, the rule below translates 13125489677 to 3005

In global configuration mode

voice translation-rule 100
rule 1 /13125489677/ /3005/   !  Several rules can be defined. In this case, 3005 is an extension on CUCM
  • Create a translation profile using the rule created:

In global configuration mode

voice translation-profile 100
translate called 100
  • Apply the translation profile to the dial-peer:
translation-profile incoming 100
nWhat would you guys suggest for me to do to get the incoming to work in that kind of setup?

2 Replies 2

alexten1983
Level 1
Level 1

Ok I got it to work on incoming with the above suggestion.

dditionally, it is advisable to define a loopback interface and configure it with your public IP address. Do not advertise this into your network though, as it may cause other problems.

In global configuration mode

interface loopback 0
ip address 50.249.214.241 255.255.255.0

 How do I make sure it is not being advertise?

And If this setting works what is the best way to go about it as the public ip might change?

Plase some one help as the public ip changed and incoming stopped working here is my set up.

home asus router with a dhcp from isp seting -> CME 8.0 on privet ip.

Here is the config with old isp IP when it was working till the isp ip changed. 

sip
bind control source-interface GigabitEthernet0/0.10
bind media source-interface GigabitEthernet0/0.10
registrar server expires max 1800 min 1800
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 ilbc
codec preference 3 g729r8
!
voice class sip-profiles 1
request ANY sip-header Contact modify "192.168.1.6" "100.2.254.60"
response ANY sdp-header Audio-Connection-Info modify "192.168.1.6" "100.2.254.6
0"
response ANY sdp-header Connection-Info modify "192.168.1.6" "100.2.254.60"
response ANY sdp-header Session-Owner modify "192.168.1.6" "100.2.254.60"
request ANY sdp-header Audio-Connection-Info modify "192.168.1.6" "100.2.254.60
"
request ANY sdp-header Connection-Info modify "192.168.1.6" "100.2.254.60"
request ANY sdp-header Session-Owner modify "192.168.1.6" "100.2.254.60"

interface Loopback0
ip address 100.2.254.60 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
description DataVlan
encapsulation dot1Q 10
ip address 192.168.1.6 255.255.255.192
ip helper-address 192.168.1.2
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.100
description VOICE Vlan
encapsulation dot1Q 100
ip address 192.168.10.1 255.255.255.240
ip helper-address 192.168.10.2
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip http server
no ip http secure-server

ip route 0.0.0.0 0.0.0.0 192.168.1.1