cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

644
Views
10
Helpful
6
Replies
Nishad Ismail
Beginner

XML Error [4]: parse error in all the IP Phones

Hi All,

While clicking on the Global Directory we are getting "XML Error [4]: Parse error " on the Cisco IP phone display,Global directory is pointed to the external server located in Same location .The issue started one week back .

I have attached the Wireshork output of the Phone ..

Regards,

Nishad KI

6 REPLIES 6

Hi

This means that the web server is returning something that the phone cannot understand - typically this is an error page or some such that is not formatted in the XML way that the phones need.

In your packet capture you can see this happening - packet 558 has a request to the web server, and 561 contains the response. It is a HTTP Error 500 page formatted in HTML. You'll need to debug the server.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Great catch Aaron

To aid with your trouble shooting an example of one of the requests that is failing is:

http://10.106.32.64/CiscoIPServices/multidirectory/multidirectory.asp?id=4&action=list&l=a&f=a

From the URL a first name of 'a' and a last name of 'a' was entered, did something change recently that would affect this custom service?

I would assume this directory service queries LDAP/AD, you might want to check the user account it uses is still valid and have a look at the windows event logs on 10.106.32.64 for any hints.

Note: A restart of IIS on the directory application server might help to resolve this

Thanks

Stephen

Thanks Aaron and Stephen ....

Packet 561 Showing below errors in extensible Markup Language

error '800a0031'

Invalid Credentials

Is it related to the LDAP integration ?

What i need to check in the CUCM and IIS server ?

Hi

Looks that way - most likely the passowrd on the account that the directory uses in AD has changed/expired/locked.

Somewhere in the files in the web server directory (usually embedded in the .asp files, so crack those open with notepad and take a look) there should be some fairly obvious credentials...

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Thank you so much Aaron ...

Issue was with the AD account  .We have resolved the issue by reset the account parameters .

Great - glad it's sorted.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Content for Community-Ad