cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6984
Views
0
Helpful
4
Replies

DHCP for Issue for Voice VLANS Problem

Charlie Mayes
Level 1
Level 1

Hello Guys,

                 My Cisco phone will not retreive a IP address from the scope I have configured on my layer 3 3550 switch. My config is below. Does anyone see a problem with it? Thanks.

!

ip subnet-zero
ip routing
no ip domain-lookup
ip dhcp excluded-address 10.3.3.1 10.3.3.40
!
ip dhcp pool 3550POEVoicePool
   network 10.3.3.0 255.255.255.0
   default-router 10.3.3.50
   domain-name
   option 150 ip 10.3.3.150
   lease 8
!
ip dhcp pool 3550POEDATAPool
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.50
   domain-name Mayes
   lease 8
!
mls qos
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 2
switchport mode access
switchport voice vlan 3
no ip address
mls qos trust device cisco-phone
spanning-tree portfast
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.2.50 255.255.255.0
!
interface Vlan3
ip address 10.3.3.50 255.255.255.0
!
ip classless
ip http server
!
!
!
line con 0
line vty 0 4
password cisco
line vty 5 15
!
end

1 Accepted Solution

Accepted Solutions

khayes1984
Level 1
Level 1

I see the problem here. Try and verify a couple of things...

Trunking is configured correctly..

Make sure you run the IP helper command. This command allows DHCP request to be sent to the subnet of the IP phones.The IP address that you need to put should be the IP address of the DHCP server. if your gateway is your DHCP server you must create a sub interface ( int GE 1/1.10) or whatever the VLAN ID for your voice, and do " IP-helper (ip of DHCP server)" if you have any questions let me know and i'll show you my config and you can see what I'm talking about.

View solution in original post

4 Replies 4

khayes1984
Level 1
Level 1

I see the problem here. Try and verify a couple of things...

Trunking is configured correctly..

Make sure you run the IP helper command. This command allows DHCP request to be sent to the subnet of the IP phones.The IP address that you need to put should be the IP address of the DHCP server. if your gateway is your DHCP server you must create a sub interface ( int GE 1/1.10) or whatever the VLAN ID for your voice, and do " IP-helper (ip of DHCP server)" if you have any questions let me know and i'll show you my config and you can see what I'm talking about.

Thanks. That did the job. I can't believe I missed that.

Hello Kenneth,

I'm running a 3750G-24PS Switch. I trying to get this config to work and you look like you got it work. Here's my config. Your assistance is greatly appreciated. Thanks!


!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ps
system mtu routing 1500
ip subnet-zero
ip routing
no ip domain-lookup
no ip dhcp use vrf connected
!
ip dhcp pool VOICE_NETWORK
   import all
   network 172.16.9.0 255.255.255.0
   dns-server 172.16.3.20 172.16.1.20
   netbios-name-server 172.16.3.20 172.16.1.20
   default-router 172.16.9.1
   option 150 ip 172.16.1.45
   lease 14
!
ip dhcp pool DATA_NETWORK
   import all
   network 172.16.7.0 255.255.255.0
   dns-server 172.16.3.20 172.16.1.20
   netbios-name-server 172.16.3.20 172.16.1.20
   default-router 172.16.7.1
   lease 14
!
!
!
mls qos
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet1/0/1
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/3
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/4
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/5
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/6
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/7
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/8
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/9
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/10
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/11
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/12
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/13
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/14
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/15
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/16
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/17
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/18
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/19
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/20
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/21
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/22
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/23
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/24
switchport access vlan 440
switchport mode access
switchport voice vlan 441
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
description Internal_NETWORK
ip address 172.16.3.16 255.255.255.0
!
interface Vlan440
description 4040 DATA_NETWORK
ip address 172.16.7.1 255.255.255.0
!
interface Vlan441
description 4040 VOICE_NETWORK
ip address 172.16.9.1 255.255.255.0
!
ip default-gateway 172.16.3.3
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end

What about your voice gateway? Do you have your sub interfaces configured?