cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Problem: MOH for external callers

ludovic.anquier
Beginner
Beginner

Hi!

I have à problem with the configuration of music on hold on my SPA 9000. I've change the MOH by TFTP server (like in admin guide). It works but only with internal calls. When I put on hold an external caller, he hears another music but not my music. I don't know where this music comes from. Is a codec problem? Does it come from my voip provider?

Thanks

Ludovic, France

14 REPLIES 14

Patrick Born
Cisco Employee
Cisco Employee

Hi Ludovic,

I cannot think of any way that a caller can hear MoH audio that is not controlled by you.

Codec use only affects if MoH is supported or not, not the audio source.

Please do the following to help troubleshoot this further:

  1. Provide the SPA9000 configuration as described here: https://www.myciscocommunity.com/docs/DOC-3027
  2. Provide the phone's configuration as described here: https://www.myciscocommunity.com/docs/DOC-2982
  3. Configure debugging on the SPA9000 as described here: https://www.myciscocommunity.com/docs/DOC-3032
  4. Configure debugging on the SPA phone as described here: https://www.myciscocommunity.com/docs/DOC-3033
  5. Make an internal call and put the call on hold so the information is logged
  6. Make an external call and put the call on hold so the information is logged
  7. Ask the person being called to record the audio, using their mobile phone's audio record feature, or something similar
  8. Send me the configuration files, log file, and the MoH audio heard by the external called party

Regards,

Patrick

-----------

Hi Patrick!

Thanks for your help!  I send you the configuration of my SPA9000 and SPA9XX. I don-t really understand what logs say so I send them too.

I can't record the music on hold for external caller (my phone doesn't have the option) but it's not the same that I have in my SPA9000 (default music downloaded on Linksys.com)

Thanks

Hi Ludovic,

Looking at the SPA9000 information:

The following is reported/configured on your SPA9000:

Voice > Info > Internal Music Status > Installed Music Path: tftp://192.168.1.33:69/perfume.au

Voice > SIP > PBX Parameters > Call Park MOH Server: imusic

Voice > SIP > Internal Music Source Parameters > Internal Music URL: tftp://192.168.1.33:69/romance.dat

I would expect both Voice > Info > Internal Music Status > Installed Music Path: and Voice > SIP > Internal Music Source Parameters > Internal Music URL: to be the same.

Could it be that you intend for people to hear romance.dat, but callers are hearing perfume.au instead?

I'm wondering if the TFTP transfer failed when you attempted to install romance.dat.

Can you please try install romance.dat again?

This time, watch the TFTP server's log and also watch the SPA9000's log to see if any errors are reported.

Lastly, please verify that romance.dat is in G.711u format, sampled at 8000 samples/sec, has  no file header, and is less than 65.6 seconds in length.

Regards,

Patrick

----------

Hi Patrick

I changed the configuration:

voice>info>Internal Music Status>Installed Music Path: tftp://192.168.1.33:69/romance.dat

voice>SIP>Internal music parameters>Internal music URL: tftp://192.168.1.33:69/romance.dat

I can hear romance.dat for internal calls only. I know how to change this music easily by TFTP server (I use Solarwinds TFTP server), TFTP transfer works perfectly. My problem is that for external calls, callers hear a totally unknown music. I don't know where it comes from, it's not "perfume.au". It sounds like flamenco but I really don't know this music, I never heared it before!

So I don't know how I can't change it for external calls. I'm using romance.dat that I downloaded on linksys.com (default music for SPA9000) so it's in good format (g711u, 8000kbits, no header and good lenght)

I'm using SPA9000 v2.0 with firmware 6.1.5

I saw that a lot of people ask the same question on many forums but no response, don't you think it could be a bug on the SPA9000?

Thanks