Showing results for 
Search instead for 
Did you mean: 

Anyconnect causes high CPU and IO load on linux

Norbert Bukuli


vpnagentd occasionally causes high CPU and IO load, that could be seen in top(1) and iotop(8). The load does not disappear by itself, vpnagentd must be restarted.

Attempts for resolution

I have tried to investigate the cause of the high load with strace and I figured out, that /etc/resolv.conf is somehow involved in the situation. An inotify watch is set on the file, then it is written, and jumping back to the inotify_add_watch system call.


I have also tried to eliminate the load without restarting the vpnagend,  because that breaks my workflow. I have changed the /etc/resolv.conf to break the infinite loop in vpnagentd with the following attempts and results:

  •  write a space character at the end of /etc/resolv.conf, sleep 1s and repeat until the load disappears. That might help sporadically.
  • rename the /etc/resolv.conf file then move it back to the original name. That helps, but after a while the /etc/resolv.conf file changes back to the dhcpcd generated one, so no VPN related name servers are registered.

strace(1) logs are attached.


  • gentoo linux
  • linux kernel version: 4.19.97-gentoo
  • NetworkManager is not installed in the system
  • network autoconfiguration is done with DHCP protocol, dhcpcd client v7.2.3
  • anyconnect version: anyconnect-linux64-4.8.03036-predeploy-k9


  • Has anybody faced the described situation?
  • Is there any resolution for the problem

Thank you for the replies in advance.

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers