cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1171
Views
0
Helpful
2
Replies
sphughes
Beginner

AnyConnect Version issues on ASA - keeps trying to downgrade

I'm trying to test and then update our corporate AnyConnect Client from version 2.4.0202 up to version 2.5.2019.  I have current production clients using 2.4.0202 and everything is working fine as expected.  I have a test machine which I installed 2.5.2019 (with the SBL/GINA if it matters).  I uploaded the 2.5.2019 pkg to my ASA but left it as a the lower priority image so as to not update production clients.

Now, everytime I try to connect using my 2.5 test client, it attempts to downgrade me back to 2.4.  Certainly there must be a way to test more than one version of the AnyConnect client.  They can't expect me to just upload the new client straight into production.  Any help?

Other possibly relevant info:

Using AnyConnect as SSL

ASA version 8.0(4)

ASDM version 6.1(5)

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
bravotom99
Beginner

I think I had the same problem.  On the machine you installed 2.5 on, make sure there is a

VPNManifest.dat file in C:\Documents and Settings\All Users\Application Data\Cisco\Cisco AnyConnect VPN Client.  I found that when this was missing completely, it tried to downgrade.  I think you can copy over the VPNManifest.dat from any machine including one that had 2.4 installed but 2.5 might be better.  I'm not sure why it doesn't get created in every instance.

View solution in original post

2 REPLIES 2
bravotom99
Beginner

I think I had the same problem.  On the machine you installed 2.5 on, make sure there is a

VPNManifest.dat file in C:\Documents and Settings\All Users\Application Data\Cisco\Cisco AnyConnect VPN Client.  I found that when this was missing completely, it tried to downgrade.  I think you can copy over the VPNManifest.dat from any machine including one that had 2.4 installed but 2.5 might be better.  I'm not sure why it doesn't get created in every instance.

View solution in original post

That did it, thanks.

For anyone searching in the future, on Windows 7 the file is under c:\Program Data\Cisco\Cisco Anyconnect VPN Client

The VPNManifest from the 2.4 client did work.

Content for Community-Ad