cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
270170
Views
40
Helpful
24
Replies
lindacbennett13
Beginner

AnyConnect VPN client version 2.5.0217- not able to establish connection to gateway

I am getting an error when trying to establish a connection to the secure gateway:  AnyConnect was not able to establish a connection to the specified secure gateway.  Please try connecting again.

I have tried connecting again many times.  I have also tried rebooting my machine and connecting to no avail.  The problem seems to be intermittent though, because it did connect just fine over the past few days.  Can anyone assist?

I am runing version 2.5.0217 on windows Vista.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hey,

I had the same problem and resolved by disabling the ICS(Internet Connection Sharing).

View solution in original post

I also have the same problem and tried all of the solutions listed above. I saw in another forum that if a wifi hotspot is enabled on a windows 7 PC, then cisco VPN will not connect. 

I disabled wifi hotspot and this did not help either. 

I finally got my VPN working by doing the following: Go to Network and sharing centre -> Change adapter settings. Right click on each connection and click on properties. Go to sharing tab and uncheck "Allow other network users to connect through this computers internet connect". This should work.

View solution in original post

24 REPLIES 24
Woodharbor
Beginner

I have had similar issues, usually when trying to connect from a wireless network while staying in a motel.  The only way I have been able to get mine to work, has been to uninstall the AnyConnect VPN Client from my laptop, reboot and reinstall the AnyConnect VPN Client.

I have also uninstalled and reinstalled, rebooted etc several times.  It does seem to work for a day if I reinstall it, but this is not a working solution.  I cannot afford to waist time reinstalling this software evertime I need to use it.

I'm on version 3.1 04072 and AnyConnect fails to connect whenever 'Internet Connection Sharing (ICS) service is running. Workaround is to stop service before connecting to VPN.

Hey,

I had the same problem and resolved by disabling the ICS(Internet Connection Sharing).

View solution in original post

Hi,

You're not able to connect with the client from the same location you were able days ago?

Has something changed on the VPN server configuration? Or on the client side?

Can you PING the VPN server IP address from the client?

Do you have access to the configuration of the VPN server that you can share with us?

Can you try connecting from a different location?

Federico.

I tried pinging the vpn server, and it timed out.  Rebooting now.

upgrade to latest?

wavinitaliaspa
Beginner

Hello ,

did you solve the problem ? How ? We have the same error and we do not know how to solve it

Thank you

aggiesoft
Beginner

Hello All,

For me, I kept getting the same errors mentioned earlier. Once the install went through, for the life of me I couldn't connect. I just happened to stumble across this after hours and hours... [This worked for me (on Vista)]...

To connect:

1. Once the Anyconnect install finishes succesfully (<---ONLY THE VERY FIRST TIME)

2. "Control Panel"

3. "Network and Sharing Center"

4. "Manage Network Connections"

5. There should be a VPN connection in the list. Simply right-click on it and click on the "Enable" option. It should go through a few connection messages "Enabling... Authenticating..." [blah-blah-blah]... Then you should be connected...

6. To verify, open a command prompt and type "ipconfig /all"...

NOTE: CONNECTING USING THE ACTUAL ANYCONNECT PROGRAM NEVER WORKED FOR ME (NO MATTER WHAT).

I hope this works for someone...

I have run into this issue on Windows 7 when two users are logged in to the client machine. Trying to connect resulted in the unhelpful message:

"AnyConnect was not able to establish a connection to the specified secure gateway.  Please try connecting again."

Trying to reinstall, as suggested above, gave a message regarding multiple users logged in. I logged off one user and was able to connect as normal.

I have checked everything you suggested above on my pc and it is correct. But still couldn't connect, can anyone help me what the problem could be on the server (ASA) side? I can ping but can't connect using anyconnect client.

Steve Prescott
Beginner

I have had exactly the same problem on a Windows 7 Professional laptop.

In fact I had one that worked and another that came up with "AnyConnect was not able to establish a connection to the specified secure gateway. Please try connecting again."

After reading many forums and trying all the suggestions I still couldnt fix it.  In the end it turned out to be an easy fix, although I have no idea why this would have happened.

Solution:

Go to Control Panel - Network & Internet - View Network status & tasks - Change Adapter Settings. Then right-click the Anyconnect connection and select properties. Select 'Internet Protocol Version 4" and select Properties.

I had an 'Use the folloiwng IP address" selected and an IP address in the fields (this was actually an IP address from the VPN pool".  I simply changed the 2 radio buttons on the screen to Obtain automatically and removed the addresses and hey presto, established the VPN at the first attempt.

I also have the same problem and tried all of the solutions listed above. I saw in another forum that if a wifi hotspot is enabled on a windows 7 PC, then cisco VPN will not connect. 

I disabled wifi hotspot and this did not help either. 

I finally got my VPN working by doing the following: Go to Network and sharing centre -> Change adapter settings. Right click on each connection and click on properties. Go to sharing tab and uncheck "Allow other network users to connect through this computers internet connect". This should work.

View solution in original post

first ensure if vpn pool is not exhausted also try with making registry edit.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vpnva]

"DisplayName"="Cisco AnyConnect VPN Virtual Miniport Adapter for Windows x64".. you may get garbage value in "DisplayName" field. detele all those garbase values before "Cisco AnyConnect.................."

Content for Community-Ad