06-04-2012 02:09 PM
Howdy all,
I'm attempting to configure an for both site-to-site and remote access VPNs. The site-to-site is working fine, however when I connect using the Cisco client, after initial connection and password prompt I get a "not connected" status. The log states that a policy map match could not be found. I have successfully set the unit up for remote access with no site-to-site and ran into another host of issues when adding the site-to-site to the working remote access config, so I started over setting up site-to-site first. I've attempted this through ADSM (hate it) - the current configuration is via CLI. Any thoughts would be appreciated, I'm certain I'm just missing a piece or two.
ASA Version 8.2(5)
!
hostname ASA5505
enable password XXXXXXXXX encrypted
passwd XXXXXXXXX encrypted
names
name 192.168.0.0 MainOffice
name 192.168.251.0 RAAddresses
name 10.10.10.0 MainSiteIP
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.250.147 255.255.255.0
!
ftp mode passive
access-list 101 extended permit ip 192.168.1.0 255.255.255.0 MainOffice 255.255.
255.0
access-list 101 extended permit ip MainOffice 255.255.255.0 192.168.1.0 255.255.
255.0
access-list 102 extended permit ip any any
access-list 102 extended permit ip MainOffice 255.255.255.0 192.168.1.0 255.255.
255.0
access-list 103 extended permit ip RAAddresses 255.255.255.0 192.168.1.0 255.255
.255.0
access-list 103 extended permit ip 192.168.1.0 255.255.255.0 RAAddresses 255.255
.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool RAPool 192.168.251.100-192.168.251.120
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 0 access-list 103
nat (inside) 1 0.0.0.0 0.0.0.0
access-group 102 in interface inside
route outside 0.0.0.0 0.0.0.0 192.168.250.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
http MainOffice 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set CryptoSet esp-aes-256 esp-sha-hmac
crypto ipsec transform-set RA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map dyn1 1 set transform-set RA
crypto map outsidemap0 1 match address 101
crypto map outsidemap0 1 set peer MainSiteIP
crypto map outsidemap0 1 set transform-set CryptoSet
crypto map outsidemap0 interface outside
crypto map mymap 100 ipsec-isakmp dynamic dyn1
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 3600
crypto isakmp policy 100
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 43200
vpn-addr-assign local reuse-delay 5
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 60
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.254 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DfltGrpPolicy attributes
vpn-filter value 101
username user1 password iqm/O64OATR4zXx7 encrypted
tunnel-group MainSiteIP type ipsec-l2l
tunnel-group MainSiteIP ipsec-attributes
pre-shared-key *****
tunnel-group RAGroup type remote-access
tunnel-group RAGroup general-attributes
address-pool RAPool
tunnel-group RAGroup ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:07120668869a94278df931162ae4d7a5
: end
Solved! Go to Solution.
06-04-2012 03:38 PM
Hello Robert,
ip local pool RAPool 192.168.251.100-192.168.251.120
access-list No_NAT_RA permit ip 192.168.1.0 255.255.255.0 192.168.251.0 255.255.255.0
no nat (inside) 0 access-list 103
nat (inside) 0 access-list No_NAT_RA
group-policy DfltGrpPolicy attributes
no vpn-filter value 101
access-list Split standard permit 192.168.1.0 255.255.255.0
group-policy R_A internal
group-lock value RAGroup
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split
Regards,
Julio
06-04-2012 03:38 PM
Hello Robert,
ip local pool RAPool 192.168.251.100-192.168.251.120
access-list No_NAT_RA permit ip 192.168.1.0 255.255.255.0 192.168.251.0 255.255.255.0
no nat (inside) 0 access-list 103
nat (inside) 0 access-list No_NAT_RA
group-policy DfltGrpPolicy attributes
no vpn-filter value 101
access-list Split standard permit 192.168.1.0 255.255.255.0
group-policy R_A internal
group-lock value RAGroup
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split
Regards,
Julio
06-05-2012 12:18 PM
Fantastic! Thank you for your help - everything is now working.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide