cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
420
Views
0
Helpful
1
Replies

Changing from PPTP to L2TP : IOS

HI,

I'm trying to setup a client L2TP connecting onto a Cisco 881 router. The router already has PPTP setup which works fine as below:

hostname Router

!

!

ip cef

no ipv6 cef

!

!

vpdn enable

!

vpdn-group 1

! Default PPTP VPDN group

accept-dialin

  protocol pptp

  virtual-template 1

!

!

!

username andrew password 0 andrew123

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface FastEthernet4.4094

encapsulation dot1Q 4094

ip address 8.8.8.8 255.255.255.252

ip nat outside

ip virtual-reassembly in

!

interface Virtual-Template1

ip address 192.168.50.1 255.255.255.0

peer default ip address pool L2TP-Pool

no keepalive

ppp encrypt mppe 128

ppp authentication ms-chap ms-chap-v2 pap

!

interface Vlan1

ip address 10.0.0.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

ip local pool L2TP-Pool 192.168.50.10 192.168.50.20

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip nat inside source list NAT interface FastEthernet4.4094 overload

ip route 0.0.0.0 0.0.0.0 8.8.8.7

!

ip access-list extended NAT

permit ip 10.0.0.0 0.0.0.255 any

I've tried to change the protocol to L2TP and changed the Windows setup to this also but it won't connect. Do I have to add anything extra to change this client VPN to L2TP?

Thanks


Andrew

1 Reply 1

Is it only possible when setting up with a Pseudowire confuguration?

I only need the client VPN to get access to local resources connect to the same router so hopefully Pseudowire isn't needed.

thanks