cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
22731
Views
0
Helpful
17
Replies

Cisco AnyConnect requires Reboot to connect second time

richards
Beginner
Beginner

On my Windows 10 computer, I can connect to the VPN using AnyConnect 3.1.02026 without difficulty. However, once I disconnect, I need to reboot my computer to connect again. When I try to connect the second (and subsequent) times I get the message,

"The VPN client driver has encountered an error. Please restart your computer or device, then try again."

followed by the message:

"AnyConnect was not able to establish a connection to the specified secure gateway. Please try connecting again."

If I reboot the computer, AnyConnect will connect (once).

17 Replies 17

Aditya Ganjoo
Cisco Employee
Cisco Employee

Hi Rich,

Is it happening on a single Win 10 machine or multiple machines ?

Please share the DART file of the affected PC.

Also could you test it with a newer Anyconnect client ?

You can also check the following workaround:

http://www.cisco.com/c/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/100597-technote-anyconnect-00.html#anc37

Regards,

Aditya

Please rate helpful posts and mark correct answers.

It is happening on both of the Windows 10 computers I have tried it on.

I am using a client's version of AnyConnect, so I can't download a new version of AnyConnect or DART.

I already tried allowing the service to interact with the desktop, but it did not help. 

This sounds exactly like what we are experiencing.  

Windows 10 Anniversary Update 64bit 

Anyconnect 3.105152

It will connect once consistently, but ALWAYS requires a reboot to connect a second time.  

I verified it's not the same as http://www.cisco.com/c/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/100597-technote-anyconnect-00.html#anc37

The 'Interact with Desktop' is checked, and RRAS is not enabled.   

adganjoo  

I have a DART Bundle if you'd like to have a look at it. Please message me if you have the time to analyze and I will email it directly. I don't want to post it in public forum as it has customer data within it.

Hi Marvin,

Sure thing. Please send it to me and I will go through it.

Regards,

Aditya

Aditya,

I don't have access to an updated client or any of the other tools Cisco provides their customers. If you can get them for me, I am happy to send you any results or logs that would help you diagnose the problem.

[@mrhoads-cco]  Please share the DART bundle.

Regards,

Aditya

Hi,

I have an issues with Cisco AnyConnect VPN. When users wants to connect to the VPN, it's connected but, they don't have access to the internal network, but when I reboot (reload) our ASA, then user can connect to the vpn and they have access to internal network. It's happens sometimes for different user. I don't know what is the issues, could you please help me.

We have ASA 5505 and we are using Cisco AnyConnect (Split tunneling) to access to the internal network.

Thanks

Marvin Rhoads
VIP Community Legend VIP Community Legend
VIP Community Legend

I too have been seeing this lately on AnyConnect 4.2.02075 (and still with the latest 4.2.03013). I haven't had time to open a TAC case on it yet.

I did find through trial and error that a total reboot was not required - simply a Windows logoff / logon does the trick for me.

I did try unsuccessfully to stop and start the VPN client and UI services from Windows' Process manager. I also found and applied the "interact with desktop" workaround. No joy.

I will try the logoff - still a pain in the neck.

I also restarted the "Cisco AnyConnect Secure Mobility Agent" windows service, but to no avail.

This seems like a pretty big bug. I am surprised it made it through testing.

Marvin Rhoads
VIP Community Legend VIP Community Legend
VIP Community Legend

[@richards@tenpenn.com]  

Do you perchance have AnyConnect NAM also installed? I dug through my DART log and saw some indicators of it being a potential issue. I turned off NAM and the VPN started working after it was failing earlier. It looks like some NAM-related bug as I can reproduce the issue simply by disabling and re-enabling NAM.

It also may be related to that plus the one VPN that seems to be causing the issue is an ASA running old 8.2(5) code.

I don't have the NAM installed. My clients just gave me a copy of AnyConnect Secure Mobility Client. I tried the logoff to reconnect, but no luck. As of now, I still need to reboot every time I connect.

Shakti Kumar
Cisco Employee
Cisco Employee

Hi 

The supported version of Any connect for windows 10 are

AnyConnect 4.1.04011 and 3.1.10010

Can you try installing the recommended version and see if it resolves the issue ??

Thanks

Shakti

I hate to bump a 10 month old thread, but I'm still having this issue as well. Windows 10 Professional build 14986

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers