cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
29098
Views
20
Helpful
5
Replies

Cisco AnyConnect Secure Mobility Client Failed to initialize connection subsystem after Windows Updates (Feb. 10. 2015)

prochazkam
Beginner
Beginner

Hello

The Cisco Anyconnect Secure Mobiliy Client is giving me an error when I try to use it. It started after the latest Windows Updates (Feb. 10. 2015).

The error it causes is 'Failed to initialize connection subsystem'.

I looked at another machine with the installed updates with the same issue.

On my machine - I reverted to the restore point before the windows updates where done, and the Cisco Anyconnect Client worked fine.

After installing the updates, it stopped working again.

Please help

 

Michael

 

 

 

1 Accepted Solution

Accepted Solutions

charlessullivan3
Beginner
Beginner

I assume you are using Windows 8.1. The workaround is to set the AnyConnect Client to use Windows 8 Compatibility Mode. This has worked on multiple machines. After the change, you'll need to log off and back on to Windows.

Cumulative IE 11 Update KB3021952 includes KB3023607.  Apparently, it is the latter patch that causes the problem, according to what I've been told. (I don't even see 3023607 in the WU History, but if I type "wmic qfe" it's there.) However, I would suggest leaving the update in place and using the workaround.

View solution in original post

5 Replies 5

charlessullivan3
Beginner
Beginner

I assume you are using Windows 8.1. The workaround is to set the AnyConnect Client to use Windows 8 Compatibility Mode. This has worked on multiple machines. After the change, you'll need to log off and back on to Windows.

Cumulative IE 11 Update KB3021952 includes KB3023607.  Apparently, it is the latter patch that causes the problem, according to what I've been told. (I don't even see 3023607 in the WU History, but if I type "wmic qfe" it's there.) However, I would suggest leaving the update in place and using the workaround.

Thank you.

The workaround works. Yes, using Windows 8.1.

An HOW TO on how to set this for everyone who is not that computer savvy...

1. Go to the Start Screen of Windows 8.1 and look for the Cisco Anyconnect Secure Mobility Client icon (or just type it on the Start Screen).

2. Right click the icon and select 'Open file location'.

3. Right click the Cisco Anyconnect Secure Mobility Client (Shortcut) and select 'Properties'

4. Select the 'Compatibility' Tab.

5. Check the box 'Run this program in compatibility mode for:' and select 'Windows 8' in the drop down.

6. Click 'OK' to close the window.

7. Log off and log on again (or reboot the computer).

 

Note to point 5. If there are multiple users are using the PC with different user accounts and they're using the Cisco Secure Mobility Client as well, then go to 'Change settings for all users' and there apply point 5. To do so you'll need administrative rights to the computer though.

 

Hi  do you know if a fix will be released or is the workaround the long term fix.

Microsoft released a fix-it patch that takes care of the problem.

https://support.microsoft.com/kb/3023607

crua00001
Beginner
Beginner

This works if you're logged into the desktop, but it does not work if you're using the Start Before Logon feature. I have tried changing the compatibility mode for both vpnui and vpnagent and neither works with the Start Before Logon feature. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers