cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1034
Views
0
Helpful
2
Replies

Configure Cisco AS2509-RJ as callback server

ciscochef
Level 1
Level 1

I'm fairly new to the Cisco world, and my latest project is to increase security on the network. It was identified that our Access Server should dial-back / callback users when they try to access the network from outside. I've gotten alot of information on how to configure callback clients, and some on configuring callback servers. However, i need a little guidance with respect to this task at hand.

Is there anyone that can give me the configuration adjustments to be made to get myCisco AS2509-RJ Access Server to call back clients?

Please find attached the current config.

RAS#sh conf

Using 2216 out of 32762 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname RAS

!

aaa new-model

aaa authentication login default local

aaa authentication ppp default local

enable secret xxxx

enable password *******

!

username s**** password 0 s****

ip subnet-zero

ip domain-name ciscochef.com

ip name-server 172.20.21.**

ip address-pool local

!

!

!

interface Ethernet0

ip address 172.20.**.250 255.255.255.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface Serial0

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Group-Async1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

async mode interactive

peer default ip address pool default

ppp authentication chap

group-range 1 8

!

router rip

network 172.20.0.0

!

ip local pool default 172.20.21.242 172.20.21.249

ip default-gateway 172.20.21.254

ip classless

!

!

line con 0

transport input none

line 1

autoselect ppp

modem InOut

modem autoconfigure type usr_sportster

transport input all

speed 115200

flowcontrol hardware

line 2 8

autoselect ppp

modem InOut

modem autoconfigure discovery

transport input all

speed 115200

flowcontrol hardware

line aux 0

transport input all

line vty 0 4

!

End

2 Replies 2

mchin345
Level 6
Level 6

Finally! A response! Thanks mchin!

I actually got that page before, it did help alot. Here's the config I came up with, will this work?

If not, can u show me where i went wrong. Thanks in advance to anyone who can help with this.

RAS#sh conf

Using 2216 out of 32762 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname RAS

!

aaa new-model

aaa authentication login default local

aaa authentication ppp default local

enable secret xxxx

enable password remoteacc

!

username smith callback-dialstring 6481000 password 0 smithy.1

username admin callback-dialstring 6481001 password 0 password

ip subnet-zero

ip domain-name ciscochef.com

ip name-server 172.20.19.20

ip address-pool local

!

!

!

interface Ethernet0

ip address 172.20.19.250 255.255.255.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface Serial0

no ip address

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

shutdown

!

interface Group-Async1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

async mode interactive

peer default ip address pool default

ppp authentication chap

dialer callback-secure

dialer map ip 172.20.21.201 name smith class diall

dialer map ip 172.20.21.202 name admin class diall

ppp callback accept

group-range 1 8

!

map-class dialer diall

dialer callback-server username

!

router rip

network 172.20.0.0

!

ip local pool default 172.20.20.200 172.20.209.220

ip default-gateway 172.20.20.254

ip classless

!

!

line con 0

transport input none

line 1

autoselect ppp

modem InOut

modem autoconfigure type usr_sportster

transport input all

speed 115200

flowcontrol hardware

line 2 8

autoselect ppp

modem InOut

modem autoconfigure discovery

transport input all

speed 115200

flowcontrol hardware

line aux 0

transport input all

line vty 0 4

!

End