Showing results for 
Search instead for 
Did you mean: 

Failed to initialize connection subsystem

Level 1
Level 1

I’m having trouble with AnyConnect Secure Mobility Client 3.0. When trying to connect to a VPN I have connected to before, I’m getting an error message of “Failed to initialize connection subsystem.” This message does not appear in the list of user messages for either release and it is happening at random and with increasing frequency. Reinstalling the client will clear the error sometimes, but after the most recent occurrence, reinstalling came up with the exact same error. This is becoming a major hassle to deal with, and if anyone has an idea of how to deal with it, I would be most appreciative.

15 Replies 15

Level 1
Level 1

Hi Stephen

I have just had the same problem.

I am running AnyConnect version 3.0.5080 on Windows XP SP3 how about you?

I have reinstalled and that has not helped.

I have many errors in windows event viewer including:



It's running on Windows 7 SP1. Haven't checked the event logs, but DART didn't seem to find anything noteworthy. Interestingly enough, I've been able to fix the problem once by deleting the AnyConnect folder under C:\Users\\AppData\Local\Cisco. Problem came back two days later and that one was resolved by deleting the folder and taking Internet Explorer out of offline mode. If (when, most likely) it starts erroring again, I'll be sure to grab the event logs and see what they're saying.

The really odd part is that it's only affecting the one person signing into the system, anyone else who signs in can use the VPN client no problem.

Got some new information on this issue. Looks like AnyConnect checks Internet Explorer's Work Offline setting and if IE is set to Work Offline, then AnyConnect will throw that connection subsystem error. Apparently it's a bug that Cisco's releasing a notice about this at some point today, I'll put a link in this thread once it goes live and I can find it.

Thanks! This offline mode fixed my issue.

Me too - turning off IE / Offline mode worked a treat.  Use Chrome so didn't see that.   thanks!

Perfect solution, in Win7 SP1 - just had to get IE into online mode and voila.

Thank you!

Level 1
Level 1

Running Cisco AnyConnect Secure Mobility Client Version 3.1.06073 on Windows 8.

  1. Find the program shortcut
  2. Right click it and select Properties
  3. Switch to the "Compatibility Tab" and click "Run compatibility troubleshooter" and let it run
  4. Click "Test the program..."
  5. This did the trick for me. I can now connect.
  6. Get back to the troubleshooter window to save the settings for this program for future runs

Thanks antondaneyko! I've been hitting this problem for days now and I had no idea what the issue was, since I've connected successfully a few times before. Running the compatibility troubleshooter solved it.


Also, coincidentally or not, my company officially supports VPN from Windows 7 but not Windows 8.


I am running AnyConnect Secure Mobility Client 3.1.01065 (which is the version my employer set me up with)

Strange that this is coming back up today. 

Same problem here, version 3.1.05187 for the VPN client, Windows 8.1 x64 otherwise. 

However the 'compatibility trick' did not work for me. 

Neither works in Windows 8 or Windows XP compatibility mode. Same error. 

Wonder whether there was a recent update (Windows I assume) that introduced this issue. 

I too have this same problem.

Can any one have a solution to it.

No luck with the compatibility trick (also not sure why I would want to set this in a different compatibility mode if the program has been running fine for months). My operating system is Windows 8.1 and Cisco client 3.1.05187. I can't tell when this problem first occurred because I don't use VPN often, but I just needed it today and ran into the same  “Failed to initialize connection subsystem” message for my company VPN. I second the sentiment of "r.oberhofer" in that there may be a recent development that causes this issue. I ran into this posting when looking up the error message and all of a sudden there seems to be activity on this topic after apparently 3 years of silence...

Here is the fix: run Microsoft Fix it 51033 to install AppCompat shim per KB 3023607. Thanks to a lead from which contains further useful information, go pick up the details and the Fix it software at


Prior to installing this fix, I want to note that I received the error “Failed to initialize connection subsystem” only under my regular user logon, which does not have administrative permissions. I had no problems connecting to VPN under a privileged account with administrative rights.


Note also that after installing the Microsoft Fix it, I had to restart my computer in order for the change to take effect. All is now well again in VPN land!

This solution worked perfectly for me.  Thanks g Paq!

This solution worked for me too. Thank you.