cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
534
Views
0
Helpful
2
Replies

GRE over DSL with OSPF in an MPLS network

Hi guys,

we run 2 GRE tunnels in our network. The A end is a PE router while the B end are 2 different CPE DSL sites.

Both tunnels at the A end (PE) are using as a source a gig sub inteface which is in the same VRF

interface Tunnel40 (for branch office 1)

ip vrf forwarding example

ip address x.x.x.250 255.255.255.252

ip mtu 1476

ip tcp adjust-mss 1420

ip ospf dead-interval 60

ip ospf mtu-ignore

keepalive 10 6

tunnel source Gig x/x.z

tunnel destination x.x.x.x.

tunnel vrf example

interface Tunnel60 (for branch office 2)

the frame is as above

router ospf 1 vrf example

log-adjacency-changes

capability vrf-lite

.

.

passive-interface default

no passive-interface Tunnel40

no passive-interface Tunnel60

network x.x.x.250 0.0.0.0 area x.x.x.x

.network ......

.

CPE example

----------------

interface Tunnel1

ip address x.x.x.249 255.255.255.252

ip flow ingress

ip flow egress

ip ospf dead-interval 60

ip ospf mtu-ignore

keepalive 10 6

tunnel source Dialer1

tunnel destination z.z.z.1 ( this is the subinterafce Gig x/x.z on the PE router)

router ospf 1

router-id x.x.x.x

log-adjacency-changes

passive-interface default

no passive-interface Tunnel1

no passive-interface Vlan1

network x.x.x.x 0.0.0.0 area x.x.x.x

network x.x.x.249 0.0.0.0 area x.x.x.x

same is the config for CPE 2 ( just the frame of the commands no the ospf areas , IP s etc)

The problem is that when the tunnel fails for cpe 1 then it fails for CPE 2 exactly the same time.

Any advice.

Thanks

Everyone's tags (6)
2 REPLIES 2
Highlighted
Cisco Employee

GRE over DSL with OSPF in an MPLS network

Out of curiosity, does the problem persist if you use "tunnel key" to separate the two tunnels?

M.

Highlighted

GRE over DSL with OSPF in an MPLS network

Hi my friend,

I didnt know about that command and the purpose you use that  but I was searching a bit. Do you use that command for

normal GRE tunnels?  This is not a point to multipoint topology and every tunnel is a point to point and I run ospf for the point to point link is is differnet area than the other tunnel. Do you beleive that its still could be related to the tunnel key?

Many thanks fo ryour advice. Please reply at your erliest convenience

I know it looks like hub and spoke or point to miltipoint but does it actually dehave like that?

Thank,

Spyros