11-18-2014 07:39 AM - edited 02-21-2020 07:56 PM
Hello,
I am actually trying to build a VTI tunnel. This case is a little particular ; as on the remote side i have router which is using a private ip address instead of a public (like i do habitually)
Router# sh crypto ipsec sa
interface: Tunnel0
Crypto map tag: Tunnel0-head-0, local addr 10.253.210.1
protected vrf: (none)
local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
remote ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
current_peer 109.7.93.184 port 500
PERMIT, flags={origin_is_acl,}
#pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
#pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. failed: 0
#pkts not decompressed: 0, #pkts decompress failed: 0
#send errors 0, #recv errors 0
local crypto endpt.: 10.253.210.1, remote crypto endpt.: x.x.x.x
path mtu 1500, ip mtu 1500, ip mtu idb GigabitEthernet0/0
current outbound spi: 0x0(0)
PFS (Y/N): N, DH group: none
inbound esp sas:
inbound ah sas:
inbound pcp sas:
outbound esp sas:
outbound ah sas:
outbound pcp sas:
Here are the keys elements of my configuration :
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key mykey address x.x.x.x
crypto ipsec transform-set 3DES-MD5 esp-3des esp-md5-hmac
mode tunnel
crypto ipsec profile VTI
set transform-set 3DES-MD5
interface Tunnel0
description tunnel
bandwidth 100
ip address 10.253.110.1 255.255.255.0
ip tcp adjust-mss 1300
load-interval 30
qos pre-classify
keepalive 5 3
tunnel source GigabitEthernet0/0
tunnel mode ipsec ipv4
tunnel destination x.x.x.x
tunnel protection ipsec profile VTI
interface GigabitEthernet0/0
description WAN
ip address 10.253.210.1 255.255.255.0
load-interval 30
duplex auto
speed auto
ip route x.x.x.x 255.255.255.255 10.253.210.254
How can i troubleshoot the problem ?
Thanks for your help
11-18-2014 09:44 PM
Both the remote and hub router will detect existence of NAT device in between, which caused the both routers switching over from UDP port 500 to UDP port 4500 to exchange IKE message. I can suspect there is no switch over taking place from you log(both using UDP 500), So I suggest you validate if both routers support NAT-T feature by checking if they are listening on UDP port 4500?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide