cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
245
Views
0
Helpful
1
Replies

Issues passing traffic from ASA5510 to Juniper SSG5

simplifyit.alex
Level 1
Level 1

Got a simple test environment set up between 2 locations and completely stumped with a Cisco issue. I will preface this by saying that it has been a while since I configured a Cisco VPN, especially with an ASA. Cisco config is posted below. I am able to pass traffic from the ASA to the Juniper, so traffic is OK from 192.168.56.0 to 10.227.0.0. I am having an issue getting anything, even a ping to go in the other direction. I imagine it is something really simple I am overlooking.

name 192.168.156.0 Pundo-LAN

name 10.227.0.0 Test-LAN

name 10.227.5.18 Test-LAN-SERVER

name 192.168.56.21 inside-LAN-SERVER

!

interface Ethernet0/0

nameif outside

security-level 0

ip address x.x.x.x y.y.y.y

!

interface Ethernet0/1

nameif inside

security-level 100

ip address 192.168.56.1 255.255.255.0

!

interface Ethernet0/2

description Backup Server

nameif hosting_1

security-level 100

ip address 10.228.2.1 255.255.0.0

!

interface Ethernet0/3

nameif hosting_2

security-level 100

ip address 192.168.253.1 255.255.255.0

!

interface Management0/0

nameif management

security-level 100

ip address 99.99.99.99 255.255.255.0

!

ftp mode passive

dns domain-lookup outside

dns server-group DefaultDNS

name-server 8.8.8.8

name-server 4.2.2.2

object-group protocol DM_INLINE_PROTOCOL_1

protocol-object ip

protocol-object icmp

protocol-object tcp

access-list outside_cryptomap extended permit ip 192.168.56.0 255.255.255.0 Test-LAN 255.255.0.0

access-list test-LAN-inbound extended permit object-group DM_INLINE_PROTOCOL_1 Test-LAN 255.255.0.0 192.168.56.0 255.255.255.0

access-list capture extended permit ip Test-LAN 255.255.0.0 192.168.56.0 255.255.255.0

access-list test-LAN extended permit ip 192.168.56.0 255.255.255.0 Test-LAN 255.255.0.0

access-list test-LAN-nonat extended permit ip 192.168.56.0 255.255.255.0 Test-LAN 255.255.0.0

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

mtu hosting_1 1500

mtu hosting_2 1500

mtu management 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

nat-control

global (outside) 1 interface

nat (inside) 0 access-list test-LAN-nonat

nat (inside) 1 192.168.56.0 255.255.255.0

nat (hosting_1) 1 10.228.0.0 255.255.0.0

nat (hosting_2) 1 192.168.253.0 255.255.255.0

route outside 0.0.0.0 0.0.0.0 z.z.z.z

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 0.0.0.0 0.0.0.0 inside

http 0.0.0.0 0.0.0.0 management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map test.local 1 match address outside_cryptomap

crypto dynamic-map test.local 1 set pfs

crypto dynamic-map test.local 1 set transform-set ESP-3DES-SHA

crypto map outside_map1 1 ipsec-isakmp dynamic test.local

crypto map outside_map1 interface outside

crypto isakmp enable outside

crypto isakmp policy 5

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 28800

telnet timeout 5

ssh timeout 5

console timeout 0

dhcp-client client-id interface outside

dhcpd dns 8.8.8.8 4.2.2.2

dhcpd lease 36000

!

dhcpd address 192.168.56.100-192.168.56.150 inside

dhcpd enable inside

!

dhcpd address 10.228.2.100-10.228.2.150 hosting_1

dhcpd enable hosting_1

!

dhcpd address 192.168.253.100-192.168.253.150 hosting_2

dhcpd dns 8.8.8.8 4.2.2.2 interface hosting_2

dhcpd lease 36000 interface hosting_2

dhcpd enable hosting_2

!

dhcpd address 99.99.99.100-99.99.99.105 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

username **** password ********************* encrypted privilege 15

tunnel-group DefaultL2LGroup ipsec-attributes

pre-shared-key *****

tunnel-group test.local type ipsec-l2l

tunnel-group test.local ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum client auto

message-length maximum 512

policy-map global_policy

class inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

inspect ip-options

inspect icmp

!

1 Reply 1

ndhingr3
Level 1
Level 1

Hi,

Looking at the configuration, everything seems correct. Please verify few things in order to troubleshoot the issue:

1) You mentioned that one side traffic from ASA to Juniper is working, however reverse is not flowing. This mostly occurs due to incorrect NAT exemption rules. Verify the NAT exemption rules on Juniper side.

2) Initiate traffic from Juniper end and check the output of show crypto ipsec sa. Check if you see any decrypts increasing on this end.

3) If you see the decrypts, capture the packets on the inside interface of the ASA for specific host entries:

capture MYCAP interface INSIDE match icmp host <Source IP Address> host <Destination IP Address>

show capture MYCAP