cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
877
Views
0
Helpful
3
Replies

NAT with a block of 4 IP's

doreskicisco1
Level 1
Level 1

Hi Guys,

I have come across a few discussion regarding this, however, I have not been able to suss out how to do this given my configuration.

I have a static public IP which connects via PPP on my HWIC (setup as dialier1 in my config) to my ISP. 

interface Dialer1

description Internet Link

ip address 203.xx.xx.xx 255.xx.xx.xx.xx

ip flow ingress

ip nat outside

ip virtual-reassembly in

encapsulation ppp

load-interval 30

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp chap hostname *********

ppp chap password ***************

ppp pap sent-username ************* password ***********

ppp ipcp dns request

no cdp enable

This is currently how to connect to the internet and it works well. However, I now want to setup a few things, FTP server, media sever etc and I have another 4 public IP's allocated to me.

What I dont want to to do is open ports ie 3389, 20 and 21 etc via my dialer1 public IP. See below: (I know this works as I tested it)

ip nat inside source static tcp 192.168.2.4 21 interface Dialer1 20

ip nat inside source static tcp 192.168.2.4 20 interface Dialer1 21

ip nat inside source static tcp 192.168.2.4 3389 interface Dialer1 3389

What I would like to do is use my 4 public IP's and have them NAT inside to my 4 different devices. See below

203.xx.xx.01 to NAT to 192.xx.xx.01

203.xx.xx.02 to NAT to 192.xx.xx.02

203.xx.xx.03 to NAT to 192.xx.xx.03

203.xx.xx.04 to NAT to 192.xx.xx.04

I am sure how to do this. If someone can give me a heads up as to how to allocate the 4 public IPs to my internal devices, connected with a static IP to a dialer1 (HWIC), it would be really really apprecaited!!.

Regards,

Dennis.

1 Accepted Solution

Accepted Solutions

Jennifer Halim
Cisco Employee
Cisco Employee

This is how you would configure it:

ip nat inside source static 192.xx.xx.1 203.xx.xx.1

ip nat inside source static 192.xx.xx.2 203.xx.xx.2

ip nat inside source static 192.xx.xx.3 203.xx.xx.3

ip nat inside source static 192.xx.xx.4 203.xx.xx.4

Please ensure that those public ip addresses are routed towards Dialer1 interface IP.

View solution in original post

3 Replies 3

Jennifer Halim
Cisco Employee
Cisco Employee

This is how you would configure it:

ip nat inside source static 192.xx.xx.1 203.xx.xx.1

ip nat inside source static 192.xx.xx.2 203.xx.xx.2

ip nat inside source static 192.xx.xx.3 203.xx.xx.3

ip nat inside source static 192.xx.xx.4 203.xx.xx.4

Please ensure that those public ip addresses are routed towards Dialer1 interface IP.

Hi Jennifer,

I thought that would be the case, however, my question is, since the dialer1 already has a public IP, how do you route the other public IP's to it?

Jennifer,

I think I may have figured it out.

Will do some testing and confirm.

Thank you for your help.