cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2748
Views
0
Helpful
6
Replies
Highlighted
Beginner

PPPoE PADR resending

Hi,

i've configured a Cisco 2800 Series with an WIC-1ADSL with the normal parameters for the PPPoE connection. The ATM is up but i can't get the PPPoE session to start.

I do debug pppoe events and it appears the following message after the first PADR is sent: ressending PADR

My ISP tells me that the problem is on the configuration but i can't tell where.

can someone help me?

6 REPLIES 6
Highlighted
Beginner

Re: PPPoE PADR resending

The configuration is this:

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

enable password xxxxxx

!

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

no fair-queue

!

interface ATM0/0.1 point-to-point

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface ATM0/1

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp pap sent-username ********* password xxxxx

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

!

access-list 1 permit any

dialer-list 1 protocol ip permit

!

call rsvp-sync

!

!

line con 0

line aux 0

line vty 0 4

password xxxxxx

login

!

!

end

i debug vpdn pppoe-events

show:

Sending PADI: vc=0/35

01:18:15: pppoe_send_padi failed

01:18:15: padi timer expired

01:18:17: Sending PADI: vc=0/35

01:18:17: pppoe_send_padi failed

01:18:17: padi timer expired

01:18:19: Sending PADI: vc=0/35

01:18:19: pppoe_send_padi failed

01:18:19: padi timer expired

01:18:20: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated.

01:18:21: Sending PADI: vc=0/35

01:18:21: padi timer expired

01:18:21: PPPoE 0: I PADO L:0000.0000.0000 R:00e0.fc15.cad7 0/35 AT0/0.1

01:18:21: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up

01:18:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up

01:18:23: PPPOE: we've got our pado and the pado timer went off

01:18:23: OUT PADR from PPPoE tunnel

01:18:33: OUT PADR from PPPoE tunnel

01:18:33: PPPOE : Resending PADR

01:18:43: OUT PADR from PPPoE tunnel

01:18:43: PPPOE : Resending PADR

01:18:53: OUT PADR from PPPoE tunnel

01:18:53: PPPOE : Resending PADR

01:19:03: OUT PADR from PPPoE tunnel

01:19:03: PPPOE : Resending PADR

01:19:13: OUT PADR from PPPoE tunnel

01:19:13: PPPOE : Resending PADR

01:19:23: PPPoE : Shutting down client session

01:19:23: PPPOE : Resending PADR

01:19:43: Sending PADI: vc=0/35

01:19:43: PPPoE 0: I PADO L:0000.0000.0000 R:00e0.fc15.cad7 0/35 AT0/0.1

01:19:45: PPPOE: we've got our pado and the pado timer went off

01:19:45: OUT PADR from PPPoE tunnel

01:19:49: PPPoE 3017: I PADT L:00b0.c28f.6b67 R:00e0.fc15.cad7 0/35 AT0/0.1

01:19:55: OUT PADR from PPPoE tunnel

01:19:55: PPPOE : Resending PADR

01:20:05: OUT PADR from PPPoE tunnel

01:20:05: PPPOE : Resending PADR

01:20:15: OUT PADR from PPPoE tunnel

01:20:15: PPPOE : Resending PADR

01:20:25: OUT PADR from PPPoE tunnel

01:20:25: PPPOE : Resending PADR

01:20:35: OUT PADR from PPPoE tunnel

01:20:35: PPPOE : Resending PADR

01:20:45: PPPoE : Shutting down client session

01:20:45: PPPOE : Resending PADRno deb all

i debug vpdn pppoe-packete

show :

01:22:39: OUT PADR from PPPoE tunnel

00 01 00 00 AA AA 03 00 80 C2 00 07 00 00 00 E0

FC 15 CA D7 00 00 00 00 00 00 88 63 11 19 00 00

00 19 01 01 00 00 01 03 00 04 82 DA 08 28 01 ...

01:22:49: OUT PADR from PPPoE tunnel

00 01 00 00 AA AA 03 00 80 C2 00 07 00 00 00 E0

FC 15 CA D7 00 00 00 00 00 00 88 63 11 19 00 00

00 19 01 01 00 00 01 03 00 04 82 DA 08 28 01 ...

01:22:59: OUT PADR from PPPoE tunnel

00 01 00 00 AA AA 03 00 80 C2 00 07 00 00 00 E0

FC 15 CA D7 00 00 00 00 00 00 88 63 11 19 00 00

00 19 01 01 00 00 01 03 00 04 82 DA 08 28 01 ...

can i solute my problem?

thanks

Cisco Employee

Re: PPPoE PADR resending

Once PADR sent from the router, ISP should respond with PADS. So it looks like PADS is not received. Talk to ISP regarding that. Here is the link which will help you to debug that

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080126dc0.shtml

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080093e67.shtml

Highlighted
Beginner

Re: PPPoE PADR resending

I forgot to mention that the connection works with an Cisco 837 (similar configuration) and with an Alcatel router.

Highlighted
Enthusiast

Re: PPPoE PADR resending

Its possible you maybe hitting this bug depending on your code.

CSCdw11368 - PPPoE client continues to resend PADR indefinitely

Daniel

Highlighted
Beginner

Re: PPPoE PADR resending

does it have a solution??

Highlighted
Enthusiast

Re: PPPoE PADR resending

Yes. It should be fixed in 12.3 code. And I also just noticed that its a 2800 series router. I don't even think there is 12.2 code for those.

The symptom of this bug was just that it would keep sending the PAD-R over and over again w/out going through the first steps Pad I and Pad O.

If you are seeing this type of behavior I would open a TAC case so they can verify if it is the same bug or a new one. Especially since you mentioned other devices have no problems connecting.

Daniel