cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2565
Views
0
Helpful
3
Replies

Problem Router 2811 connect with modem

RC8656137644
Level 1
Level 1

Hi,

I`m newbie in cisco routers and I need help.

I want connect Cisco Router 2811 with modem. I used AUX port.

I was checked modem connection via Windows XP, and there was working. Only initialization script was needed (AT+CGDCONT=1,"IP","internet") and call number is *99***1#.

Now, I configured router:

version 12.4
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname MSHDO
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Gg4B$Mf7Pb/DsT6Oxd4Uffiya80
enable password <XXX>
!
no aaa new-model
memory-size iomem 20
clock timezone GMT 1
clock summer-time GMT recurring last Sun Mar 2:00 last Sun Oct 2:00
!
!
ip cef
!
!
no ip domain lookup
multilink bundle-name authenticated
!
chat-script reset "" "at&w" OK
chat-script init "" "at" OK "at+ipr=38400" OK
chat-script dialer "" "at" OK "at+cgdcont=1,IP,internet" OK "ATD\T" TIMEOUT 45 CONNECT\c
modemcap entry twist:HFL=\Q3:TPL=default
x25 routing
!
!
username mshdo privilege 15 password 0 <xxx>
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex half
speed auto
no cdp enable
no mop enabled
!
interface FastEthernet0/1
no ip address
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/3/0
!
interface FastEthernet0/3/1
!
interface FastEthernet0/3/2
!
interface FastEthernet0/3/3
!
interface Vlan1
description $ES_LAN$
no ip address
!
interface Async1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string "*99***1#"
dialer-group 1
ppp chap hostname router
ppp chap password 0 router
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Async1 100
!
!
ip http server
ip nat inside source list 11 interface Async1 overload
!
access-list 11 permit 1.1.1.1
dialer-list 1 protocol ip permit
no cdp run
!
!
control-plane
!
!
line con 0
line aux 0
no exec-banner
script dialer dialer
script reset reset
modem InOut
modem autoconfigure type twist
no exec
transport input all
stopbits 1
flowcontrol hardware
line vty 0 4
password <xxx>
login
!
scheduler allocate 20000 1000
!
end

My question is, why I can`t connect to Internet. I tried ping, but unsuccessfull.

How can I see debug information? How can I find where is problem?

Here are some outputs:


MSHDO#show line
   Tty Line Typ     Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise Overruns  Int
*     0    0 CTY              -    -      -    -    -     0      0    0/0      -
*     1    1 AUX  38400/38400 - inout     -    -    -     0      0    0/0      -
    514  514 VTY              -    -      -    -    -     0      0    0/0      -
    515  515 VTY              -    -      -    -    -     0      0    0/0      -
    516  516 VTY              -    -      -    -    -     0      0    0/0      -
    517  517 VTY              -    -      -    -    -     0      0    0/0      -
    518  518 VTY              -    -      -    -    -     0      0    0/0      -

MSHDO#show async status
Async protocol statistics:
       Int           Local          Remote Qd     InPack     OutPac Inerr  Drops
  MTU
         1         0.0.0.0            None  0          0          0     0      0
1500

  Rcvd: 0 packets, 0 bytes
        0 format errors, 0 checksum errors, 0 overrun
  Sent: 0 packets, 0 bytes, 0 dropped

MSHDO#show caller
                                                          Active    Idle
  Line           User               Service       Time      Time
  con 0          -                  TTY           00:02:43  00:00:00
  aux 1          -                  Modem Autocon -         -

MSHDO#show dialer

As1 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (never), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Dial String      Successes   Failures    Last DNIS   Last status
*99***1#                 0          0    never                   -   Default

If you need more information, I can give you.

I thint that problem can be with script or configuring modem, but I dont know what to do with it.

Please help me, I realy dont know how to fix it.

PS: sorry for my bad english , I hope that you understant it.

Thank you

3 Replies 3

Phillip Remaker
Cisco Employee
Cisco Employee

Does this dial string (*99***1#) make a PPP connection to your provider?

"debug ppp negotiation" may be enlightening. as would "debug modem" and "debug dialer"

From a vty, be sure to set the "terminal monitor" command and "ternminal no monitor" to stop seeing the debugs (and "undebug all" to stop debugging)

Also, it never seens to attempt to dial.  That NAT commands will apply to transit traffic, not traffic sourced from the router.  The fact that the async interface has no IP address may be complicating matters.  What happens if you try to send traffic from the NAT-inside interface?

Thank you for reply and good advice.

Yes, this dial is correct.

Now, I change some things. I found out, that Orange Slovakia use pap authentication, so my Async interface looks like:

interface Async1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string "*99***1#"
dialer-group 1
async mode interactive
ppp authentication pap callin
ppp eap refuse
ppp chap refuse
ppp ms-chap refuse
ppp ms-chap-v2 refuse
ppp pap sent-username router password 0 router

I changed also this line:

access-list 11 permit 1.1.1.0 0.0.0.255

line aux looks like now:

line aux 0
no exec-banner
script dialer dialer
script reset reset
modem InOut
no exec
transport input all
stopbits 1
speed 38400
flowcontrol hardware

I tried this configuration with my modem, but I have problem with dialling.

When I put to telnet by hand part of chat script  at+cgdcont=1,IP,internet -> ERROR, but when I put at+cgdcont=1,"IP","internet" -> OK.

Do you know, how can I put this to chat script with quotes? Because it end on first quote, as end char.

I tried this configuration also with Siemens modem, and it works perfect. So maybe when I put quotes in chat script, it will work also with my modem.

Thanks

To send a literal double-quote, use \"

example:

chat-script dialer "" at OK at+cgdcont=1,\"IP\",\"internet\" OK ATD\T TIMEOUT 45 CONNECT \c

See http://www.cisco.com/en/US/docs/ios/dial/configuration/guide/dia_modem_chat_scpts_ps6350_TSD_Products_Configuration_Guide_Chapter.html

for more tips.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: