Showing results for 
Search instead for 
Did you mean: 

Problem with updating AnyConnect client SW through webdeploy package


We are using AnyConnect in conjunction with an ASA 5516 for the remote VPN users. When trying to update the client software via the corresponding webdeploy-package, the problem occurs that it does not work for some users. When the error occurs, the startup window remains after entering the password and user ID - but unfortunately the spinning circle remains permanently and the client can only be finished with the task-manager. No error message occurs.

What could be the problem?

Here is some more information about our configuration and performed tests:
- We are trying to update from anyconnect-win-4.10.0471-webdeploy-k9.pkg to anyconnect-win-4.10.05111-webdeploy-k9.pkg
- Windows10 21H2 (Build 19044.1706) is active on the computers.
- None of the users have no admin privileges
- Since we use anyconnect with the MFA authentication, I can see in the admin panel of DUO that the user has logged in correctly.
- When installing with user rights, it does not ask for higher rights - neither on the machines where it worked, nor on the ones where it did not work.
- As a test, the AnyConnect client was started with admin rights on one of the failing computers - then the update worked after logging in with the users credentials

Any ideas to find the source of the problems and the solution is very welcome


0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers