09-12-2012 12:04 PM
I currently have a site to site VPN running connecting a branch office and the Main office using a ASA 5510 and ASA 5505. currently PC's at the branch can access the network in the main office using interface 0/1, but we have added another ip range using interface 0/2 and I can't seem to route the traffic to both interfaces. I currently have 0/1 as inside 192.168.10.1 which works, and have added 0/2 as Inside2 192.168.20.1. I know I am forgetting something, could someone tell me the commands to route incoming VPN traffic so PC's at the branch office can connect to both IP ranges?
Darryl
09-12-2012 12:09 PM
Hi Darryl,
Just add the new IP range to the crypto ACL on both ASAs and make sure you have a NAT Exempt rule to allow these networks.
Let me know.
Portu.
Please rate any post you find helpful.
09-12-2012 12:53 PM
I am pretty sure I have done this, these are the commands I entered
on the 5510
access-list Inside_nat0_outbound line 1 extended permit ip 192.168.10.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list Inside_nat0_outbound line 1 extended permit ip 192.168.20.0 255.255.255.0 192.168.2.0 255.255.255.0
on the 5505
access-list cryptoacl_outside permit ip 192.168.2.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list cryptoacl_outside permit ip 192.168.2.0 255.255.255.0 192.168.20.0 255.255.255.0
Access-list nonat permit ip 192.168.2.0 255.255.255.0 192.168.10.0 255.255.255.0
Access-list nonat permit ip 192.168.2.0 255.255.255.0 192.168.20.0 255.255.255.0
NAt (inside) 0 access-list nonat
09-12-2012 12:58 PM
Darryl,
You mentioned a different / new interface, you must apply the specific NAT rule to the interface as well, not only to the inside.
NAt (inside) 0 access-list nonat
NAt (new_interface) 0 access-list nonat_new_interface
Keep me posted.
Portu.
09-12-2012 01:24 PM
Thank you for your time with this. The Access list nonat does not exist on the main ASA 5510 and the ASA 5505 (branch) does not use the new interface.
----0/1-----> 192.168.10.0 (inside) (currently works)
ASA 5505 (192.168.2.0) --------> ASA 5510 -----|
Branch Main ----0/2-----> 192.168.20.0 (inside2) (no connectivity)
09-12-2012 01:30 PM
On the ASA 5510, you should make the following changes:
no access-list Inside_nat0_outbound permit ip 192.168.20.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list inside2_nat0_outbound permit ip 192.168.20.0 255.255.255.0 192.168.2.0 255.255.255.0
nat (inside) 0 access-list Inside_nat0_outbound
nat (inside2) 0 access-list inside2_nat0_outbound
Keep me informed
Thanks.
09-12-2012 02:11 PM
No luck yet. But in the NAT rules I did see Dynamic rule set on Inside that was not on Inside2, I replicated it but I still can't get connectivity.
09-12-2012 02:13 PM
Could you please include the current configuration of the ASA?
Thanks.
09-12-2012 02:42 PM
Sure Thing.
hostname Bramptonvpn
domain-name default.domain.invalid
enable password e9Hkp8lgruadV9M0 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
nameif Outside
security-level 0
ip address 76.66.208.18 255.255.255.248
!
interface Ethernet0/1
nameif Inside
security-level 100
ip address 192.168.10.1 255.255.255.0
!
interface Ethernet0/2
nameif Terranet
security-level 100
ip address 192.168.20.5 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.9.1 255.255.255.0
management-only
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup management
dns domain-lookup Inside
dns domain-lookup Outside
dns server-group DefaultDNS
name-server 67.69.184.199
domain-name default.domain.invalid
same-security-traffic permit intra-interface
access-list Bellmodem_access_in extended permit ip XX.XX.XXX.XX 255.255.255.248 interface Inside
access-list outside_access_in extended permit tcp any host XX.XX.XXX.XX eq www
access-list Inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip any 192.168.10.0 255.255.255.0
access-list splittunnel standard permit 192.168.20.0 255.255.255.0
access-list splittunnel standard permit 192.168.10.0 255.255.255.0
access-list cryptoacl_outside extended permit ip 192.168.10.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list cryptoacl_outside extended permit ip 192.168.20.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list terranet_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list terranet_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list terranet_nat0_outbound extended permit ip any 192.168.20.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
logging from-address
logging recipient-address
level errors
mtu management 1500
mtu Inside 1500
mtu Outside 1500
mtu Terranet 1500
ip local pool Test 192.168.10.10-192.168.10.210 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
nat (management) 101 0.0.0.0 0.0.0.0
nat (Inside) 0 access-list Inside_nat0_outbound
nat (Inside) 1 0.0.0.0 0.0.0.0
nat (Terranet) 0 access-list terranet_nat0_outbound
nat (Terranet) 1 0.0.0.0 0.0.0.0
static (Inside,Outside) tcp interface www 192.168.10.10 www netmask 255.255.255.255
access-group outside_access_in in interface Outside
!
router eigrp 1
!
route Outside 0.0.0.0 0.0.0.0 XX.XX.XXX.XX 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 management
http 0.0.0.0 0.0.0.0 Inside
http 0.0.0.0 0.0.0.0 Terranet
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set reverse-route
crypto dynamic-map dynamic 10 set transform-set ESP-AES-256-SHA
crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map Outside_map interface Outside
crypto ca trustpoint _SmartCallHome_ServerCA
crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
6c2527b9 deb78458 c61f381e a4c4cb66
quit
crypto isakmp enable Inside
crypto isakmp enable Outside
crypto isakmp enable Terranet
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
vpn-addr-assign local reuse-delay 5
telnet 0.0.0.0 0.0.0.0 Inside
telnet 0.0.0.0 0.0.0.0 Terranet
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 Outside
ssh 0.0.0.0 0.0.0.0 Terranet
ssh timeout 5
console timeout 0
management-access Inside
dhcp-client client-id interface Inside
dhcpd dns 67.69.184.199 67.69.184.7
dhcpd auto_config management
!
dhcpd domain default.domain.invalid interface management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable Outside
svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
svc enable
tunnel-group-list enable
group-policy AnyConnect_profile internal
group-policy AnyConnect_profile attributes
wins-server none
dns-server value 67.69.184.199
vpn-tunnel-protocol svc
split-tunnel-policy tunnelspecified
split-tunnel-network-list value splittunnel
default-domain value terraprobe.ca
username Darryl password Het1kqm8MYQlIJvl encrypted privilege 15
username Darryl attributes
vpn-group-policy AnyConnect_profile
username user1 password tJsDL6po9m1UFs.h encrypted
username user1 attributes
vpn-group-policy DfltGrpPolicy
username cisco password 3USUcOPFUiMCO4Jk encrypted
tunnel-group DefaultL2LGroup ipsec-attributes
pre-shared-key *****
tunnel-group Terra-Tunnel type remote-access
tunnel-group Terra-Tunnel general-attributes
address-pool Test
tunnel-group Terra-Tunnel ipsec-attributes
pre-shared-key *****
tunnel-group SSL_Anyconnect type remote-access
tunnel-group SSL_Anyconnect general-attributes
address-pool Test
default-group-policy AnyConnect_profile
tunnel-group SSL_Anyconnect webvpn-attributes
group-alias Anyconnect enable
tunnel-group SSLVPN_profile type remote-access
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
call-home
contact-email-addr
profile CiscoTAC-1
destination address http
https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:39cfe8ce7816c4f5b5b8070cdc3bf32e
: end
no asdm history enable
09-12-2012 02:50 PM
Darryl,
Where are you initiating the tunnel from?
You can not initiate it from Bramptonvpn, since it has a dynamic crypto-map.
Are you initiating it from the remote side?
In addition, could you try to ping from the inside interface of the 5505 to the Terranet interface of the Main office?
* Make sure the "management-access nameif" command is configured for the correct interface.
Please attach the "show crypto ipsec sa peer main_ASA_IP" from the ASA 5505 as well.
Thanks
09-12-2012 03:11 PM
The first tunnel was initiated from the remote side, but I haven't had to initiate it it been like that since it was first set up. Do I need to initiate every time I make a change?
09-12-2012 03:17 PM
When you have a dynamic-to-static tunnel, in order to create a new SA, the traffic has to be initiated from the peer with the dynamic IP. Once this is done and the SA's are created on the Main office, then you would be able initiate the traffic from both directions.
Could you please test it and let me know?
Thanks.
09-13-2012 05:56 AM
Initiated the tunnel using this command.
packet-tracer input inside tcp 192.168.10.50 1250 192.168.20.100 80
Ping from 5505(inside) to the 5510(Terranet) interface failed to get a response, but to 5510(inside) succeeded
Result of the command: "show crypto ipsec sa peer XX.XX.XXX.XX"
peer address: XX.XX.XXX.XX
Crypto map tag: outsidemap, seq num: 10, local addr: XX.XX.XXX.XXX
access-list cryptoacl_outside extended permit ip 192.168.2.0 255.255.255.0 192.168.20.0 255.255.255.0
local ident (addr/mask/prot/port): (192.168.2.0/255.255.255.0/0/0)
remote ident (addr/mask/prot/port): (192.168.20.0/255.255.255.0/0/0)
current_peer: XX.XX.XXX.XX
#pkts encaps: 18, #pkts encrypt: 18, #pkts digest: 18
#pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 18, #pkts comp failed: 0, #pkts decomp failed: 0
#pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
#PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
#send errors: 0, #recv errors: 0
local crypto endpt.: XX.XX.XXX.XXX, remote crypto endpt.: XX.XX.XXX.XX
path mtu 1500, ipsec overhead 74, media mtu 1500
current outbound spi: E968E4FB
current inbound spi : 24AA17E5
inbound esp sas:
spi: 0x24AA17E5 (615127013)
transform: esp-aes-256 esp-sha-hmac no compression
in use settings ={L2L, Tunnel, PFS Group 1, }
slot: 0, conn_id: 106496, crypto-map: outsidemap
sa timing: remaining key lifetime (kB/sec): (3915000/27072)
IV size: 16 bytes
replay detection support: Y
Anti replay bitmap:
0x00000000 0x00000001
outbound esp sas:
spi: 0xE968E4FB (3915965691)
transform: esp-aes-256 esp-sha-hmac no compression
in use settings ={L2L, Tunnel, PFS Group 1, }
slot: 0, conn_id: 106496, crypto-map: outsidemap
sa timing: remaining key lifetime (kB/sec): (3914998/27072)
IV size: 16 bytes
replay detection support: Y
Anti replay bitmap:
0x00000000 0x00000001
Crypto map tag: outsidemap, seq num: 10, local addr: XX.XXX.XXX.XXX
access-list cryptoacl_outside extended permit ip 192.168.2.0 255.255.255.0 192.168.10.0 255.255.255.0
local ident (addr/mask/prot/port): (192.168.2.0/255.255.255.0/0/0)
remote ident (addr/mask/prot/port): (192.168.10.0/255.255.255.0/0/0)
current_peer: XX.XX.XXX.XX
#pkts encaps: 13, #pkts encrypt: 13, #pkts digest: 13
#pkts decaps: 8, #pkts decrypt: 8, #pkts verify: 8
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 13, #pkts comp failed: 0, #pkts decomp failed: 0
#pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
#PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
#send errors: 0, #recv errors: 0
local crypto endpt.: XX.XX.XXX.XXX, remote crypto endpt.: XX.XX.XXX.XX
path mtu 1500, ipsec overhead 74, media mtu 1500
current outbound spi: 786ADA19
current inbound spi : FCBC5984
inbound esp sas:
spi: 0xFCBC5984 (4240202116)
transform: esp-aes-256 esp-sha-hmac no compression
in use settings ={L2L, Tunnel, PFS Group 1, }
slot: 0, conn_id: 106496, crypto-map: outsidemap
sa timing: remaining key lifetime (kB/sec): (3914999/27348)
IV size: 16 bytes
replay detection support: Y
Anti replay bitmap:
0x00000000 0x000001FF
outbound esp sas:
spi: 0x786ADA19 (2020268569)
transform: esp-aes-256 esp-sha-hmac no compression
in use settings ={L2L, Tunnel, PFS Group 1, }
slot: 0, conn_id: 106496, crypto-map: outsidemap
sa timing: remaining key lifetime (kB/sec): (3914998/27348)
IV size: 16 bytes
replay detection support: Y
Anti replay bitmap:
0x00000000 0x00000001
09-13-2012 10:23 AM
Darryl,
"Ping from 5505(inside) to the 5510(Terranet) interface failed to get a response, but to 5510(inside) succeeded"
So from 5505(inside) to 5510(inside) it works fine?
From the output:
access-list cryptoacl_outside extended permit ip 192.168.2.0 255.255.255.0 192.168.20.0 255.255.255.0
local ident (addr/mask/prot/port): (192.168.2.0/255.255.255.0/0/0)
remote ident (addr/mask/prot/port): (192.168.20.0/255.255.255.0/0/0)
current_peer: XX.XX.XXX.XX
#pkts encaps: 18, #pkts encrypt: 18, #pkts digest: 18
#pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
It looks like the 5510 is not encrypting... Please answer the question above to clarify if there is a routing issue.
Thanks.
Portu.
Message was edited by: Javier Portuguez
09-13-2012 11:04 AM
That is correct, the 5505(inside and ping the 5510(inside), if it helps I have added all ping tests I have tried.
Ping from 192.168.2.0 to 192.168.10.50 succeeded
Ping from 192.168.2.0 to 192.168.20.100 failed
Ping from 192.168.10.0 to 192.168.2.66 succeeded
Ping from 192.168.10.0 to 192.168.20.100 failed
Ping from 192.168.20.0 to 192.168.10.50 failed
Ping from 192.168.20.0 to 192.168.2.66 failed
Thanks again
Darryl
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide