cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12018
Views
10
Helpful
1
Replies

What version of AnyConnect is needed to support TLS v1.2

Michael Murray
Explorer
Explorer

I need to support TLS v1.2 to pass PCI compliance. Can anyone confirm what version of AnyConnect is needed? I can't tell if 3.x will support it or if I need to go to 4.x.

 

Thanks,

-mike

1 Accepted Solution

Accepted Solutions

Marvin Rhoads
Hall of Fame
Hall of Fame

It requires AnyConnect 4.0.00048 or later with ASA 9.3(2) or later.

Reference.

Quote from the above referenced release notes for AnyConnect 4.0:

AnyConnect now supports TLS version 1.2 with the following additional cipher suites:

  • DHE-RSA-AES256-SHA256

  • DHE-RSA-AES128-SHA256

  • AES256-SHA256

  • AES128-SHA256


Note
 

AnyConnect TLS 1.2 requires a secure gateway that also supports TLS 1.2. This is available in release 9.3(2) of the ASA on 5500-X models.

View solution in original post

1 Reply 1

Marvin Rhoads
Hall of Fame
Hall of Fame

It requires AnyConnect 4.0.00048 or later with ASA 9.3(2) or later.

Reference.

Quote from the above referenced release notes for AnyConnect 4.0:

AnyConnect now supports TLS version 1.2 with the following additional cipher suites:

  • DHE-RSA-AES256-SHA256

  • DHE-RSA-AES128-SHA256

  • AES256-SHA256

  • AES128-SHA256


Note
 

AnyConnect TLS 1.2 requires a secure gateway that also supports TLS 1.2. This is available in release 9.3(2) of the ASA on 5500-X models.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: