Showing results for 
Search instead for 
Did you mean: 

Windows 10 Preview - SSL VPN Client

I know the official answer will be it's not supported... but here's the issue.


Installed Cisco AnyConnect client  v3.1.05182 on Windows 10 Preview. It installs just fine and the service is started. However, when attempting to connect we receive the error "Failed to initialize connection subsystem." And in the system logs we get..

Function: ConnectMgr::doConnectIfcConnect

File: .\ConnectMgr.cpp

Line: 1937

Invoked Function: ConnectMgr::getConnectIfc

Return Code: -29622267 (0xFE3C0005)



Any help with ideas/known resolutions would be great. We're suppose to evaluate this release for testing by Friday. I know quick.... :( 

Found an additional error....

Function: CTransportWinHttp::clearSSLCache

File: .\CTransportWinHttp.cpp

Line: 1784

Invoked Function: SslEmptyCache

Return Code: 13 (0x0000000D)


The error code above comes out to be MSG_E_CANNOT_GET_KEY_PROVIDER 



Function: CTransportWinHttp::InitTransport

File: .\CTransportWinHttp.cpp

Line: 284

Invoked Function: CTransportWinHttp::clearSSLCache

Return Code: -30015447 (0xFE360029)



LJ Gabrillo

Windows 10 is just a new release.
Cisco will for sure release an anyconnect software that will support win10 but as of now, it does not

With regards to your problems, well highly likely we cannot fix it, but just wait for a few weeks hopefully, Cisco will release it. 

This discussion has been reposted from Additional Communities to the VPN community.

Leo Laohoo
VIP Community Legend

Windows 10, the announcement, is just a few HOURS old.  I seriously doubt if anyone in Cisco has done any compatibility testing.

well yes we know... interesting thing is I just got it to connect. But after that session we are back to the empty SSL cache message. So it's probably fixable if I knew what exactly the error meant. So let's pretend it's not Windows 10 and it's Windows 8.1. What would cause the empty SSL cache message?


Look at the login at 6:08PM versus the later ones around 7:22PM.. Whats the issue?

While not a perfect answer, here is a workaround that I found on the Microsoft forums. I have not had a chance to do this yet, but it looks like it worked for the few people who were discussing it. I had the same issue you did, and also the same luck of it working once but not again, so I am looking forward to trying this out later today.

Rising star

It's going to take some time before AnyConnect catches up on preview releases of Windows.

It appears that you're comfortable living on the edge, so I'll suggest you give OpenConnect a try as a client alternative to see if it fits the bill until a working AnyConnect client is released for the platform.


I  have the same problem,wish cisco can resolve it as soon as possible,Thanks~


Configure Windows 8 compatibility mode for C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\vpnagent.exe. Restart "Cisco AnyConnect Secure Mobility Agent" windows service. It works for me.


I have not find the below solution myself but can confirm that it is working: I have Windows 10 Preview with CISCO AnyConnect Secure Mobile Client Version 3.1.05160.


1. Right click VPNUI in the Cisco install folder. (I have it in "C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\"

2. Choose Troubleshoot compatibility.

3. The wizard suggests win8 compatibility.

4. The "test program does not work" since the program may be running. Just add the configuration. (It did work for me)

5. Restart the VPN service. (No need for me, worked after the compatibility mode fix)

6. Start AnyConnect from the start meny.
7. Working.


Hi ,

If you have problem "Cisco VPN Client: Unable to Enable Virtual Adapter" with VPN Client. You must edit this registry subkey - 

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentSet\ControlSet001\Services\CVirta - right click on "Display Name"\Modify\ and then delete everything before "Cisco Systems VPN Adapter" in ""Value Data" box.

Thank you evanerwee your solution works for me.



This worked for me. Win10 Build 9841 with AnyConnect v3.1.03103


First, uninstall any Cisco VPN Client software you may have installed earlier;

Then uninstall any DNE updater software(s) you may have installed earlier;

Reboot your computer.

Run winfix.exe from citrix to ensure the DNE is properly cleaned up.

Reboot your computer again.

Install the SonicWall VPN software to get a version of DNE that works (DNE off citrix website did not work for me)

Reboot your computer.

Reinstall the Cisco VPN Client software again. (You do not need to uninstall the SonicWall VPN software. If you face a version check issue, run the msi file instead of the exe file

Configure the Cisco VPN Client

Change  registry key HKLM\SYSTEM\CurrentControlSet\Services\CVirtA\DisplayName.  Remove preceding "@oemX.inf,%CVirtA_Desc%” so the entry reads “Cisco Systems VPN Adapter for 64-bit Windows”

Reboot your computer.

Your Cisco VPN Client should now work in Windows 10!


I have done all steps that you mentioned above, however when I tried to install the VPN client, windows says that the app is not supported. Do you have any idea?

Content for Community-Ad