Showing results for 
Search instead for 
Did you mean: 

Configuration file updater from 7.5 to 8.5

Level 5
Level 5

Tried updating my S160 to whatever the version 8 is that is build 119 from installed 7.5 version.  System hung so I rebooted it.  Now its a paperweight.  Can't ever log in because it says to wait for the services but then it gives a traceback.  HDD led is lit constantly so I don't want to pull power again.


So I deployed a virtual appliance in my vmware infrastructure.  I'm trying to upload the config from my 7.5 physical appliance.  It keeps getting hung up on things like <default_gateway> is not allowed here, and stuff about password grace period not found before /password, and then it hangs on snmp stuff.  I'm at the point right now where I removed the snmp stuff and corrected all the other things its complaining about, but now its b*tching about periodic report recipients.  I'm thinking OMG what the ----.  Is there any tool that will just parse the file and update it to syntax that the virtual WSA 8.5 can handle?  Even if this is an evaluation, it would be nice to have working webfiltering while I wait for TAC to act on the case I opened on our physical S160.



4 Replies 4

Level 5
Level 5

I found a Cisco config migration utility but it doesn't work.

First error in the conversion process was this:

config_migration_tool:CRITICAL: Error in conversion: ERROR: Element 'prox_etc_dy
namic_send_win_size' not allowed here
  at Unknown:10774:37
  Text: 1</prox_et


So I removed that line in the file and then it created an updated xml.  I tried to upload the xml to the appliance and I still get this error.


Configuration File was not loaded. ERROR: Element 'account_policies' ended before required elements found (enable_password_grace) at Unknown:180:22 Text:

So its the same sh!t.  It moans and groans about the enable password grace, so I just throw on in there.  Next its b*tching about password_grace_period, so again I throw one of those in the xml.  Now its complaining with this:

Configuration File was not loaded. ERROR: Element 'community' not allowed here at Unknown:233:16 Text: ironport


This is just going to be an endless manual process with the end result that nothing will be left of the config!

Ok giving up (this was going nowhere), I pulled the power cord on the original S160 hardware appliance, then held the power button down in the front for 10 seconds to drain any residual charge in the power supplies capacitors, then plugged it back in.


Low and behold, the original physical appliance came back to life and I'm in its updated web gui now along with the new software version.  You can bet I'm going to save off a config to get a proper xml file for 8.5!

If the S160 has just been upgraded from say version 7 to version 8 and when ask to reboot the system hangs, this issue most likely that the appliance was having problem when copying across from upgraded partition to the primary or boot partition, this is quite often occurs in 1u appliances such as S160 or S170.

Hard rebooting by pressing the off button and wait for about 20 seconds then press the on button again most of the time will force the appliance to boot to the correct boot partition with upgraded version.