cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1464
Views
5
Helpful
13
Replies
Highlighted
Beginner

Unable to upgrade WSA S370 8.5.3-069

Current version 8.5.3-069

When upgrading from the it just fails.

When upgrading from the CLI I receive the following: "Upgrade image is invalid. Please check settings and try again" and I get an email with the following text: "Download and installation of upgrade image failed due to: The manifest checksum does not match the actual checksum for hints." This happens with all available updates - AsyncOS and RAID.

I've downloaded the manifest files and put them in local HTTP server, but I've got the same result.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Can you please try again?

View solution in original post

13 REPLIES 13
Highlighted
Cisco Employee

Hello ,

Which version you try to upgrade to?

What is the hardware model of the appliance (or paste here output of version command).

Can you also paste output fro mthe upgrade process via CLI?

Highlighted

Hi,

It is S370

Here is the output from the upgrade process:

login as: admin
Using keyboard-interactive authentication.
Password:
Last login: Thu Jul 21 11:21:38 2016 from x.x.x.x
AsyncOS 8.5.3 for Web build 069

Welcome to the Cisco S370 Web Security Appliance
s370> upgrade

Upgrades available.
1. AsyncOS 9.0.1 build 162 upgrade For Web, 2016-02-18, is a release available
for General Deployment
2. Update for RAID controller firmware (For S360/S370/S660/S670 only, reboot
required)
[2]> 2

Would you like to save the current configuration to the configuration directory
before upgrading? [Y]> y

Would you like to email the current configuration before upgrading? [N]> n

Choose the password option:
1. Mask passwords (Files with masked passwords cannot be loaded using
loadconfig command)
2. Encrypt passwords
3. Plain passwords
[1]> 2

Performing an upgrade may require a reboot of the system after the upgrade is
applied. You may log in again after this is done. Do you wish to proceed with
the upgrade? [Y]> y

Upgrade image is invalid. Please check settings and try again.
s370>

and this is the related email:

The Warning message is:

 

Download and installation of upgrade image failed due to: The manifest checksum does not match the actual checksum for hints.

 

Product: Cisco S370 Web Security Appliance

Model: S370

Version: 8.5.3-069

 

Highlighted

Can you share the output from 'version' command from CLI. Your RAID firmware version might already running the latest one and not require to perform the RAID firmware update anymore.

Highlighted

This is the output

Current Version
===============
Product: Cisco S370 Web Security Appliance
Model: S370
Version: 8.5.3-069
Build Date: 2016-01-15
Install Date: 2016-07-19 18:59:26
Serial #: 848F69E82EF9-8K72TW1
BIOS: 2.2.17C
RAID: 1.22.52-1909, 2.04.00, 1.02-015B
RAID Status: Optimal
RAID Type: 10
BMC: 1.85
Cisco DVS Engine: 1.0 (Never Updated)
Cisco DVS Malware User Agent Rules: 0.554 (Never Updated)
Cisco DVS Object Type Rules: 0.554 (Never Updated)
Cisco Trusted Root Certificate Bundle: 1.3 (Wed Aug  3 08:21:49 2016)
Cisco Certificate Blacklist: 1.3 (Wed Aug  3 08:21:49 2016)
L4 Traffic Monitor Anti-Malware Rules: 1470214648 (Wed Aug  3 12:22:06 2016)
Cisco Web Usage Controls - Web Categorization Engine: 3.0.0.046 (Wed Jul 20
00:25:05 2016)
Cisco Web Usage Controls - Web Categorization URL Keyword Filters: 1312487822
(Wed Jul 20 00:25:06 2016)
Cisco Web Usage Controls - Web Categorization Prefix Filters: 1470215266 (Wed
Aug  3 12:32:40 2016)
Cisco Web Usage Controls - Web Categorization Categories List: 1424380693 (Wed
Jul 20 00:25:07 2016)
Cisco Web Usage Controls - Dynamic Content Analysis Engine: 2.1.0-016 (Never
Updated)
Cisco Web Usage Controls - Dynamic Content Analysis Engine Data: 3.1.0.003 (Thu
Feb 11 12:01:43 2016)
Cisco Web Usage Controls - Application Visibility and Control Engine: 1.1.0-076
(Never Updated)
Cisco Web Usage Controls - Application Visibility and Control Data:
1.1.0.40-001 (Fri Jul 15 02:05:54 2016)
Web Reputation Engine: 3.0.0.046 (Wed Jul 20 00:25:05 2016)
Web Reputation IP Filters: 1470216021 (Wed Aug  3 12:32:40 2016)
Web Reputation Rules: 1469208401 (Fri Jul 22 21:12:10 2016)
Web Reputation Prefix Filters: 1470215266 (Wed Aug  3 12:32:40 2016)
Webroot Anti-Malware Engine: 2.1.5.8 (Never Updated)
Webroot Engine Definition: 2.1.5.8 (Never Updated)
Webroot Malware Categories DATs: 3476 (Wed Aug  3 12:28:47 2016)
Sophos Engine: 3.2.07.365.2_5.28 (Tue Jul  5 20:54:18 2016)
Sophos IDE: 2016080301 (Wed Aug  3 10:21:56 2016)

Highlighted

Your RAID firmware already using the latest one and you do not need to update it.

Below is your RAID firmware:

RAID: 1.22.52-1909, 2.04.00, 1.02-015B

If its still showing as 1.21.xx then the appliance will require to update the RAID firmware.

If you do not want for the appliance to show that RAID firmware update from the appliance available upgrade list, open a TAC case for them to de-provision it from your appliance serial number

Highlighted

We still can't upgrade the AsyncOS.

The "Download and installation of upgrade image failed due to: The manifest checksum does not match the actual checksum for hints." persists.

Highlighted

Can you please try again?

View solution in original post

Highlighted

Hello,

 AsyncOS 9.1.1 has been applied successfully and the device is pending reboot.

Thank you

Highlighted

Hi,

I also have this problem. Could you share what the cause of the problem was please?

How the problem got solved?

Highlighted

Unknown to me. I guess Cisco made a change on their side.

My suggestion is to open a support ticket.

Highlighted
Cisco Employee

can you share the appliance serial number for us to check in database whether it is valid or not. if we do not have records or not valid, you will not be able to upgrade at all.

Highlighted

Serial # is 848F69E82EF9-8K72TW1

Highlighted
Beginner

Hi,

I also have this problem. Could you share what the cause of the problem was please?

How the problem got solved?