ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
344
Views
0
Helpful
5
Replies
Highlighted

WSA S690 Login Issues

Hello team,

 

All of a sudden, we can't get access to our S690 Gui, running 11.8.1-023.

The error we are getting on the browser is: Error code 500: Server got its self in trouble. The application raised an exception.

 

We are also getting this critical alert via mail: 

The Critical message is:

 

An application fault occurred: ('egg/http_connector.py serve_forever|245', "<type 'exceptions.AttributeError'>", "'NoneType' object has no attribute 'listen'", '[_coro.pyx coro._coro._wrap1 (coro/_coro.c:8505)|757] [egg/http_connector.py serve_forever|245]')

 

I have never seen it before and my search doesn't get me any results.

Any idea what is going on?

 

We already tried kicking the proxy, restart https service, restart the appliance, using different browsers, clear cookies and cache. We even tried to connect via HTTP, but the login screen seems to be loading forever.

 

Thank you in advance.

Chrysostomos Tzouros

 

 

5 REPLIES 5
Highlighted

Re: WSA S690 Login Issues

We managed to find the root cause of the issue.

The problem occurred when we tried to add a module to dashboard.

We managed to get access to GUI. We can navigate to the menu except the dashboard and archived reports where we are getting the previously mentioned error.

 

Any suggestions on how to proceed?

 

 

Highlighted
Cisco Employee

Re: WSA S690 Login Issues

Hi Chrysostomos,

What module dod you add to trigger the issue? Could please you provide steps you did to trigger it?

Highlighted

Re: WSA S690 Login Issues

Hello, 

 

From reporting --> system status , we tried to add almost all modules (except from the ise one), by clicking the + icon (add to my dashboard).

 

Another maybe interesting fact is that the issue appears only with the admin account.

Every other account with admin rights or less don't face the issue.

Highlighted
Cisco Employee

Re: WSA S690 Login Issues

Thanks for the details.

 

I checked in the lab appliance and didn't face the issue. 

I think the best approach to address it would be to open a TAC case and check it from the backend - based on the appfault there might be a config parameter missing from the backend config file.

Highlighted

Re: WSA S690 Login Issues

Thanks for your reply and your time spent  :)

 

Me too, i tried to reproduce it in a lab VM but with no luck.

I will update the post, in case a solution is found  :)