Showing results for 
Search instead for 
Did you mean: 

How to Assign Static ip to lightweight Access Point (LAP) 1131AG before Registering to Controller (WLC)







WLC (Wireless LAN controller) is installed in corporate office with H-reap enabled so that remote office access point can be registered with corporate office controller. This AP was registered with WLC on different subnet and we have shifted this AP to other remote office and want to assign static IP address .


While assigning static IP address to remote site AP through console before registering to the controller, after login into the AP, we got the console with below name :


......MAC Address....>


but when we try any command to assign IP address , it shows the error "Command Disabled"




We can connect this AP to corporate office LAN and get registered with WLC and then through WLC GUI and can assign static IP address but we need solution to assign static IP before getting registered to WLC.


We Also tried the following command, but got error " Command disabled ":-



AP#lwapp ap ip address <IP address> <subnet mask>
AP#lwapp ap ip default-gateway <IP-address>
AP#lwapp ap controller ip address <IP-address>
AP#lwapp ap hostname <name>

By Default in LWAPP APs the config commands are disabled. We need to issue the command:-


"debug lwapp console cli"
"debug capwap console cli"

(depending on the version of the sw of the AP)


After this you can use the AP config as you would do in IOS APs.




There is one Bug CSCsy17745 filed for this issue. The workaround will be helpful to fix the issue:-


The command DEBUG LWAPP CONSOLE CLI is a HIDDEN command. Please enter the complete command and then you need to perform the work around mentioned in this Bug.



"lwapp ap" CLI always returns "ERROR!!! Command is disabled.".



When attempting to configure a lightweight AP using the "Ease of Deploy" CLI, i.e. the "lwapp ap" exec mode command, from the console, the following error is returned:


ERROR!!! Command is disabled.




The access point is running the lightweight IOS featureset (k9w8) or recovery image (rcvk9w8).


Workaround 1:


1. configure the AP to boot the recovery image:
ap#debug lwapp console cli (use "debug capwap console cli" if running 5.2 or above)
ap#dir flash:/ (look for a folder with "rcvk9w8" in its name)
ap#configure terminal
ap(config)#boot system flash:/c1250-rcvk9w8-mx/c1250-rcvk9w8-mx


2. disconnect the AP from the LAN (e.g. shutdown the switchport)

3. reload the AP

4. from the AP console, clear the LWAPP (CAPWAP) configuration:


ap#clear lwapp private-config


5. You can now enter the "lwapp ap" "Ease of Deploy" CLI commands.


Workaround 2:


1. Disconnect the AP from the LAN (e.g. shutdown the switchport)

2. ap#debug lwapp console cli (use "debug capwap console cli" if running 5.2 or above)

3. ap#write erase

4. ap#reload

5. After reloading, you can now use the "lwapp ap" (or "capwap ap")

"Ease of Deploy" CLI commands.


Workaround 3:


ap#test lwapp controller ip a.b.c.d [w.x.y.z] (or "test capwap controller")


More information:


Even with the resolution of this bug, the "capwap ap hostname" CLI is still disabled. See CSCtl96208.





how to assign static ip to lightweight Access Point 1131AG before registering to controller


Hello Vinay,

I have tried all the above commands and it worked but now it is showing an error of ERROR-3-CAPWAP ap does not have an ip address. I have tried giving an Ip address but still it goes on the DHCP server. I also have a DHCP server configured on the switch but still the AP is not getting the IP address. But if I connect the Laptop it gets the IP address. Can u address me how to resolve this issue???

I tried giving the IP address statically but still the AP is showing this error.

Pls find the attachment.

Thanks in advance..

Hey Vikas,

How did you end up resolving this issue?






I had to raise an RMA for the device..

Cisco TAC has recommended to do so...

But I think there must be a other solution to resolve this issue...

Can some1 provide me some other solution to it.






I have 300 ap's at Cisco WLC

I want to check box "static IP", can you help me with is?

you have cli command?

if yes, I running with prime.

tnx Lior

Content for Community-Ad