cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12100
Views
0
Helpful
14
Replies

How to config DHCP option 43 on win server 2008,2012

HI,

 

We plan to deployment a WLC+LAP,the WLC is 5520,we want to ap get ip address by dhcp,and get wlc's management interface by dhcp option 43.But,AP can get ip address,they cannot join WLC.Is there any error?The dhcp server config as below,and the wlc's management address is 10.10.2.200.

In my mind,win server 2008,2012 have different config,Do you know how to reslove it?

 

DU@4{XOLQ4P_SZH3_IDY8ZB.png

and there are some logs:

*Jul 24 03:11:42.103: %CDP_PD-4-POWER_OK: Full power - NEGOTIATED inline power source
*Jul 24 03:11:43.211: %LINK-6-UPDOWN: Interface Dot11Radio0, changed state to up
*Jul 24 03:11:44.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to up
*Jul 24 03:11:44.439: %LINK-6-UPDOWN: Interface Dot11Radio1, changed state to up
*Jul 24 03:11:45.439: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio1, changed state to up
Not in Bound state.
*Jul 24 03:12:27.047: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.
*Jul 24 03:12:30.119: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address 10.11.60.6, mask 255.255.254.0, hostname AP003a.7d5f.466c

Translating "CISCO-CAPWAP-CONTROLLER.uwcchina.org"...domain server (10.1.8.101)

*Jul 24 03:12:37.047: %CAPWAP-5-DHCP_OPTION_43: Controller address 10.10.2.200 obtained through DHCP
*Jul 24 03:12:42.111: %CDP_PD-4-POWER_OK: Full power - NEGOTIATED inline power source
Not in Bound state.
*Jul 24 03:13:23.551: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.
*Jul 24 03:13:26.623: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address 10.11.60.6, mask 255.255.254.0, hostname AP003a.7d5f.466c

Translating "CISCO-CAPWAP-CONTROLLER.uwcchina.org"...domain server (10.1.8.101)

*Jul 24 03:13:33.551: %CAPWAP-5-DHCP_OPTION_43: Controller address 10.10.2.200 obtained through DHCP
Not in Bound state.
*Jul 24 03:14:20.051: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.
*Jul 24 03:14:23.127: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address 10.11.60.6, mask 255.255.254.0, hostname AP003a.7d5f.466c

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !
1 Accepted Solution

Accepted Solutions

Alright,

 

I think you are missing the default gateway on the scope options. 

Can you add that? and test.

 

Regards,

Rafael 

Saludos,
Rafael - TAC

View solution in original post

14 Replies 14

Sandeep Choudhary
VIP Alumni
VIP Alumni

check this doc to enter or modify DHCP option 43:

 

https://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/97066-dhcp-option-43-00.html

 

Regards

Dont forget to rate helpful posts

OK,i will check ,thanks
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

Rafael E
Cisco Employee
Cisco Employee

Hello,

 

Few things:

  • your DHCP option 43 looks good
  • AP is getting the right IP address as per logs -  we are good here.
  • What code are you running? 
  • WHat AP model?
  • Are you getting the request into the WLC?

Monitor >> Statistics >> AP Join

  • If yes, then I would enable debug on the WLC to understand further
    • debug capwap event enable
    • debug capwap errores enable

 

Regards,

Rafael

 

Saludos,
Rafael - TAC

HI,

the third point,is the code of WLC or other?
the ap model is ap1702.and i cannot get request in wlc.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

Yes,  WLC Code?

If the request is not getting to the WLC, that is the problem.

  • Can you ping the WLC from the AP?
  • is there something in between WLC / AP blocking any traffic?

Rafael,

 

 

Saludos,
Rafael - TAC

yes.wlc run 8.5.131.0
and ap can ping wlc,there is not blocking traffic.If i config wlc's ip on ap,the ap also can join wlc.and then,if i make the dhcp server on core swith,it's also do well.So,i think it's possible dhcp server have some abnormal,but i can't find it.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

and the debug info as below:
Translating "CISCO-CAPWAP-CONTROLLER.uwcchina.org"...domain server (10.1.8.101)
*Jul 24 03:22:02.087: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:22:02.087: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:22:02.087: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:22:02.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:02.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:02.087: %CAPWAP-5-DHCP_OPTION_43: Controller address 10.10.
2.200 obtained through DHCP
*Jul 24 03:22:02.087: %CAPWAP-3-EVENTLOG: DNS Option IpAddr 10.1.8.101 SwitchName CISCO-CAPWAP-CONTROLLER.uwcchina.org
*Jul 24 03:22:03.087: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:22:03.087: %CAPWAP-3-EVENTLOG: Discovery Request sent to 255.255.255.255 with discovery type set to 0
*Jul 24 03:22:03.087: %CAPWAP-3-EVENTLOG: Send broadcast discovery request
*Jul 24 03:22:03.087: %CAPWAP-3-EVENTLOG: Failed to send packet to destination FF01::18C
*Jul 24 03:22:03.087: %CAPWAP-3-EVENTLOG: Discovery Request sent to FF01::18C with discovery type set to 0
*Jul 24 03:22:13.087: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:22:13.087: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:22:13.087: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:22:13.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:13.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:13.087: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:22:13.087: %CAPWAP-3-EVENTLOG: Send IPv4 Broadcast discovery request

*Jul 24 03:22:22.971: %CAPWAP-3-EVENTLOG: No changes in lwapp configs
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: Discovery Request sent to 255.255.255.255 with discovery type set to 0
*Jul 24 03:22:23.087: %CAPWAP-3-EVENTLOG: Send broadcast discovery request
*Jul 24 03:22:33.087: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:22:33.087: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:22:33.087: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:22:33.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:33.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:33.087: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:22:33.087: %CAPWAP-3-EVENTLOG: Send IPv4 Broadcast discovery request

*Jul 24 03:22:43.087: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:22:43.087: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:22:43.087: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:22:43.087: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
Not in Bound state.
*Jul 24 03:22:48.591: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.
*Jul 24 03:22:48.591: %CAPWAP-3-EVENTLOG: Discovery failed 5 times. Release/Renew DHCP
*Jul 24 03:22:48.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:48.591: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:22:48.591: %CAPWAP-3-EVENTLOG: Discovery Request sent to 255.255.255.255 with discovery type set to 0
*Jul 24 03:22:48.591: %CAPWAP-3-EVENTLOG: Send broadcast discovery request
*Jul 24 03:22:48.591: %CAPWAP-3-EVENTLOG: Failed to send packet to destination FF01::18C
*Jul 24 03:22:48.591: %CAPWAP-3-EVENTLOG: Discovery Request sent to FF01::18C with discovery type set to 0
*Jul 24 03:22:51.603: %CAPWAP-3-EVENTLOG: ADDING IP 10.11.60.6, 255.255.254.0 resolvemethod A, ip_dhcp_addr 1
*Jul 24 03:22:51.603: %CAPWAP-3-EVENTLOG: Teardown DTLS connection local port 62567
*Jul 24 03:22:51.603: %CAPWAP-3-EVENTLOG:
Engine id is set to 168508422

*Jul 24 03:22:51.603: %CAPWAP-3-EVENTLOG: ip_address_change: DCB updated: type-1, address-A0B3C06

*Jul 24 03:22:51.663: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address 10.11.60.6, mask 255.255.254.0, hostname AP003a.7d5f.466c

*Jul 24 03:22:51.663: %CAPWAP-3-EVENTLOG: ADDING IP 10.11.60.6, 255.255.254.0 resolvemethod A, ip_dhcp_addr 1
*Jul 24 03:22:51.663: %CAPWAP-3-EVENTLOG:
Engine id is set to 168508422

*Jul 24 03:22:51.663: %CAPWAP-3-EVENTLOG: ip_address_change: DCB updated: type-1, address-A0B3C06

Translating "CISCO-CAPWAP-CONTROLLER.uwcchina.org"...domain server (10.1.8.101)
*Jul 24 03:22:58.591: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:22:58.591: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:22:58.591: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:22:58.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:58.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:22:58.591: %CAPWAP-5-DHCP_OPTION_43: Controller address 10.10.
2.200 obtained through DHCP
*Jul 24 03:22:58.591: %CAPWAP-3-EVENTLOG: DNS Option IpAddr 10.1.8.101 SwitchName CISCO-CAPWAP-CONTROLLER.uwcchina.org
*Jul 24 03:22:59.591: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:22:59.591: %CAPWAP-3-EVENTLOG: Send IPv4 Broadcast discovery request

*Jul 24 03:23:02.971: %CAPWAP-3-EVENTLOG: No changes in lwapp configs
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: Discovery Request sent to 255.255.255.255 with discovery type set to 0
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: Send broadcast discovery request
*Jul 24 03:23:09.591: %CAPWAP-3-EVENTLOG: Failed to send packet to destination FF01::18C
*Jul 24 03:23:19.591: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:23:19.591: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:23:19.591: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:23:19.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:19.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:19.591: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:23:19.591: %CAPWAP-3-EVENTLOG: Send IPv4 Broadcast discovery request

*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: Discovery Request sent to 255.255.255.255 with discovery type set to 0
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: Send broadcast discovery request
*Jul 24 03:23:29.591: %CAPWAP-3-EVENTLOG: Failed to send packet to destination FF01::18C
*Jul 24 03:23:39.591: %CAPWAP-3-EVENTLOG: Could not discover any MWAR.
*Jul 24 03:23:39.591: %CAPWAP-3-EVENTLOG: Starting Discovery. Initializing discovery latency in discovery responses.
*Jul 24 03:23:39.591: %CAPWAP-3-EVENTLOG: CAPWAP State: Discovery.
*Jul 24 03:23:39.591: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:42.971: %CAPWAP-3-EVENTLOG: No changes in lwapp configs
Not in Bound state.q
*Jul 24 03:23:45.095: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.
*Jul 24 03:23:45.095: %CAPWAP-3-EVENTLOG: Discovery failed 5 times. Release/Renew DHCP
*Jul 24 03:23:45.095: %CAPWAP-3-EVENTLOG: spamResolveStaticGateway - gateway NOT found
*Jul 24 03:23:45.095: %CAPWAP-3-EVENTLOG: Could not resolve gateway. Not sending discovery request to 10.10.2.200, type 2
*Jul 24 03:23:45.095: %CAPWAP-3-EVENTLOG: Send IPv4 Broadcast discovery request
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

Alright,

 

I think you are missing the default gateway on the scope options. 

Can you add that? and test.

 

Regards,

Rafael 

Saludos,
Rafael - TAC

it's a must option?my meaning is gatway for ap?
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

Hi rafenriq ;Sandeep.
the issue have been resloved,the root reason is DHCP HA failed,and ap cannot get the gateway ip address.
thanks for your help.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

Agree with Rafael..

You must check the DHCP pool....agian and onfigure the DG

 

 

or try this:

 

AP#lwapp ap ip address <IP address> <subnet mask>
AP#lwapp ap ip default-gateway <IP-address>
AP#lwapp ap controller ip address <IP-address>

 

Regards

Dont forget to rate helpful posts

yes,i will do it next time.
and i have test it,if i config config capwap ap controller ip add <ip add>
the ap can join into the wlc.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

What happens if you console into the AP and enter the following command "capwap ap primary- <WLC name> <WLC management IP address>".

I have found the root reason,that is DHCP server HA failed.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !
Review Cisco Networking for a $25 gift card